Find the answer to your Linux question:
Results 1 to 9 of 9
I have a question. It is possible to take the internet from Ethernet card and expand it by the wireless card? I have 3 network card on my desktop PC, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167

    Talking expand from ethernet to wireless


    I have a question. It is possible to take the internet from Ethernet card and expand it by the wireless card?

    I have 3 network card on my desktop PC, 2 ethernet and 1 wireless. The internet came in my from one of the ethernet card, and i was wondering if it is possible to give the internet from my desktop to my laptop from wireless card. I hope you understand what i am saying!

    Cheers!
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    If I understand correctly, you want your desktop PC to act as a wireless access point? This is definitely possible. If you google there are many guides, or someone here might be able to help. It would help to know which distro you're running. Build A Linux-Based Wireless Access Point

  3. #3
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167
    Yes, I guess Acces Point it`s called I did on windows XP and worked fine! I didn`t know that this is possible I create a ad-hoc connection wich i connect to the laptop and then i made a bridge connection with ethernet. I don`t know how to do it on linux (opensuse 11.1).
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Not all wireless cards can be used as an access point. Take a look at this this list, is shows which work as an access point (AP).

    Drivers - Linux Wireless

    You will need to know more about your wireless device, especially the driver module. You can use this How-To as a guide to find that information.

    Wireless Setup - Srart Here

    The wireless would be set as an AP using the iwconfig command. It is referred to as master. For more info, read the iwconfig man pages.
    Code:
    man iwconfig
    Last edited by waterhead; 03-26-2009 at 10:24 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167
    Ok Paul, i have looked at the

    Drivers - Linux Wireless

    but i didn`t see my model there. But i`m sure it support AP too.

    I read you guide too "Wireless Setup" and my wireless card is on usb. The output from the lsusb:

    Code:
    Bus 004 Device 002: ID 0b05:1742 ASUSTek Computer, Inc. 802.11n Network Adapter
    The result of the command

    Code:
    $ dmesg | grep firmware
    doesn`t return anything so i guess i don`t have any firmware errors.

    What i am sure it use it the "rt2870sta" kernel module. It is a ralink one.

    What i have found in dmesg:

    Code:
    $ dmesg | grep rt2870sta
    rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
    The kernel version is

    Code:
    $ uname -r
    2.6.27.19-3.2-pae
    I am using opensuse 11.1 and my motherboard is P5E3 Premium.

    This module rt2870sta is loaded at boot, but i can`t found any configuration file that i can use to configure this card. In yast it doesn`t show this card, i have tried to add it by my self but no luck.

    Here it is the info about the module:

    Code:
    $ modinfo rt2870sta
    
    filename:       /lib/modules/2.6.27.19-3.2-pae/kernel/drivers/staging/rt2870/rt2870sta.ko
    version:        1.4.0.0
    license:        GPL
    description:    RT2870 Wireless Lan Linux Driver
    author:         Paul Lin <paul_lin@ralinktech.com>
    srcversion:     82010C1E34C5083BC0E159F
    alias:          usb:v0789p0164d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0789p0163d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0789p0162d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v5A57p0282d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v5A57p0280d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v7392p7711d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07B8p2770d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07B8p2870d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07B8p3071d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07B8p3070d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v04E8p2018d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v14B2p3C09d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v1482p3C09d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v050Dp805Cd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v157Ep300Ed*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v129Bp1828d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0E66p0003d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0E66p0001d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v15C5p0008d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v083Ap6618d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v13D3p3247d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v14B2p3C25d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0471p200Fd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v1740p9702d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v1740p9701d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0CDEp0025d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0586p3416d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0CDEp0022d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v083Ap7522d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v083ApA618d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v083ApB522d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v15A9p0006d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v1044p800Bd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v18C5p0012d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07AAp003Fd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07AAp003Cd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07AAp002Fd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v14B2p3C27d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v14B2p3C23d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v050Dp8053d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v14B2p3C12d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v14B2p3C07d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07D1p3C11d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v07D1p3C09d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v2019pAB25d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v2019pED06d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v14B2p3C28d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v14B2p3C06d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0DF6p002Dd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0DF6p002Cd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0DF6p002Bd*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0DF6p0017d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0B05p1742d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0B05p1732d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v0B05p1731d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v148Fp3070d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v148Fp2870d*dc*dsc*dp*ic*isc*ip*
    alias:          usb:v148Fp2770d*dc*dsc*dp*ic*isc*ip*
    depends:        usbcore
    staging:        Y
    vermagic:       2.6.27.19-3.2-pae SMP mod_unload modversions 586 
    parm:           mac:rt28xx: wireless mac addr (charp)
    If you need other information i will post.
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

  7. #6
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167
    What i found recently is a new driver version 2.1. The driver that i use now is 1.4.0.0 as you can see in the modinfo.

    Another thing that i found in the README driver is

    Code:
    Features:
    ==========
       This driver implements basic IEEE802.11. Infrastructure and adhoc mode with 
       open or shared or WPA-PSK or WPA2-PSK authentication method. 
       NONE, WEP, TKIP and AES encryption.
    so it`s support ad-hoc mode

    I will install the latest driver i will tell you what i have done.

    Cheers!
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

  8. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Please post the output of this command
    Code:
    lsmod
    It will show all modules loading on your system.

    Your wireless is supported by the rt2x00 family of drivers. More specifically the rt2800usb driver. This is a relatively new driver, and may not be fully functional, yet. You can try the latest version from the GIT repository, but it looks pretty complicated.

    Rt2x00 GIT instructions - Rt2x00Wiki

    You could instead try the Ralink supplied driver. I believe that is the one called rt2870sta.

    Ralink Technology: Linux

    You could also install the latest compat-wireless package, from the Linuxwireless.org site. This is most likely the easiest option.

    Download - Linux Wireless

    Before doing anything, have you tried changing the mode to Master?

    Code:
    iwconfig ra0 mode Master
    
    or this
    
    iwconfig ra0 mode Ad-Hoc
    Edit: I see you posted while I was writing this, so I see that you know about the ralink driver. Make sure you also download and install the firmware.
    Last edited by waterhead; 03-26-2009 at 10:37 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #8
    Linux Newbie bobescalin2005's Avatar
    Join Date
    Oct 2005
    Posts
    167
    I installed the latest version, and i use this tutorial. It seems to be working but i have not tried to connect to a wireless network. I will try this days.

    The firmware doesn`t let me to install it.

    Code:
    ./rt2870.bin 
    bash: ./rt2870.bin: cannot execute binary file
    i made it executable first.

    Now how can i bridge those to connection my wireless and my ethernet? Is there any command to bridge two networks?

    Cheers!
    Registered Linux user #471256
    http://counter.li.org
    Don`t give up so easy...
    calin

  10. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I think that the Ralink driver may already have the firmware included. The firmware file is not "run", but simply copied to the /lib/firmware folder.

    I never attempted to do what you are trying, so I can't help much.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •