Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, this is my first post! I just started using BackTrack 3 and I'm having a very difficult time getting it to recognize my new Wi-Fire (by hfield) USB wireless ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    3

    BT3 wont detect Wi-Fire


    Hello, this is my first post!

    I just started using BackTrack 3 and I'm having a very difficult time getting it to recognize my new Wi-Fire (by hfield) USB wireless internet adapter. I'm pretty sure it's compatable but I dont have any luck:\. Any help would be great!

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Hello and welcome. Please start here for wireless troubles: http://www.linuxforums.org/forum/wir...tart-here.html

    The biggest thing we need to know first is the output of lsusb

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    3
    So i upgraded to BT4 because apparently BT3 uses a kernal version too low for my device. Still no dice. Here is all the important information. Am i missing any drivers or modules?

    it definitely detects it at device 3, I'm just not sure if I'm missing anything.

    Code:
    kernal version
    2.6.28.1
    
    
    lsusb
    root@bt:~# lsusb
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0cde:001a Z-Com ZD1211B
    Bus 001 Device 002: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 2.0 USB Stick (4GB)
    
    
    dmesg
    root@bt:~# dmesg
    
    zd1211rw 1-3:1.0: phy1
    -a lot came before this, but i figured this is the important stuff...
    usbcore: registered new interface driver zd1211rw
    lp: driver loaded but no devices found
    ip_tables: (C) 2000-2006 Netfilter Core Team
    ACPI: WMI: Mapper loaded
    sky2 eth0: enabling interface
    NET: Registered protocol family 10
    lo: Disabled Privacy Extensions
    ADDRCONF(NETDEV_UP): eth0: link is not ready
    [drm] Initialized drm 1.1.0 20060810
    pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    pci 0000:00:02.0: setting latency timer to 64
    [drm] Initialized i915 1.6.0 20080730 on minor 0
    usbcore: deregistering interface driver zd1211rw
    usb 1-3: reset high speed USB device using ehci_hcd and address 3

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You most likely need to install firmware. Read more about it here:

    zd1211rw - Linux Wireless
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Apr 2009
    Posts
    3
    I believe I already have the firmware. It comes installed with BT4 I believe. I tried copying the new firmware and overwriting the old one, but still no luck.

    lsmod shows zd1211rw module to be running.

    I'm using KNetworkManager to manage my connections. The version that came with BT4. Should I be using something else?

    Sorry I'm pretty new to linux so let me know if you need to know anything more!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •