Find the answer to your Linux question:
Results 1 to 2 of 2
running debian lenny. ive downloaded the compat-wireless tar file but dont know how to proceed after. I have read the build and install insructions on linuxwireless but I can't even ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    3

    wireless driver install


    running debian lenny.

    ive downloaded the compat-wireless tar file but dont know how to proceed after.
    I have read the build and install insructions on linuxwireless but I can't even begin to un-tar it. I have a problem navigating to the downloaded folder, which is to my desktop.

    In terminal I will do wizkid@wizkid2:~$ cd /wizkid's home/desktop
    >
    I know this is wrong. please help.




    uname -r
    2.6.26-2-686



    lspci -nn

    00:00.0 Host bridge [0600]: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] [1002:cbb2] (rev 02)
    00:01.0 PCI bridge [0604]: ATI Technologies Inc PCI Bridge [IGP 340M] [1002:7010]
    00:06.0 Multimedia audio controller [0401]: ALi Corporation M5451 PCI AC-Link Controller Audio Device [10b9:5451] (rev 02)
    00:07.0 ISA bridge [0601]: ALi Corporation M1533/M1535/M1543 PCI to ISA Bridge [Aladdin IV/V/V+] [10b9:1533]
    00:08.0 Modem [0703]: ALi Corporation M5457 AC'97 Modem Controller [10b9:5457]
    00:09.0 Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 02)
    00:0a.0 CardBus bridge [0607]: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus Controller [1217:6972]
    00:0b.0 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 50)
    00:0b.1 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 50)
    00:0b.2 USB Controller [0c03]: VIA Technologies, Inc. USB 2.0 [1106:3104] (rev 51)
    00:0c.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link) [104c:8026]
    00:10.0 IDE interface [0101]: ALi Corporation M5229 IDE [10b9:5229] (rev c4)
    00:11.0 Bridge [0680]: ALi Corporation M7101 Power Management Controller [PMU] [10b9:7101]
    00:12.0 Ethernet controller [0200]: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller [100b:0020]
    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon IGP 330M/340M/350M [1002:4337]


    dmesg | grep firmware


    [ 29.220044] firmware: requesting b43legacy/ucode4.fw
    [ 29.408850] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 32.504058] firmware: requesting b43legacy/ucode4.fw
    [ 32.515680] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 49.896051] firmware: requesting b43legacy/ucode4.fw
    [ 49.904760] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 67.512111] firmware: requesting b43legacy/ucode4.fw
    [ 67.520103] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 85.020061] firmware: requesting b43legacy/ucode4.fw
    [ 85.032592] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 102.472082] firmware: requesting b43legacy/ucode4.fw
    [ 102.484402] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 119.912125] firmware: requesting b43legacy/ucode4.fw
    [ 119.920759] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 137.316149] firmware: requesting b43legacy/ucode4.fw
    [ 137.325108] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 154.732053] firmware: requesting b43legacy/ucode4.fw
    [ 154.740954] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 277.188051] firmware: requesting b43legacy/ucode4.fw
    [ 277.197175] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 399.592056] firmware: requesting b43legacy/ucode4.fw
    [ 399.601690] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 521.964041] firmware: requesting b43legacy/ucode4.fw
    [ 521.973310] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 644.332054] firmware: requesting b43legacy/ucode4.fw
    [ 644.341806] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 766.728178] firmware: requesting b43legacy/ucode4.fw
    [ 766.739796] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 889.176085] firmware: requesting b43legacy/ucode4.fw
    [ 889.214468] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 1011.644191] firmware: requesting b43legacy/ucode4.fw
    [ 1011.654493] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 1134.212539] firmware: requesting b43legacy/ucode4.fw
    [ 1134.220229] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 1256.832114] firmware: requesting b43legacy/ucode4.fw
    [ 1256.842587] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 1379.269112] firmware: requesting b43legacy/ucode4.fw
    [ 1379.278579] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 1501.688497] firmware: requesting b43legacy/ucode4.fw
    [ 1501.701024] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 1624.108043] firmware: requesting b43legacy/ucode4.fw
    [ 1624.120674] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).
    [ 1746.680042] firmware: requesting b43legacy/ucode4.fw
    [ 1746.710385] b43legacy-phy0 ERROR: You must go to b43 - Linux Wireless and download the correct firmware (version 3).

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You don't need to upgrade the driver, your kernel should already have a very recent version.

    What you do need is to install firmware for it to work. I don't know if Debian has it available in a package, like Ubuntu does. Otherwise you will have to do a manual install.

    b43 - Linux Wireless

    Maybe you can find and use a Ubuntu .deb package. I have made a .rpm package for Fedora and RHEL, that contains the firmware. If you can unpack it, then you can use the firmware in it.

    http://www.linuxforums.org/forum/att...5-0.noarch.rpm

    You can convert it with the alien command
    Install .rpm Files in Debian and Ubuntu -- Debian Admin
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •