Find the answer to your Linux question:
Results 1 to 8 of 8
I installed drivers for my Broadcom wireless card from the Hardware Drivers utility. However, it seems that my connection drifts in and out frequently, locking up downloads and just being ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    8

    Spotty wireless connection


    I installed drivers for my Broadcom wireless card from the Hardware Drivers utility. However, it seems that my connection drifts in and out frequently, locking up downloads and just being generally annoying. It doesn't seem to be a problem with the router. Has anyone else had this problem?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,448
    I've seen this happen when the access point you are connecting to is using the same channel as another access point that is within range of your system. Try changing the channel - which you can do via the router/ap's web page. I had to do that at home - we have 2 access points and there are several neighbors with reachable access points, so I changed ours to use less-frequently configured channels and these problems have disappeared.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    8
    How do I do that exactly? Whats the setting that I would be changing to change the router to a different channel?

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,448
    You need to login to your router/ap and change the channel there. Your laptop's wireless will detect the new channel and use that. There are 11 channels on an 802.11g wireless network. I think the default is 6, though I might be incorrect on that. I've set my business network on 1 to avoid conflicts with our home and neighbors' networks.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    May 2009
    Posts
    8
    So are you saying there should be a setting simply called "Channel"?

    I'm running an N router thats supposedly backwards compatible with G adapters. My adapter is a G.

    I found the channel function, but changing the channel doesn't seem to be solving the problem.

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,448
    Is your laptop an 802.11n or an 802.11g device? And do you have the same problem with other access points?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Just Joined!
    Join Date
    May 2009
    Posts
    8
    My device is a 802.11g. Supposedly my router is backwards compatible, but it's crossed my mind that it might be a factor. I have only tried one other access point, using the same router, and that access point would kick me out after 30 seconds and wouldn't let me back in after a restart.

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,448
    Have you considered that your Broadcom card might be defective? Have you run diagnostics on the card (assuming you can get them)?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •