Find the answer to your Linux question:
Results 1 to 4 of 4
Hi I have just bought a linskys WUSB54GC wireless adapter I was`advised (by a freind and on forum sites) that this would be upto running all of the features of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    3

    rt73 driver on BackTrack 3


    Hi I have just bought a linskys WUSB54GC wireless adapter I was`advised (by a freind and on forum sites) that this would be upto running all of the features of BT3 provided I install the rt73 drivers.
    A problem has come up in that when I attempt to build the driver :

    Code:
    bt ~ # cd rt73-k2wrlz-2.01/Module
    bt Module # make
    I get a message saying: /lib/modules/2.6.21.5/build does not exist. I used the file browser program to navigate to /2.6.21.5 and sure enough it says build appears to no longer exist (does display a file type icon with a padlock on top though).
    I tried to create such a directory but no joy. After this I searched the BT support forum for help and found a post advising me to locate something called kernel.lzm. I navigated to "/" and ran a search:

    Code:
    bt / # find / -name kernel.lzm
    this returned no results. I have done a HD installation but I've tried this on the live cd aswell with no luck.
    can someone help pls
    thx

    PS
    I seem to be missing something is it possible I have a bad copy of BT3?

    ---Update---
    --------------------------------------------------------------------------------

    I was advised to download a newer version of the driver rt73-k2wrlz-3.0.1.tar but same thing again. Made a directory called build in the right location but now when i try make I get a message saying:

    Code:
    make[1]: Entering directory '/lib/modules/2.6.21.5/build'
    make[1]: *** No rule to make target 'modules'. Stop.
    make[1]: Leaving directory '/lib/modules/2.6.21.5/build'
    rt73.ko failed to build!
    make: *** [module] Error 1

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You need the kernel source and kernel headers installed.

    It looks like the BT3 distro is old, and uses and older kernel (2.6.21). The current stable kernel is 2.6.29.3. If you want good wireless support, get a more modern distro like Ubuntu, Suse or Fedora.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    3
    Sadly not an option. As you may know BT4 is now available but I'm working towards taking the training packages supplied by Offensive Security (the developers of Backtrack) to get up to speed quickly, and the training is based around BT3. I use UBUNTU as my main OS and this problem doesn't occur in that OS.

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Then, like I said, install the kernel headers and kernel source for your kernel version
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •