Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Hello, I am trying to set-up my wireless card. I am running Kubuntu 9.04 (kernel 2.6.28.11. The card I have, according to the lspci command I am using Broadcom BCM4313 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    28

    Wireless Configuration


    Hello, I am trying to set-up my wireless card. I am running Kubuntu 9.04 (kernel 2.6.28.11. The card I have, according to the lspci command I am using Broadcom BCM4313 Network Card. I went to this site to locate drivers because I am able to see my wireless device, connect, but I cannot do anything on any websites. Here is my driver: broadcom.c_m / support/802.11/linux_sta.php

    I burned the disk with my other 64-Bit computer in mind, so my distro is 64-bit.

    I ran lsmod and dmesg, but I didn't see anything related to my wireless device.

    I believe this is all the information that the post asked, but if you need more, please feel free to ask. I have attached my LSPCI file.


    Thanks for any help.
    Attached Files Attached Files

  2. #2
    tpl
    tpl is offline
    Linux User
    Join Date
    Jan 2007
    Location
    cleveland
    Posts
    476
    the sun is new every day (heraclitus)

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    28
    Quote Originally Posted by tpl View Post
    this looks like a helpful site:

    Broadcom 802.11 Linux STA driver[/url]
    That's why I linked to it. The text file that had instructions on how to run the driver didn't work for me. When created the directory I ran the install on that directory and it said error because the directory didn't exist or something like that. Maybe you can explain the steps involved better to create the LKM?

  4. #4
    Just Joined!
    Join Date
    May 2009
    Posts
    28
    I was using this site - h__p://linuxwireless.o_g/en/users/Drivers/b43#firmwareinstallation (.org), and I can see that I am connected to my wireless router, BUT I cannot visit any websites. Can someone help?

  5. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I believe 9.04 comes with the driver you linked to installed. I know you said dmesg and lsmod didn't contain anything useful, but please do post them. Enclose the output is [code] tags as described in that link.

    One option is to remove the Broadcom STA driver, and use the open source b43 driver. Ubuntu will have the driver already installed, but you need to the firmware as well. If you have a wired connection, download the b43-fwcutter package to get the firmware. More info here.

    Note that the b43 driver should be blacklisted, so it won't interefere with the current driver; if you decide to use it, you'll need to remove it from the list at /etc/modprobe.d/blacklist

  6. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Maybe I can explain this in detail.

    There are actually two Linux drivers for Broadcom wireless chips. One is developed as a completely open-source driver, and includes the b43/b43legacy drivers. The other was developed by Broadcom, and is not open-source. It contains the wl driver. They cover different wireless chips, so there really isn't much overlapping, except for one card. That wireless is the 4312 wireless.

    Your wireless card (4312) seems to be one of the overlapping ones. There is no predicting which driver Ubuntu is loading for the card, so we need the outputs of lsmod and dmesg. It may even be loading both drivers, so that would keep it from working.

    I would suggest using the Broadcom STA driver (wl) for this card, and removing and blacklisting the b43 driver.
    Last edited by waterhead; 05-17-2009 at 11:43 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #7
    Just Joined!
    Join Date
    May 2009
    Posts
    28
    Can you tell me how to copy my output? I'm a bit new to Linux, so I am not sure of the commands.

    Another board suggested I run this:

    Code:
    echo 'deb h__p://apt.wicd.n_t hardy extras' | sudo tee -a /etc/apt/sources.list
    wget -q h__p://apt.wicd.n_t/wicd.gpg -O- | sudo apt-key add -
    sudo apt-get update
    sudo apt-get install wicd
    And, I got the wicd manager, but when I try to connect, I type in the router password and press connect. It works fine, then it gets stuck on "Obtaining IP address" Any idea why? I know the wireless works because I am on it now. Maybe there is a manual way I can do this?

    I tried to do a static IP, but it stopped at "Validating Authenticity." I thought that may have solved it, but no go.

    I'll look get the outputs of lsmod and dmesg. Thanks for the help and suggestions.

  8. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Read this stickied post for a How-To:

    http://www.linuxforums.org/forum/wir...tart-here.html
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #9
    Just Joined!
    Join Date
    May 2009
    Posts
    28
    Here are lspci.txt, dmesg.txt, and lsmod.txt.

    If you need me to get anything else, please say so.
    Attached Files Attached Files

  10. #10
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    You have eth0 running b44 driver, (that would be wired internet) and wl driver for the wireless, according to dmesg and modprobe.. Maybe disable wl and enable b43 driver to see if that allows it to work.
    Registered Linux User #420832

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •