Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
Hi All,,, i have installed oracle enterprise linux 5.3, and my laptop has intel wifi 5100 wireless card which is not active. i have tried ndiswrapper 1.54 everything was installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    8

    Intel wifi 5100 AGN + Oracle Enterprise Linux=no internet/network connection


    Hi All,,,

    i have installed oracle enterprise linux 5.3, and my laptop has intel wifi 5100 wireless card which is not active.
    i have tried ndiswrapper 1.54 everything was installed fine,,,,when i type "ndiswrapper -l"...
    it displays device present,,,but still my wireless card is not active,,,although it scans the wireless networks when i issue "iwlist wlano scan" command..

    output of ndiswrapper -l command:
    netw5v32:driver installed
    device (8086:4243) present (alternate driver: iwlagn)

    I have dual boot,,,Windows Vista and Oracle Enterprise Linux 5.3....
    wireless card works very fine with Vista,,,,with linux it never works....
    I have WEP enabled on my wireless network......
    Linux kernel is 2.6.18.....so i downloaded the concerned microcode and copied it into /lib/firmware as directed in the readme file....

    now the wierd thing happening is....that with auto settings like essid:auto mode:auto etc...it connects to some wireless network which does not have key on....that means the card is detected and is capable of connecting to wireless networks..

    It does not connect to my home wireless network.....
    when i gave my home network essid,rate,access point info in /etc/sysconfig/network-scripts/ifcfg-wlan0 ........ at the time of bringing up wlan0 ,,,it says....determining ip information for wlan0....failed.....when i give it static ip....it gets active upon activating but still no internet connection.

    when i issue iwconfig wlan0 , it says access point not associated.

    please help....thanks

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,596
    Look at Welcome - Linux Wireless for better instructions how to deal with these sort of issues. Besides the driver, you also need the device firmware. The link provided has instructions how to get and install the firmware for most wireless devices available. I haven't looked for this particular chip set, but it is likely there.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    8
    thanks for replying...
    i have already applied the firmware for the card......the only thing is, it is not connecting to my home wireless network.....which has WEP enabled......it does connect to other wireless network which does not have key on,,,,that means that the driver and the device are working fine.....
    thanks....

  4. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome.
    I'd say set it up like you had it:
    when i gave my home network essid,rate,access point info in /etc/sysconfig/network-scripts/ifcfg-wlan0 ........ at the time of bringing up wlan0 ,,,it says....determining ip information for wlan0....failed.....when i give it static ip....it gets active upon activating but still no internet connection.
    Give the static IP and then run your dhcp command on the device. I've never used OE Linux so I don't know the exact command name but it should be something like this, as root or sudo:
    Code:
    dhcpd wlan0
    If you get no errors then try connecting your browser to google or somewhere.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  5. #5
    Just Joined!
    Join Date
    May 2009
    Posts
    8
    Hi MikeTbob,,,,,
    now the only issue i m left with is.....
    my card is detected..and when i configure it to have essid, rate, mode etc as Auto in network Manager.....it connects to unsecure wireless network and i can browse internet,,,,,i have WEP enabled on my home wireless network...so it does not connect to the WEP enabled networks......can you please tell me how to get it to connect to my home network....btw Oracle Linux is nothing but the copy of Redhat 5...
    thanks ,,,any help wud be appreciated....

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    So did you try to connect, like you said? By setting the static IP and then use your DHCP command on it? Any results?
    Is there any way that you can disable WEP until you get this sorted out?
    Last edited by MikeTbob; 05-18-2009 at 06:03 PM. Reason: Type-O's
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Just Joined!
    Join Date
    May 2009
    Posts
    8
    hi there,,,,
    i gave it static ip 192.168.1.35 and ran the command dhclient wlan0,,,,it says DHCPACK from 192.168.1.1
    bound to 192.168.1.102----renewal in 39752 seconds..
    and i set all the parameters (essid, rate, mode ,,key:off) and now it is connected to some unsecure network,,,with no key...but i want it to connect to my home network...i m sure if i disable my WEP key,,,then it will connect to my home network too,,,but what cud be the problem with WEP?
    thanks

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,596
    Ok. Have you installed WPA_supplicant? I don't know if it will help with WEP connections, but it is necessary for WPA ones. And you are correct, that the driver and firmware are functional. If you look at the web site for linux wireless networking that I posted in my previous message, you will find that some chip sets don't have wep/wpa support. I don't know why, but that is the case in some instances.

    One other thing I have found in the past with Ubuntu, is to connect specifically to the ssid using "hidden networks" in the connection manager. That has brought up the password request form a couple of times when just connecting to the ssid would not.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  9. #9
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I'm not entirely sure what the problem is, I do know in some programs like WifiRadar, you have to prepend a 0x in front of the WEP key to signify that it is a hex key.
    Does Networkmanager give you this option?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #10
    Just Joined!
    Join Date
    May 2009
    Posts
    8
    yes MikeTbob....i have to append 0x with my wep key........
    i dont know what i m gonna do.....

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •