Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
Rebooting was the first thing I tried after nothing came up. I didn't follow a guide, I folled the instructions in the ndiswrapper readme. When the wlan0 still didn't work, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    May 2009
    Posts
    9

    Rebooting was the first thing I tried after nothing came up. I didn't follow a guide, I folled the instructions in the ndiswrapper readme. When the wlan0 still didn't work, I then started looking up various solutions. One of them suggested blacklisting ssb. But I've undone everything from ndiswrapper, including deleting ssb from the blacklist. lsmod still doesn't show b43 as running.

    Code:
    [root@localhost Cake]# lsmod
    Module                  Size  Used by
    fuse                   49436  2 
    bridge                 43796  0 
    stp                     6148  1 bridge
    bnep                   14848  2 
    rfcomm                 33936  4 
    l2cap                  21504  16 bnep,rfcomm
    bluetooth              48608  5 bnep,rfcomm,l2cap
    sunrpc                156052  3 
    ipt_REJECT              6656  2 
    nf_conntrack_ipv4      11528  7 
    iptable_filter          6528  1 
    ip_tables              13840  1 iptable_filter
    ip6t_REJECT             7296  2 
    xt_tcpudp               6656  12 
    nf_conntrack_ipv6      15864  7 
    xt_state                5888  14 
    nf_conntrack           51424  3 nf_conntrack_ipv4,nf_conntrack_ipv6,xt_state
    ip6table_filter         6400  1 
    ip6_tables             14736  1 ip6table_filter
    x_tables               15236  6 ipt_REJECT,ip_tables,ip6t_REJECT,xt_tcpudp,xt_state,ip6_tables
    cpufreq_ondemand        9868  1 
    powernow_k8            18692  0 
    loop                   17164  0 
    dm_multipath           17292  0 
    scsi_dh                 9476  1 dm_multipath
    radeon                119172  2 
    drm                   146276  3 radeon
    ipv6                  230644  24 ip6t_REJECT,nf_conntrack_ipv6
    snd_atiixp             18828  3 
    snd_seq_dummy           6660  0 
    8139cp                 21504  0 
    snd_atiixp_modem       15496  0 
    snd_ac97_codec         95140  2 snd_atiixp,snd_atiixp_modem
    ac97_bus                5504  1 snd_ac97_codec
    snd_seq_oss            30492  0 
    pcspkr                  6272  0 
    snd_seq_midi_event      9600  1 snd_seq_oss
    snd_seq                48576  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    joydev                 12736  0 
    snd_seq_device          9996  3 snd_seq_dummy,snd_seq_oss,snd_seq
    snd_pcm_oss            42496  0 
    snd_mixer_oss          16896  1 snd_pcm_oss
    snd_pcm                65924  4 snd_atiixp,snd_atiixp_modem,snd_ac97_codec,snd_pcm_oss
    8139too                24708  0 
    yenta_socket           24972  1 
    rsrc_nonstatic         13696  1 yenta_socket
    snd_timer              22024  2 snd_seq,snd_pcm
    k8temp                  7936  0 
    hwmon                   6300  1 k8temp
    mii                     8192  2 8139cp,8139too
    snd                    50744  17 snd_atiixp,snd_seq_dummy,snd_atiixp_modem,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
    soundcore               9416  1 snd
    snd_page_alloc         11016  3 snd_atiixp,snd_atiixp_modem,snd_pcm
    sr_mod                 17064  0 
    cdrom                  32792  1 sr_mod
    video                  20496  0 
    output                  6528  1 video
    wmi                     9640  0 
    mos7720                20484  0 
    i2c_piix4              12688  0 
    usbserial              30252  1 mos7720
    sg                     31156  0 
    i2c_core               21396  2 drm,i2c_piix4
    dm_snapshot            19364  0 
    dm_zero                 5632  0 
    dm_mirror              19968  0 
    dm_log                 12164  1 dm_mirror
    dm_mod                 48692  10 dm_multipath,dm_snapshot,dm_zero,dm_mirror,dm_log
    pata_acpi               7680  0 
    ata_generic             8452  0 
    pata_atiixp             8320  2 
    libata                135148  3 pata_acpi,ata_generic,pata_atiixp
    sd_mod                 32668  3 
    scsi_mod              123772  5 scsi_dh,sr_mod,sg,libata,sd_mod
    crc_t10dif              5632  1 sd_mod
    ext3                  109192  2 
    jbd                    43284  1 ext3
    mbcache                10244  1 ext3
    uhci_hcd               23312  0 
    ohci_hcd               24336  0 
    ehci_hcd               33164  0

  2. #12
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Manually load the b43 driver, and see if the wireless works.
    Code:
    modprobe b43
    You may first need to set it up. Open the Network program with this command.
    Code:
    system-config-network
    Click on the wireless, then the "Edit" icon. Make sure you check the boxes for
    "Controlled by NetworkManager"
    "Allow all users to enable and disable the device"
    "Automatically obtain IP address with: dhcp
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #13
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Opened up system config network, b43 showed up in hardware. Those options were checked when I edited it. I restarted the network devices, wlan0 still shows up as inactive, with no way to make it active.

  4. #14
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Since this card didn't work with either NDISwrapper or b43, something out-of-the-ordinary is wrong here. The fact that it didn't automatically load the b43 driver is unusual.

    If this is a built-in wireless on a laptop, there may be an on/off switch or keyboard shortcut keys (Fn + Fx). This did not work too good in older versions of Linux, and could be fixed by using a version with a newer kernel.

    If this is a PCI card in a desktop, try removing it from the slot and then reinserting it. It may not be fully inserted into the PCI slot, or the slot could be dirty.

    Also post the entire output of this command.
    Code:
    dmesg
    The output is very large. If you need to transfer this file to a Windows PC to post it, you can directly output it as a text file.
    Code:
    dmesg > dmesg.txt
    The text file can then be found in your home folder.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #15
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Interesting. Not once did I think about that, because the light never came on, orange or blue. I will be sure to try that when I get home. If that's the case, I'm going to kick myself soooo hard.

  6. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    One other that is worth a try. If you can't upgrade to the newest kernel, you can always just install the latest wireless drivers. You can download the source package from here.

    Download - Linux Wireless

    This requires a kernel >= 2.6.22. You will be compiling the driver modules. so you should have these programs installed first:

    kernel-devel
    kernel-headers
    gcc
    make
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #17
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Problem solved. I can't express in enough expletives how fscking stupid I feel right now. The problem, was exactly as posted above. The wireless card wasn't turned on. In XP, when the card was turned off the light would be orange. The light never even turned on in fedora, so I never even thought about it. But as soon as I pushed the button, the light turned blue. !@#$! Thanks guys for all your wonderful help, and idears. So, for future googlers who are having wireless trouble, DID YOU MAKE SURE YOU TURNED ON THE CARD??? Fuuuuuuuudge.


    This is like that one time my buddy called me for help with his computer. He said it wouldn't turn on. First thing I asked him "Scotty, is it plugged in?" He told me "Of course it's plugged in, you think I'm an idiot?" A thirty minute drive later, I replied, "Yes, I do think you're an idiot."

    Again, thank you everyone for your time, effort, patience, and help.

  8. #18
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Good News!

    Bananas for all!
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #19
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Good job on sticking with it!
    Here's a couple more for ya!
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •