Find the answer to your Linux question:
Results 1 to 8 of 8
Hey I've followed the advice on the sticky to set up my ralinkrt61 wireless device, unfortunately, when I do I run into two problems: the first is that (following this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    4

    trying to set up rt61 drivers


    Hey I've followed the advice on the sticky to set up my ralinkrt61 wireless device, unfortunately, when I do I run into two problems: the first is that (following this guide: h t t p s :// help(dot)ubuntu(dot)com/community/WifiDocs/Driver/RalinkRT61 ) when it comes time to make all I get this:
    Code:
    make: *** /lib/modules/2.6.26-2-686/ build: no such file or directory. stop
    make: ***[all] error 2
    also, There seems to be no rt61.ko file anywhere
    ps. I'm new to linux

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    What version of Ubuntu are you using? RT61 devices are supported out of the box using newer kernels so there is generally no need for you to compile the driver yourself.

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    4
    Quote Originally Posted by daark.child View Post
    What version of Ubuntu are you using? RT61 devices are supported out of the box using newer kernels so there is generally no need for you to compile the driver yourself.
    Actually I'm using Debian. I just installed it the other night and its my first linux distro
    edit: kernel 2.6.26-2-686
    also, when trying to install the drivers via the ndiswrapper method, I come accross a makefile:34: *** cannot find kernal version in lib/modules/2.6.26-2-868/build, is it configured?

    What does it mean by this?

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Before we can help, we need some detailed information concerning your system. The link below is for a stickied post that explains how to obtain this information. Please read through it, and post the info here in this thread.

    Wireless Setup - Start Here
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    Just Joined!
    Join Date
    May 2009
    Posts
    4
    Oops, forgot to add all that:

    lspci
    Code:
    00:00.0 Host bridge [0600]: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface [8086:2560] (rev 03)
    00:01.0 PCI bridge [0604]: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE Host-to-AGP Bridge [8086:2561] (rev 03)
    00:1d.0 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 [8086:24c2] (rev 02)
    00:1d.1 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 [8086:24c4] (rev 02)
    00:1d.2 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 [8086:24c7] (rev 02)
    00:1d.7 USB Controller [0c03]: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller [8086:24cd] (rev 02)
    00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 82)
    00:1f.0 ISA bridge [0601]: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge [8086:24c0] (rev 02)
    00:1f.1 IDE interface [0101]: Intel Corporation 82801DB (ICH4) IDE Controller [8086:24cb] (rev 02)
    00:1f.3 SMBus [0c05]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller [8086:24c3] (rev 02)
    00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller [8086:24c5] (rev 02)
    01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV280 [Radeon 9200 PRO] [1002:5960] (rev 01)
    01:00.1 Display controller [0380]: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) [1002:5940] (rev 01)
    02:01.0 Network controller [0280]: RaLink RT2561/RT61 802.11g PCI [1814:0301]
    02:05.0 Communication controller [0780]: Conexant HSF 56k HSFi Modem [14f1:2f00] (rev 01)
    02:08.0 Ethernet controller [0200]: Intel Corporation 82801DB PRO/100 VE (CNR) Ethernet Controller [8086:103a] (rev 82)
    lsmod
    Code:
    Module                  Size  Used by
    isofs                  28164  1 
    nls_utf8                1760  2 
    zlib_inflate           14144  1 isofs
    nls_cp437               5568  1 
    vfat                    9184  1 
    fat                    40896  1 vfat
    udf                    67684  0 
    nls_base                6820  6 isofs,nls_utf8,nls_cp437,vfat,fat,udf
    crc_itu_t               2080  1 udf
    radeon                118912  1 
    drm                    65192  2 radeon
    ipv6                  235364  12 
    ppdev                   6500  0 
    lp                      8164  0 
    loop                   12748  0 
    snd_mpu401              6152  0 
    sd_mod                 22200  2 
    snd_cs4232             11380  0 
    snd_opl3_lib            9344  1 snd_cs4232
    snd_hwdep               6212  1 snd_opl3_lib
    snd_cs4231_lib         20512  1 snd_cs4232
    snd_mpu401_uart         6368  2 snd_mpu401,snd_cs4232
    ns558                   3712  0 
    snd_seq_midi            5728  0 
    snd_seq_midi_event      6432  1 snd_seq_midi
    gameport               10700  2 ns558
    snd_rawmidi            18528  2 snd_mpu401_uart,snd_seq_midi
    parport_pc             22500  1 
    parport                30988  3 ppdev,lp,parport_pc
    snd_intel8x0           26268  1 
    snd_ac97_codec         88484  1 snd_intel8x0
    ac97_bus                1728  1 snd_ac97_codec
    snd_pcm                62596  3 snd_cs4231_lib,snd_intel8x0,snd_ac97_codec
    snd_seq                41456  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              17800  4 snd_opl3_lib,snd_cs4231_lib,snd_pcm,snd_seq
    snd_seq_device          6380  4 snd_opl3_lib,snd_seq_midi,snd_rawmidi,snd_seq
    pcspkr                  2432  0 
    snd                    45604  15 snd_mpu401,snd_cs4232,snd_opl3_lib,snd_hwdep,snd_cs4231_lib,snd_mpu401_uart,snd_rawmidi,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_seq,snd_timer,snd_seq_device
    soundcore               6368  1 snd
    i2c_i801                7920  0 
    snd_page_alloc          7816  3 snd_cs4231_lib,snd_intel8x0,snd_pcm
    i2c_core               19828  1 i2c_i801
    rng_core                3940  0 
    iTCO_wdt                9508  0 
    button                  6096  0 
    intel_agp              22556  1 
    agpgart                28776  2 drm,intel_agp
    shpchp                 25528  0 
    pci_hotplug            23460  1 shpchp
    joydev                  8480  0 
    evdev                   8000  3 
    led_class               3908  0 
    wmi                     6440  0 
    ext3                  105512  3 
    jbd                    39444  1 ext3
    mbcache                 7108  1 ext3
    ide_cd_mod             27652  1 
    cdrom                  30176  1 ide_cd_mod
    ide_disk               10496  5 
    ata_generic             4676  0 
    libata                140416  1 ata_generic
    dock                    8304  1 libata
    usbhid                 35904  0 
    hid                    33184  1 usbhid
    ff_memless              4392  1 usbhid
    usb_storage            77024  1 
    scsi_mod              129324  3 sd_mod,libata,usb_storage
    piix                    6568  0 [permanent]
    floppy                 47748  0 
    e100                   28908  0 
    mii                     4896  1 e100
    ide_pci_generic         3908  0 [permanent]
    ide_core               96136  4 ide_cd_mod,ide_disk,piix,ide_pci_generic
    ehci_hcd               28396  0 
    uhci_hcd               18672  0 
    usbcore               118224  5 usbhid,usb_storage,ehci_hcd,uhci_hcd
    thermal                15228  0 
    processor              32544  1 thermal
    fan                     4164  0 
    thermal_sys            10856  3 thermal,processor,fan

  6. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Thank you for the info.

    This is the wireless:
    Code:
    02:01.0 Network controller [0280]: RaLink RT2561/RT61 802.11g PCI [1814:0301]
    I believe that the rt61pci driver should work, but I don't see it loading. I don't know what kind of wireless support Debian has, but you could try manually loading the module. Use the su command to gain root priviledge first.
    Code:
    modprobe rt61pci
    If this returns with a blank prompt, then the module loaded. Look for it in the lsmod output.

    If you get an error, then the kernel is not compiled with support for your card. You will then have to add the driver, as you first tried to do. There are actually two drivers that you can use. There is the open-source rt61pci driver. It can be found in a package that includes many drivers:

    Download - Linux Wireless

    Or you can use the Ralink rt61 driver that you first tried to compile. Both drivers will need to be compiled.

    The reason that your first compile failed, is most likely because you do not have some dependencies installed. The Ubuntu document that you linked to even says what needs to be installed first:
    You will need to install a few packages for the compilation process. For installation of packages, please refer to InstallingSoftware.

    • gcc
    • build-essential
    • linux-headers

    These may have different names in Debian. What you need is this:

    kernel headers
    kernel source
    gcc
    make

    With these installed, you should be able to compile either of the drivers.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #7
    Just Joined!
    Join Date
    May 2009
    Posts
    4
    ok thanks. After running modprobe rt61pci its now finding a wireless connection in network connection, however I am having trouble setting it up. Iwconfig finds this:
    wlan0 IEEE 802.11 ESSID home
    Mode: managed Frequencey:2.412 Ghz Access point: not Associated
    (...)
    link Quality: 0 Signal level: 0 Noise level: o
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

    If config finds eth0 and lo
    and the lights on my actual NIC aren't lighting up.

    I thought I had got all the dependencies I needed for the other problem. Debian had a "linux-header" that I downloaded, I might recheck that I got and installed the right kernel headers and source, failing that I'll move onto Ubuntu but it would be good to get this working

  8. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I'm not sure what other problems there are. The output of the dmesg command may show these.

    I don't know if Debian has a network connetion manager by default. It would be located in the system tray, next to the date/time. If not, you can try installing it.
    Code:
    apt-get install network-manager
    There is also the system tray applet, nm-applet. It too is needed.

    Or you could just install the Wicd connection manager. It looks to be in the lenny-backports repository.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •