Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Working with ubuntu, latest version. I can get wireless working if I run the following commands: ifconfig wlan0 down ifconfig wlan0 192.168.1.244 netmask 255.255.255.0 up route add default gw 192.168.1.1 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    9

    Not working on reboot


    Working with ubuntu, latest version.

    I can get wireless working if I run the following commands:

    ifconfig wlan0 down
    ifconfig wlan0 192.168.1.244 netmask 255.255.255.0 up
    route add default gw 192.168.1.1
    iwconfig wlan0 essid "linksys"
    iwconfig wlan0 mode Managed
    dhclient wlan0

    This works and everything is fine. But I don't want to run this script everytime.

    I thought I should configure etc/network/interfaces here is my file:
    auto lo
    iface lo inet loopback

    auto wlan0
    iface wlan0 inet static
    wireless-essid linksys
    address 192.168.1.222
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

    iface eth0 inet dhcp

    auto eth0


    After reboot, I can ping 192.168.1.222 and ping 127.0.0.1 but not my router.

    Any ideas on what I am screwing up?

    Bill

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I'm not sure exactly what the problem is. But is usually better to have the wireless receive its IP address through DHCP. You can configure the router to always give it the same IP address, as it identifies it through the MAC address.

    By manually setting the IP address on the computer, you will have trouble connecting to any other wireless network. (assuming that this is a portable laptop)
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Quote Originally Posted by waterhead View Post
    I'm not sure exactly what the problem is. But is usually better to have the wireless receive its IP address through DHCP. You can configure the router to always give it the same IP address, as it identifies it through the MAC address.

    By manually setting the IP address on the computer, you will have trouble connecting to any other wireless network. (assuming that this is a portable laptop)
    I had the same problem using DHCP. It is desktop computer so DHCP is not necessary.

    When I had the settings on DHCP it would not pick up the router. Using the above iwconfig lines everything works fine. But the lease goes out in 10 minutes(The router is configured for 1 day leases).

    But I can't get it to work when it boots up.

    I thought using a static IP would be easier to work with the router, but I have little experience working with wireless on linux, so I can go back to DHCP.

    Is there any other config file I need to tweak besides /etc/network/interfaces ??

    Do my settings look right? Any other reported problems similar to this?

    Thanks,

    Bill

  4. #4
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    I should also add that the eth0 works just fine when I plug in a network cable. And the wireless card will pick up it's DHCP address(when I had it configured that way) when the cable is plugged in.

    Not sure if that is important but thought it was at least interesting.

    Maybe I should run wireshark and see if DHCP reponses are being properly sent out and if the routers ever responds.

    Other ideas?

    Bill

  5. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like all network configuration is now done through the NetworkManager program. You can right-click the tray icon and select "Edit Connections".

    I don't know if it even uses the /etc/network/interfaces file anymore.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #6
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Quote Originally Posted by waterhead View Post
    It looks like all network configuration is now done through the NetworkManager program. You can right-click the tray icon and select "Edit Connections".

    I don't know if it even uses the /etc/network/interfaces file anymore.
    That what I started with and it seemed useless. Never could get anything going at all until I started using command line tools.

    Is there a recent doc that talks about this stuff?

    Thanks,

    Bill

  7. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Yeah, I don't understand why Ubuntu doesn't have a network configuration program. It is important.

    It may be possible that the wireless signal is dropping out. This would happen because of interference (walls, electronics, etc), distance, or just a weaker wireless chip.

    You may need to go to the Ubuntu forums for this. I don't know if instructions for older versions apply to 9.04.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by bnorton916 View Post
    Is there a recent doc that talks about this stuff?
    Check this out, and see if it helps:

    ubuntu 9.04(jaunty jackalope) internet configuration for static ip | iTech7.com

    In my resolv.conf, I have this:
    Code:
    # Generated by NetworkManager
    domain gateway.2wire.net
    search gateway.2wire.net
    nameserver 192.168.1.254
    So put your router IP address in there.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #9
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Great I will check it out tonight when I get home.

    Bill

  10. #10
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    Quote Originally Posted by waterhead View Post
    Yeah, I don't understand why Ubuntu doesn't have a network configuration program. It is important.

    It may be possible that the wireless signal is dropping out. This would happen because of interference (walls, electronics, etc), distance, or just a weaker wireless chip.

    You may need to go to the Ubuntu forums for this. I don't know if instructions for older versions apply to 9.04.
    The desktop is only 10 feet away for the router. And it worked just fine for 2 years when I had Windows 2000 installed on it. It also works just fine when I run the command line utilities.
    I will read that doc you posted maybe it will help.

    Thanks,

    Bill

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •