Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 26 of 26
Well, your wireless seems to be active, it is named eth1. The problem may be with NetworkManager. Run this command, it will scan for available networks. Post it back if ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    Well, your wireless seems to be active, it is named eth1. The problem may be with NetworkManager.

    Run this command, it will scan for available networks. Post it back if you want, it shouldn't contain any sensitive info.
    Code:
     iwlist eth1 scan
    You may want to install a different wireless connection manager. If you open the Synaptic package Manager, there are two you can install:

    wicd
    wifiradar

    Wicd is for all wired and wireless network connections. You have to disable or uninstall NetworkManager to use it, if Synaptic doesn't do it for you. Wifiradar is only for wireless, but I have never used it. I just installed it, but it won't run.

    Edit: wifiradar needs something called su-to-root to run, but it' doesn't seem to be available.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #22
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I was able to run wifiradar, just using sudo.
    Code:
    sudo /usr/sbin/wifi-radar
    Edit: It may be better to start it with this command:
    Code:
    gksudo -S /usr/bin/wifi-radar
    You can actually edit the menu and change the wifiradar icon to use the gksudo command instead of su-to-root.

    I sure hope one of these programs gets your wireless working.
    Last edited by waterhead; 06-21-2009 at 06:54 PM. Reason: spelling
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #23
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I googled the problem, and came up with some info that says you should remove and reload the module. So run these commands:
    Code:
    sudo modprobe -r wl
    Code:
    sudo modprobe wl
    Code:
    ifconfig eth1 up
    Last edited by waterhead; 06-21-2009 at 06:46 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #24
    Just Joined!
    Join Date
    May 2009
    Posts
    11
    well,

    Code:
    iwlist eth1 scan
    returns

    Code:
    eth1      Interface doesn't support scanning.

    wicd can't find any wireless networks (and of course there are wireless networks where I am)
    wifi-radar returns "eth1 Failed to read scan data : Invalid argument"

    and removing and reloading the wl module did not help.

    it seems I just can't receive the wireless signal or somthing like that no?
    I'm really desperate. I don't know what else can it be other than some hardware problem.

  5. #25
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It does seem like the wireless card is broken. The only other thing it could be is a switch that turns it on/off. If you have such a switch, try turning it off and rebooting with it off. Then shut the PC down again, this time turn it back on and then boot up again. Try this several different ways, to see if it will "shake it loose". You can also check your BIOS settings for anything that may affect it. I would try enabling "wake-on-LAN", and see if that helps.

    It may be time to look for another wireless card.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #26
    Just Joined!
    Join Date
    May 2009
    Posts
    11
    well, in the bios I turned the wireless off and then on and still nothing. I guess the card is indeed broken.
    I'll put it in repair.
    thank you very much waterhead.
    when it's out of repair i'll update about what it was.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •