Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
Nevermind, I'll post the relevant section. Code: [ 21.407904] iwlagn 0000:0e:00.0: firmware: requesting iwlwifi-5000-1.ucode [ 21.794854] Registered led device: iwl-phy0:radio [ 21.794868] Registered led device: iwl-phy0:assoc [ 21.794880] Registered led ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    Nevermind, I'll post the relevant section.
    Code:
    [   21.407904] iwlagn 0000:0e:00.0: firmware: requesting iwlwifi-5000-1.ucode
    
    [   21.794854] Registered led device: iwl-phy0:radio
    
    [   21.794868] Registered led device: iwl-phy0:assoc
    
    [   21.794880] Registered led device: iwl-phy0:RX
    
    [   21.794891] Registered led device: iwl-phy0:TX
    
    [   22.292059] iwlagn: Error sending REPLY_ADD_STA: time out after 500ms.
    
    [   22.293377] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    
    [   23.843703] wlan0: authenticate with AP 00:23:69:5b:91:29
    
    [   23.845803] wlan0: authenticated
    
    [   23.845807] wlan0: associate with AP 00:23:69:5b:91:29
    
    [   23.847952] wlan0: RX AssocResp from 00:23:69:5b:91:29 (capab=0x401 status=0 aid=2)
    
    [   23.847955] wlan0: associated
    
    [   23.851185] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    
    [   34.152106] wlan0: no IPv6 routers present
    I don't see anything wrong. Post the output of these commands.
    Code:
    ifconfig
    Code:
    iwconfig
    You can manually scan for networks with this command.
    Code:
    iwlist wlan0 scan
    I going to bed!

    Bye
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #12
    Banned
    Join Date
    Dec 2002
    Location
    Texas
    Posts
    242
    ifconfig

    Code:
    eth0      Link encap:Ethernet  HWaddr 00:24:e8:a8:34:7f  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:247 Base address:0xc000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:12 errors:0 dropped:0 overruns:0 frame:0
              TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:800 (800.0 B)  TX bytes:800 (800.0 B)
    
    wlan0     Link encap:Ethernet  HWaddr 00:22:fb:20:0a:76  
              inet6 addr: fe80::222:fbff:fe20:a76/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:217 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:25101 (25.1 KB)  TX bytes:576 (576.0 B)
    
    wmaster0  Link encap:UNSPEC  HWaddr 00-22-FB-20-0A-76-61-37-00-00-00-00-00-00-00-00  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    iwconfig

    Code:
    wlan0     IEEE 802.11abgn  ESSID:"linksys"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: 00:23:69:5B:91:29   
              Bit Rate=1 Mb/s   Tx-Power=15 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
              Encryption key:off
              Power Management:off
              Link Quality=12/100  Signal level:-82 dBm  Noise level=-87 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    iwlist wlan0 scan

    Code:
    wlan0     Scan completed :
              Cell 01 - Address: 00:23:69:5B:91:29
                        ESSID:"linksys"
                        Mode:Master
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=38/100  Signal level:-86 dBm  Noise level=-127 dBm
                        Encryption key:off
                        IE: Unknown: 00076C696E6B737973
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030106
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: Unknown: 32040C121860
                        IE: Unknown: DD06001018020104
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
                        Extra:tsf=0000001d45abb3e9
                        Extra: Last beacon: 100ms ago
              Cell 02 - Address: 00:09:5B:A3:BA:D8
                        ESSID:"HOME01"
                        Mode:Master
                        Channel:8
                        Frequency:2.447 GHz (Channel 8)
                        Quality=81/100  Signal level:-53 dBm  Noise level=-127 dBm
                        Encryption key:on
                        IE: Unknown: 0006484F4D453031
                        IE: Unknown: 010482848B96
                        IE: Unknown: 030108
                        IE: Unknown: 2A0100
                        IE: Unknown: 32080C1218243048606C
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (1) : TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 0706555320010B1E
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Extra:tsf=000002e815343229
                        Extra: Last beacon: 2380ms ago
    "HOME01" is my AP.

  3. #13
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    OK, this is the wireless network interface. It seems to be working, but it doesn't have an IP address.
    Code:
    wlan0     Link encap:Ethernet  HWaddr 00:22:fb:20:0a:76  
              inet6 addr: fe80::222:fbff:fe20:a76/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:217 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:25101 (25.1 KB)  TX bytes:576 (576.0 B)
    You appear to be connected to the "linksys" wireless network. But look at the bit rate and quality level. This is why it drops out.
    Code:
    wlan0     IEEE 802.11abgn  ESSID:"linksys"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: 00:23:69:5B:91:29   
              Bit Rate=1 Mb/s   Tx-Power=15 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
              Encryption key:off
              Power Management:off
              Link Quality=12/100  Signal level:-82 dBm  Noise level=-87 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    This is verified by the Quality level of the scanned connection:
    Code:
    wlan0     Scan completed :
              Cell 01 - Address: 00:23:69:5B:91:29
                        ESSID:"linksys"
                        Mode:Master
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=38/100  Signal level:-86 dBm  Noise level=-127 dBm
                        Encryption key:off
                        IE: Unknown: 00076C696E6B737973
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030106
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: Unknown: 32040C121860
                        IE: Unknown: DD06001018020104
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
                        Extra:tsf=0000001d45abb3e9
                        Extra: Last beacon: 100ms ago
    This connection has a much better quality rating, can you connect to this one?
    Code:
     Cell 02 - Address: 00:09:5B:A3:BA:D8
                        ESSID:"HOME01"
                        Mode:Master
                        Channel:8
                        Frequency:2.447 GHz (Channel 8)
                        Quality=81/100  Signal level:-53 dBm  Noise level=-127 dBm
                        Encryption key:on
                        IE: Unknown: 0006484F4D453031
                        IE: Unknown: 010482848B96
                        IE: Unknown: 030108
                        IE: Unknown: 2A0100
                        IE: Unknown: 32080C1218243048606C
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (1) : TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 0706555320010B1E
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Extra:tsf=000002e815343229
                        Extra: Last beacon: 2380ms ago
    "HOME01" is my AP.
    Well, it appears that it is not connecting to your AP, but another one named "linksys". I would delete all of the saved wireless connections, and then connect to the one you want (HOME01). Right-click the NetworkManager icon and select "Edit Connections". Delete all of the connections under the wireless taab. Then left-click and choose the HOME01 connection to connect to.

    If your HOME01 connection is a hidden network, meaning it does not broadcast it's availability, then you need to uncloak it. As you can see, that doesn't really work anyway, but it makes it difficult for NetworkManager to connect to it.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #14
    Banned
    Join Date
    Dec 2002
    Location
    Texas
    Posts
    242
    Quote Originally Posted by waterhead View Post
    Right-click the NetworkManager icon and select "Edit Connections". Delete all of the connections under the wireless tab. Then left-click and choose the HOME01 connection to connect to.
    HOME01 is the only connection listed in my Network Manager,
    and its setup for Auto connect. Although I have not deleted that
    and tried to re-add it yet, I will do that and see what happens.

    What I find odd is that my "Enable Wireless" option is grayed out
    on the Network Manager icon on the task bar. I did not pay much
    attention when it was working, but I would assume it was available
    previously. We'll see if the delete/re-add helps.

  5. #15
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I assume that by being greyed out, you mean that you also cannot click it to enable it. This is usually caused by there being no usable wireless card, but we know that isn't true. it also can be caused by configuring a different connection manager to handle the wireless connections.

    Maybe this is a problem with NetworkManager. You can try using a different connection manager, like Wicd. Wicd can be install through the Synaptic Package Manager, or with Apt. I believe that it will automatically disable NetworkManager
    Code:
    sudo apt-get install wicd
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #16
    Banned
    Join Date
    Dec 2002
    Location
    Texas
    Posts
    242
    Quote Originally Posted by waterhead View Post
    Maybe this is a problem with NetworkManager.
    My wireless is fixed (and I'm on my Ubuntu again right now).

    Here's the sequence of events...

    I decide to see if I can reinstall the Network Manager first.
    I connect via hard wire and reinstall the package
    I restart networking
    It still does not work

    Since I'm online it found updates and asks me about them
    I go ahead and install them
    As the updates finish, my wireless fires on up!

    Looks like it was ANOTHER round of updates that killed my wi-fi.

  7. #17
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I learned something when dealing with systems setup with MythTV. When you have it all setup and working, disable any updates. You don't need to fix something that isn't broken.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #18
    Banned
    Join Date
    Dec 2002
    Location
    Texas
    Posts
    242
    Quote Originally Posted by waterhead View Post
    I learned something when dealing with systems setup with MythTV. When you have it all setup and working, disable any updates. You don't need to fix something that isn't broken.
    I do agree with not fixing something that isn't broken, but I also
    don't want to miss out on any security related updates (like ssh).
    Double edged sword, I guess.

    Thanks for your help!

  9. #19
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    The solution is to not allow automatic updates. When you are alerted of updates, pick the ones you want to use and refuse the rest.
    Registered Linux User #420832

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •