Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 35
Your correct in thinking something is amiss. I am not sure that the firmware isn't actually loading, but I'll take your word for it. Maybe you need to check the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    Your correct in thinking something is amiss. I am not sure that the firmware isn't actually loading, but I'll take your word for it.

    Maybe you need to check the wireless settings. If there are any settings for it in the BIOS, you may want to review them. If you can set it to Wake-on-LAN, try that. I'm sure that you checked any on/off switch or shortcut keys, but I wanted to mention that. There is a module loading called rfkill, that is being used by the dell_laptop module. This implies that there is a key combination to control the wireless.

    I think you said that it works in Windows, so is this a dual-boot system? If so, then maybe Windows is leaving it in a state that is difficult for Linux to deal with. I have heard of this problem in the past, but I don't recall the solution.

    Without trying anything else, try unloading and then reloading the driver module. See if this kicks in the wireless.
    Code:
    sudo modprobe -r iwlagn
    Code:
    sudo modprobe iwlagn
    Skipping back to the rfkill module. There is a way to check the state of that module. Run ths command:
    Code:
    cat /sys/class/rfkill/rfkill0/state
    You will get a 0 or 1 for the answer.
    0 = off (disabled)
    1 = on (enabled)
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #22
    Just Joined!
    Join Date
    Jun 2009
    Location
    Cotati
    Posts
    21
    Yes, it is a dual-boot system. Following the suggestions above:

    graton% sudo -s
    graton# dmesg | grep iwlagn
    [ 8.244490] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
    [ 8.244493] iwlagn: Copyright(c) 2003-2008 Intel Corporation
    [ 8.244582] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 8.244612] iwlagn 0000:0c:00.0: setting latency timer to 64
    [ 8.244729] iwlagn: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
    [ 8.266975] iwlagn: Tunable channels: 13 802.11bg, 24 802.11a channels
    [ 8.312274] iwlagn 0000:0c:00.0: PCI INT A disabled
    [ 8.312338] wmaster0 (iwlagn): not using net_device_ops yet
    [ 8.477722] wlan0 (iwlagn): not using net_device_ops yet
    graton# modprobe -r iwlagn
    graton# dmesg | grep iwlagn
    [ 8.244490] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
    [ 8.244493] iwlagn: Copyright(c) 2003-2008 Intel Corporation
    [ 8.244582] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 8.244612] iwlagn 0000:0c:00.0: setting latency timer to 64
    [ 8.244729] iwlagn: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
    [ 8.266975] iwlagn: Tunable channels: 13 802.11bg, 24 802.11a channels
    [ 8.312274] iwlagn 0000:0c:00.0: PCI INT A disabled
    [ 8.312338] wmaster0 (iwlagn): not using net_device_ops yet
    [ 8.477722] wlan0 (iwlagn): not using net_device_ops yet
    graton# modprobe iwlagn
    graton# dmesg | grep iwlagn
    [ 8.244490] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
    [ 8.244493] iwlagn: Copyright(c) 2003-2008 Intel Corporation
    [ 8.244582] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 8.244612] iwlagn 0000:0c:00.0: setting latency timer to 64
    [ 8.244729] iwlagn: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
    [ 8.266975] iwlagn: Tunable channels: 13 802.11bg, 24 802.11a channels
    [ 8.312274] iwlagn 0000:0c:00.0: PCI INT A disabled
    [ 8.312338] wmaster0 (iwlagn): not using net_device_ops yet
    [ 8.477722] wlan0 (iwlagn): not using net_device_ops yet
    [ 137.133878] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
    [ 137.133884] iwlagn: Copyright(c) 2003-2008 Intel Corporation
    [ 137.133961] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 137.133975] iwlagn 0000:0c:00.0: setting latency timer to 64
    [ 137.134210] iwlagn: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
    [ 137.153296] iwlagn: Tunable channels: 13 802.11bg, 24 802.11a channels
    [ 137.158477] wmaster0 (iwlagn): not using net_device_ops yet
    [ 137.159201] wlan0 (iwlagn): not using net_device_ops yet
    graton# cat /sys/class/rfkill/rfkill0/state
    1
    graton#

    Proceeding further:

    graton# ifconfig wlan0 up
    graton# dmesg | grep iwlagn
    [ 8.244490] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
    [ 8.244493] iwlagn: Copyright(c) 2003-2008 Intel Corporation
    [ 8.244582] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 8.244612] iwlagn 0000:0c:00.0: setting latency timer to 64
    [ 8.244729] iwlagn: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
    [ 8.266975] iwlagn: Tunable channels: 13 802.11bg, 24 802.11a channels
    [ 8.312274] iwlagn 0000:0c:00.0: PCI INT A disabled
    [ 8.312338] wmaster0 (iwlagn): not using net_device_ops yet
    [ 8.477722] wlan0 (iwlagn): not using net_device_ops yet
    [ 137.133878] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
    [ 137.133884] iwlagn: Copyright(c) 2003-2008 Intel Corporation
    [ 137.133961] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 137.133975] iwlagn 0000:0c:00.0: setting latency timer to 64
    [ 137.134210] iwlagn: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
    [ 137.153296] iwlagn: Tunable channels: 13 802.11bg, 24 802.11a channels
    [ 137.158477] wmaster0 (iwlagn): not using net_device_ops yet
    [ 137.159201] wlan0 (iwlagn): not using net_device_ops yet
    [ 457.501021] iwlagn 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 457.501211] iwlagn 0000:0c:00.0: irq 31 for MSI/MSI-X
    [ 457.501284] iwlagn 0000:0c:00.0: firmware: requesting iwlwifi-5000-1.ucode
    [ 457.581936] iwlagn loaded firmware version 5.4.1.16

    It is apparently the ifconfig command that prompts the firmware load.

    And at this point, it will detect access points:

    graton# iwlist wlan0 scan
    wlan0 Scan completed :
    Cell 01 - Address: 00:13:49:23:EC:06
    ESSID:"ZyXEL"
    Mode:Master
    Channel:11
    Frequency:2.462 GHz (Channel 11)
    Quality=61/100 Signal level:-71 dBm Noise level=-127 dBm
    Encryption key:on
    IE: Unknown: 00055A7958454C
    IE: Unknown: 010882848B960C121824
    IE: Unknown: 03010B
    IE: Unknown: 2A0100
    IE: Unknown: 32043048606C
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : TKIP
    Authentication Suites (1) : PSK
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Extra:tsf=0000004a79d6f404
    Extra: Last beacon: 1568ms ago
    Cell 02 - Address: 00:22:3F:75:5F:1C
    ESSID:"Benfell"
    Mode:Master
    Channel:11
    Frequency:2.462 GHz (Channel 11)
    Quality=93/100 Signal level:-36 dBm Noise level=-127 dBm
    Encryption key:on
    IE: Unknown: 000742656E66656C6C
    IE: Unknown: 010882848B960C183048
    IE: Unknown: 03010B
    IE: Unknown: 2A0100
    IE: Unknown: 32041224606C
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    Preauthentication Supported
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
    48 Mb/s; 54 Mb/s
    Extra:tsf=0000021ea1b24181
    Extra: Last beacon: 1560ms ago

    graton#

    However, while I can connect to an unsecured access point, I have never succeeded (on this laptop or any other) in connecting to a secured one via command line tools.

    This is why I need wicd to work; it still stubbornly refuses to recognize any wireless networks. I tried restarting the daemon; that only made things worse as even afterwards restarting the client failed to connect (I presume to the daemon).

  3. #23
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You may get what you are looking for by just using wpa_supplicant, instead of Wicd. You will need to set up a config file containing your network information.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #24
    Just Joined!
    Join Date
    Jun 2009
    Location
    Cotati
    Posts
    21
    Yeah, sad to say, for whatever reason, I'm thinking wicd, which has served me well in every other situation I've tried it, is not working on this system.

    So I'm trying to figure out wpa_supplicant. The example configuration file claims it will try network blocks in the order listed.

    So, before I really hose myself, here's what I've got:

    graton# grep -v "^#" /etc/network/interfaces

    auto lo
    iface lo inet loopback

    iface eth0 inet dhcp
    wpa-driver wired

    iface wlan0 inet manual
    wpa-driver wext
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

    graton# grep -v "^#" /etc/wpa_supplicant/wpa_supplicant.conf

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

    network={
    ssid="coffee_catz"
    key_mgmt=NONE
    id_str="Coffee_Catz"
    }

    network={
    ssid="Benfell"
    psk="ItsSupposedToBeASecret"
    id_str="Moms_house"
    }

    network={
    key_mgmt=NONE
    }

    You might guess I have here changed the password on my home network, but it is a text password in something like that format. What, because I always screw stuff like this up somehow, am I getting wrong?

    Oh, and how will it know to get a dhcp address?

  6. #25
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Hmmm... I'm not sure about those.

    When I used wpa_supplicant (a long time ago), I recall only being able to have one connection listed in the wpa_supplicant file. This is why I dumped it as soon as NetworkManager became usable. You may also need to give more info for the connection.

    Take a look at the wpa_supplicant documentation. It can be found in the /usr/share/doc/wpasupplicant/ folder. There are also some example files. What I found curious was the README.Debian file. It gives examples that are formatted differently than the other examples.

    You have to set up wpa_supplicant before it will work. You will need to tell it which driver to use and the location of the wpa_supplicant.conf file. For more info on that, use the --help option.
    Code:
    wpa_supplicant --help
    The example set up command it gives is this:
    Code:
    wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
    Note the location of the wpa_supplicant.conf file. I was looking at the Debian file package, found HERE. It says the location of the wpa-supplicant.conf file is /etc/dbus-1/system.d/wpa_supplicant.conf. It looks like Debian is doing things a little different than what I used in Suse and Fedora.

    Edit: You can read the wpa_supplicant man pages using this command
    Code:
    man 5 wpa_supplicant.conf
    There are examples there too.
    Last edited by waterhead; 06-09-2009 at 11:55 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #26
    Just Joined!
    Join Date
    Jun 2009
    Location
    Cotati
    Posts
    21
    wpa_supplicant appears to work, at least partially, at least in the context of having already gotten the firmware to load. I am presently connected through a secured wired access point. I did have to run dhclient manually but I also had some configuration file changes pending that it turns out I had not written to disk. I will test further and post the final configuration.

    Waterhead, your experience appears to refer to a "managed" configuration. I am, and I would expect most users to be, interested in a "roaming" configuration, which allows multiple networks to be configured.

  8. #27
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Yes, I saw that when reading through the instructions. I wasn't aware of that before, so it shows that you are never too old to learn something new.

    I thought that Wicd also used wpa_supplicant to connect to secured networks. I don't understand why it wasn't working. It seems that using only wpa_supplicant is what you wanted in the first place.

    The Debian README file had some example settings for DHCP and Static connections, you may want to look into that.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #28
    Just Joined!
    Join Date
    Jun 2009
    Location
    Cotati
    Posts
    21
    I will have to play with this further. It looks like the "ifconfig wlan0 up" command is necessary prior to running wpa_supplicant. Also, while it connected to the unsecured coffee_catz access point, dhclient failed. dhclient failed when run manually, so I actually don't know whether wpa_supplicant failed to run it or not.

    This particular access point is a bit flaky (is there one that sees any real use that isn't?) so I tried rebooting under Windows. Windows successfully connected.

  10. #29
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I use a Linksys WAP54G access point, and have never had any problems with it. I updated the firmware once, a long time ago.
    Please do not send Private Messages to me with requests for help. I will not reply.

  11. #30
    Just Joined!
    Join Date
    Jun 2009
    Location
    Cotati
    Posts
    21
    I have had few problems with access points I have personally administered. The problem I'm seeing there seems to be with access points serving larger numbers of users.

    Back on topic, one problem appears to be that dhclient, the dhcp client Debian installs by default, has stopped working on this laptop over wlan0. I installed dhcpcd and successfully negotiated a dhcp address where dhclient failed.

    So the remaining question is whether or not my wpa_supplicant configuration will automatically run the dhcp client. The configuration now:

    graton# grep -v "^#" /etc/network/interfaces

    auto lo
    iface lo inet loopback

    iface eth0 inet dhcp
    wpa-driver wired

    iface wlan0 inet manual
    wpa-driver wext
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

    iface Coffee_Catz inet dhcp
    iface Moms_house inet dhcp
    iface default inet dhcp
    graton# grep -v "^#" /etc/wpa_supplicant/wpa_supplicant.conf

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

    network={
    ssid="coffee_catz"
    scan_ssid=1
    key_mgmt=NONE
    id_str="Coffee_Catz"
    }

    network={
    ssid="Benfell"
    scan_ssid=1
    key_mgmt=WPA-PSK
    psk="Secret"
    id_str="Moms_house"
    }

    network={
    key_mgmt=NONE
    }
    graton#

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •