Find the answer to your Linux question:
Results 1 to 9 of 9
hi i want to know the driver and its corresponding files which enable the wireless connectivity in fedora 9. wil the loading of these driver files(driver) onto other linux based ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    6

    drivers suppoting wireless connectivity feature in fedora 9


    hi
    i want to know the driver and its corresponding files which enable the wireless connectivity in fedora 9.
    wil the loading of these driver files(driver) onto other linux based os , enable wireless connectivity in it?
    iam working on moblin os which is a linux based os and want to setup wireless connectivity using d-link dongle n router i have.
    plz help me doing it.

  2. #2
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    Moblin is still in beta so don't expect it to be fully functional. Plug in the usb adapter. In applications tab search for "terminal" without the quotes.
    su
    enter your root password, you won't be able to see what you type.
    lsusb
    iwconfig
    Post the output of the commands.
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  3. #3
    Just Joined!
    Join Date
    Jun 2009
    Posts
    6
    1. I did as you told

    but for the commands-
    lsusb
    iwconfig

    "no command found" without quotes was displayed

    2. actually when i connect the usb adapter, the required network is found
    And when i select the required network, the icon shows as if it is connecting/searching for something.

    Enter Passphrase window appears in which -
    Network requires input of parsephrase is asked
    when i enter it, no change is observed.The connectivity icon shows it is still connecting/searching for something.

    3. the moblin os that iam using now shows that it uses connection manager 0.3
    when i connect a ethernet cable between the router and the processor board, the connectivity happens and i get the ip address also.
    why doesnt the wireless connectivity b/w adapter and router happen?
    wat r the files/folders tat iv 2 include 2 enable this wireless feature of it?

    plz help me.
    i need 2 get the wireless connection working on moblin.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    Fedora need to write /sbin/iwconfig and /sbin/lsusb as root user. Anyway, your cards seems to have the apropriate drivers loaded. What encryption are you using? Try to disable the encryption from the router and connect.
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  6. #5
    Just Joined!
    Join Date
    Jun 2009
    Posts
    6
    I am working on Fedora core 9 as root user and the commands iwconfig, lsusb are present in /sbin/

    I am not able to find the above mentioned commands in moblin, ie. location /sbin/.

    After connecting the D-Link usb adapter, to the fedora system, and executing the commands I found the following-

    iwconfig

    [root@localhost ~]# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    pan0 no wireless extensions.

    virbr0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan1 IEEE 802.11 ESSID:"nozomi"
    Mode:Managed Frequency:2.437 GHz Access Point: 00:22:B0:42:6C:2F
    Bit Rate=54 Mb/s Tx-Power=12 dBm
    Retry min limit:7 RTS thr:off Fragment thr=2352 B
    Encryption key:63BF-3139-0544-D270-5F50-8655-EE6F-D736-C992-128B-8297-8CE5-AD55-20A0-9584-79CF [2]
    Link Quality=74/100 Signal level=-32 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    lsusb


    [root@localhost ~]# lsusb
    Bus 001 Device 010: ID 07d1:3c07 D-Link System Wireless G DWA-110 Adapter
    Bus 001 Device 005: ID 0424:2504 Standard Microsystems Corp. USB 2.0 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 002: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    The above were found in fedora core 9. If I copy the iwconfig file and lsusb file in /sbin/ in moblin, can I get the above results?

    How to find what encryption I am using?
    How to disable the encryption from router and connect?
    Where can I find the option about this encryption in moblin os?

  7. #6
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    In moblin its exactly the same /sbin/iwconfig and /sbin/lsusb. Output would be the same anyway. I read that using wicd instead of network manager should work. Before installing it though, try the steps I mentioned. You can access your router's home page by typing it's IP in your browser window. Look for wireless security and disable it and then try to reconnect. Also keep in mind that moblin is still in beta so don't expect it to work flawlessly.
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  8. #7
    Just Joined!
    Join Date
    Jun 2009
    Posts
    6
    Hi,

    I thank you ..

    Now I am trying to install moblin image creator.As per the instructions given in README---

    Installation
    ------------

    It needs below packages that install Image-Creator.
    autoconf, automake, intltool, gettext-devel(only fedora)

    $ ./autogen.sh
    $ ./configure
    $ sudo make install


    I have made sure that all the packages are installed in the first place. Then, when I follow the above steps, I get the following ----


    [root@localhost moblin-image-creator]# ./autogen.sh
    + intltoolize --force
    You should update your 'aclocal.m4' by running aclocal.
    + aclocal -I m4
    configure.ac:28: warning: macro `AM_GNU_GETTEXT' not found in library
    configure.ac:29: warning: macro `AM_GNU_GETTEXT_VERSION' not found in library
    + autoconf
    + automake --add-missing --foreign

    [root@localhost moblin-image-creator]# ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether make sets $(MAKE)... (cached) yes
    ./configure: line 2253: syntax error near unexpected token `0.35.0'
    ./configure: line 2253: `IT_PROG_INTLTOOL(0.35.0)'


    [root@localhost moblin-image-creator]# sudo make install
    make: *** No rule to make target `install'. Stop.

    Please help me fix the problem. When I searched in google, I could not find any satisfactory answer.

  9. #8
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    Have a look here for the first error. Also usually after ./configure and before "make install" you have to type "make".
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  10. #9
    Just Joined!
    Join Date
    Jun 2009
    Posts
    6
    hi..
    thank you for supporting..
    coming back to the old problem..
    that is- wireless connectivity in moblin..
    u had told me to access your router's home page by typing it's IP in your browser window and to look for wireless security and disable it and then try to reconnect.

    but it shows as if it is stil connecting and even after giving the ip it not accessable.
    this was what I was trying with moblin 1.

    I got moblin2 beta version also which works very well for wiress connectivity.
    as soon as i connect the wireless dongle, it gives me the ip address and shows wi-fi connected.
    But the only problem with this is that it is very very slow...
    when i checked what takes up so much of cpu usage, it showed me a process called metacity which takes up 50-60% of cpu usage..
    Iam not able to kill it.
    How do I make moblin2 beta faster?
    How do I get rid of metacity?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •