Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
First of all, I recently installed Ubuntu (dual-boot with win XP), so i'm practically a noob. I have a PCI wireless card from Canyon - CN-WF511 Turbo. It has the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    5

    How to set up an Access point with Canyon CN-WF511 Turbo


    First of all, I recently installed Ubuntu (dual-boot with win XP), so i'm practically a noob.

    I have a PCI wireless card from Canyon - CN-WF511 Turbo. It has the Ralink R2561 chipset. And now I'm asking you to help me configure it, so it'll work as an access point!

    I've searched the internet to find out how to set up an access point, like I had in Win XP. I would really need this to work, because there are some other computers in my house, which access the internet over my PC.

    I found some drivers:
    1.: WWW . ralinktech.com/ralink/Home/Support/Linux . HTML
    2.: HTTP :// rt2x00.serialmonkey.com/wiki/index.php/Main_Page and HTTP :// sourceforge.net/projects/rt2400

    So now I don't know which of these acctually work and if it's possible to configure my wireless card to work as a access point at all.

    I haven't tried nothing yet, I'll just wait for your instructions and report to you what's happenig.

    Thanks!

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Here is a AP How-To, for starters.

    AP-mode Howto - Rt2x00Wiki
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Jun 2009
    Posts
    5
    Cool, thanks, I'll try that as soon as I come home

  4. #4
    Just Joined!
    Join Date
    Jun 2009
    Posts
    5
    Thanks for the how to, but I'll still need some help before I try anything, because I'm a beginner (and the how to is a bit too advanced )

    1. I don't get the line:
    Code:
    edit .config to CONFIG_DRIVER_NL80211=y and CFLAGS += -I#WHERE YOUR KERNEL HEADERS ARE#
    Where are my kernel headers?

    2. set country_code to match your contry
    Can you give me the link to the country-code list?

    3. set channel to something more suitable
    I assume that I can set it to 1, like in win xp?

    4.
    Code:
    subnet 10.254.239.0 netmask 255.255.255.224 {
      range 10.254.239.10 10.254.239.20;
    #  option routers rtr-239-0-1.example.org, rtr-239-0-2.example.org;
    }
    So if I want to give the computers IP adresses from 192.168.0.10 to 192.168.0.50, then I must write:

    Code:
    subnet 192.168.0.0 netmask 255.255.255.0 {
      range 192.168.0.10 192.168.0.50;}
    but I don't get the option routers..? What can I do with that option, and do I need it anyway?

    5. Note, this will not get your clients (machines connecting to your AP) a connection to the internet.
    I would need to do that too. So please, can anyone tell me how to do that in addition?

    Thanks everybody!

  5. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I've never attempted this, so my knowledge on the subject is limited. I'll learn at the same time you do.

    You took your first question out of context. let's view it as the instructions put it:
    Hostapd

    Hostapd is a userspace daemon that handles the configuration, association etc for WLAN Access Points.
    [edit]
    Get the latest version of hostapd

    * git clone git://w1.fi/srv/git/hostap.git
    * cd hostap/hostapd
    * cp defconfig .config
    * edit .config to CONFIG_DRIVER_NL80211=y and CFLAGS += -I#WHERE YOUR KERNEL HEADERS ARE#
    * make
    You first need git installed, so enter this command.
    Code:
    sudo apt-get install git git-core
    Then you need to download the source code of hostapd, using git:
    Code:
    git clone git://w1.fi/srv/git/hostap.git
    This will create a folder in your home directory named hostap. There is a filed named defconfig in the folder hostapd. It wants you to copy it as a file named .config:
    Code:
    cd ~/hostap/hostapd
    Code:
    cp defconfig .config
    Putting a dot in front of the config file makes it hidden, so you will need to go to the "View" settings of the file browser and select "Show Hidden Files". It says to then edit the .config file.
    edit .config to CONFIG_DRIVER_NL80211=y and CFLAGS += -I#WHERE YOUR KERNEL HEADERS ARE#
    So install the kernel headers first.
    Code:
    sudo apt-get install linux-headers-`uname -r`
    They should install in the /usr/source/ folder. The uname -r section of the command is surrounded by backticks (`). Then open the file for editing.
    Code:
    gedit .config
    For me, the headers are in this folder:
    /usr/src/linux-headers-2.6.28-13-generic

    There already is a section for the nl80211, but it is commented out:
    Code:
    # Driver interface for drivers using the nl80211 kernel interface
    #CONFIG_DRIVER_NL80211=y
    # driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
    # shipped with your distribution yet. If that is the case, you need to build
    # newer libnl version and point the hostapd build to use it.
    #LIBNL=/usr/src/libnl
    #CFLAGS += -I$(LIBNL)/include
    #LIBS += -L$(LIBNL)/lib
    According to the instructions, I would edit it to this:
    Code:
    # Driver interface for drivers using the nl80211 kernel interface
    CONFIG_DRIVER_NL80211=y
    # driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
    # shipped with your distribution yet. If that is the case, you need to build
    # newer libnl version and point the hostapd build to use it.
    #LIBNL=/usr/src/libnl
    CFLAGS += -I/usr/src/linux-headers-2.6.28-13-generic
    #LIBS += -L$(LIBNL)/lib
    I then ran this command:
    Code:
    make
    It started out OK, but then exited because of errors. The first several errors were these.
    Code:
    ../src/drivers/driver_nl80211.c:23:31: warning: netlink/genl/genl.h: No such file or directory
    ../src/drivers/driver_nl80211.c:24:33: warning: netlink/genl/family.h: No such file or directory
    ../src/drivers/driver_nl80211.c:25:31: warning: netlink/genl/ctrl.h: No such file or directory
    I would assume that I am missing something. Maybe the .config file had a clue, because the original said to install a recent version of libnl, which has something to do with netlink. You may notice that my error has to do with netlink, so this seems to be the problem. I have libnl1-1.1-3 installed in /usr/lib, so I edited the .config file to look like this:
    Code:
    # Driver interface for drivers using the nl80211 kernel interface
    CONFIG_DRIVER_NL80211=y
    # driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
    # shipped with your distribution yet. If that is the case, you need to build
    # newer libnl version and point the hostapd build to use it.
    #LIBNL=/usr/src/libnl
    #CFLAGS += -I$(LIBNL)/include
    LIBS += -L$(LIBNL)/usr/lib
    CFLAGS += -I/usr/src/linux-headers-2.6.28-13-generic
    But this didn't work either.

    I'm not sure where to go with this. You could try getting the libnl source and uncomment that part of the .config file.

    It's Friday and I'm going to drink some beer!
    Last edited by waterhead; 06-26-2009 at 11:16 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I found some more info. There is some info on the hostapd application at LinuxWireless:

    hostapd - Linux Wireless

    I needed to install hostapd.
    Code:
    sudo apt-get install hostapd
    The hostapd.conf file is in /etc/hostapd/ folder. Now you can edit it according to the next instructions.
    edit hostapd.conf

    * change the ssid to something more fun
    * set country_code to match your contry
    * change hw_mode=g
    * set channel to something more suitable
    EDIT: I would follow the instructions from the LinuxWireless web site first. There even is a section concerning the errors that I got.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Well, it looks like Ubuntu installs an old version of hostapd:
    Code:
    paul@eeepc:$ hostapd -v
    hostapd v0.5.10
    User space daemon for IEEE 802.11 AP management,
    IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
    Copyright (c) 2002-2008, Jouni Malinen <j@w1.fi> and contributors
    It installs version 0.5.10. The How-To talks about using version 0.6.8 or newer. I guess you will need to install from source after all.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #8
    Just Joined!
    Join Date
    Jun 2009
    Posts
    5
    Thanks a lot waterhead, I really appreciate your work! I'll try that right away and I hope that there'll be no problems
    Thanks again!

  9. #9
    Linux Newbie ryptyde's Avatar
    Join Date
    Apr 2005
    Location
    Tragic City Michigan USA
    Posts
    232
    Fedora includes the rt61pci-firmware for that chipset and you may try a Fedora LiveCD/USB to see if it recognises your card in NetworkManager and if it does then set up a adhoc connection ap.

  10. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It's not that the wireless won't work in Ubuntu, he wants to use it as a AP, not ad-hoc. This requires newer versions of programs than what Ubuntu offers. I tried to uninstall an older version of one of them (I forget which) so that I could manually compile a newer version. Ubuntu wanted to uninstall a host of other apps that depend on it, so I gave up!

    I agree that doing this in Fedora 11 may be much easier. It is also much easier to install newer apps and libraries in Fedora.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •