Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 25 of 25
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21

    Sir ....finally i am on the net wirelessly , don't ask me how ! i went through several steps : first gksudo gedit /etc/network/interfaces
    i edited it to be
    auto lo
    iface lo inet loopback

    then i went though your recommendations :

    sudo modprobe -r b44
    sudo modprobe -r b43
    sudo modprobe -r wl
    sudo modprobe -r ssb

    Then load only the wl module

    sudo modprobe wl

    then i clicked on the network manager to find for the first time my wireless net among others . i selected my network and started writing to you
    indeed i appreciate your patient and faithful cooperation and help
    thank you very much

  2. #22
    What you have un the /etc/network/interfaces file is what is suppose to be there. Was there something else instead?

    Unless the interfaces file was causing problem, I would bet that disabling all of the open-source Broadcom driver, and enabling the proprietary Broadcom wl driver was what did it. FYI, the wired network driver will no longer work. If you need it you will have to remove the wl module and load the ssb and b44 modules.

    You can blacklist the modules that aren't needed. This is done by adding them to the /etc/modprobe.d/blacklist.conf file.
    echo blacklist ssb >> /etc/modprobe.d/blacklist.conf
    echo blacklist b43 >> /etc/modprobe.d/blacklist.conf
    echo blacklist b44 >> /etc/modprobe.d/blacklist.conf
    Make sure you use two chevrons (>>), using only one will replace the entire file with a new one. Or you could just open the file in a text editor.
    gksudo gedit /etc/modprobe.d/blacklist.conf
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #23
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Boston, MA
    Quote Originally Posted by drwolf View Post
    it didn't work , i am wondering why i am not able to manually figure ( or add ) a wired or wireless Internet without all these commands ... it is really a remarkable drawback for naive customers or end users as connectivity is their main primary endpoint ...
    thanks and i think it is time for ubuntu 9.04 unless you are gonna to you suggest something else ?
    In the majority of cases you do not. Broadcom cards have long been some of the most finicky, irritating, and challenging cards out there. Until fairly recently, the only option was to use the b43 driver (developed by the linux community) and extract the firmware from a windows xp driver or use a program called ndiswrapper with the windows xp driver. Because most distros do not include non-free software, in some cases because they cannot legally distribute said software, Broadcom cards pretty much never worked out of the box. Broadcom then released a (proprietary) driver for linux, and those distros (like Ubuntu) that are less strict about free and open software have begun incorporating it, so I believe starting with 9.04, supported Broadcom cards should work out of the box.

    However, adding the proprietary wl driver can be a hassle, especially for new users, because the b43 and wl drivers will conflict, so you need to make sure the wrong one isn't loading, which will generally involve the command line.

  4. $spacer_open
  5. #24
    There is something else that was going on here, and I have a theory on it.

    I believe that the wireless interface on drwolf's system was created using the wl driver. It seems that you cannot easily switch drivers on an existing interface, at least not in Ubuntu. In Fedora I would just open the "Network" GUI and delete the interface, then recreate it using a different driver. How to do this in Ubuntu eludes me. There used to be some config files that you could alter, but those have disappeared in newer Ubuntu versions.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #25
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Boston, MA
    For being "user-friendly" most everything in Ubuntu eludes me. Fedora is an even greater mystery to me.

    In Arch it's just a wee change to /etc/rc.conf...
    MODULES=(!b43 wl)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts