Find the answer to your Linux question:
Results 1 to 8 of 8
can't turn rtl8187b wlan card on under ubuntu 9.04 in Advent 9315 Hello, I have a Advent 9315 laptop with an internal RTL8187B LAN Card (I have tested this, though ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    4

    [SOLVED] can't turn rtl8187b wlan card on under ubuntu 9.04 in Advent 9315


    can't turn rtl8187b wlan card on under ubuntu 9.04 in Advent 9315
    Hello,

    I have a Advent 9315 laptop with an internal RTL8187B LAN Card (I have tested this, though Ubuntu seems to misidentify the card as a Ralink RT25000), where I have just installed a dual-boot system with Ubuntu 9.04 and Windows XP. The card works fine out of the box under Windows. Under Ubuntu too, but here I have an issue that I would like to solve with your help. Given that the FN+F10 hotkey combination to toggle the wifi doesn't work under Ubuntu (the card doesn't appear at all in the list of usb or pci devices), everytime I want to use the card I must restart the computer, go to Windows, press FN+F10 to turn the card on, restart again, and finally go to Ubuntu. The card then works fine, but in an unusual way, because the rt73usb module is loaded, not the rtl8187b one. I can connect to my wlan with proper speed.

    I have noticed that under Ubuntu indeed, when the card is on, if I press FN+F10 the card goes off, but further FN+F10 keystrokes doesn't turn it on again.

    During the installation my only chance to get Ubuntu work in this laptop was setting the noapic nolacpi acpi=off settings. I have heard that that choice can be causing the FN problems.

    My question is: is there any way to activate your internal wlan card under Linux without using the FN hotkeys?

    I would appreciate very much your help.

    ____

    $ lsusb (after activating the card under windows)
    Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
    Bus 001 Device 002: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


    $ lspci
    00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
    00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
    00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
    00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
    00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
    00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
    00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
    00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
    00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
    00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
    01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The rtl8187b chip is a Realtek wireless, and I see no evidence of that on your system.

    As for turning it on when it is shut off, there is a way to do this with a terminal command. The exact command is dependent on the kernel version that you are using, as this method has had some changes recently. Find your kernel version with this command.
    Code:
    uname -r
    You also may find some error messages that can shed some light on the problem, by reading through the output of this command.
    Code:
    dmesg
    It is pretty large, but the network/wireless messages are usually towards the bottom half. Post anything you think may help.

    The other option is to not shut it off. You really only need to shut it off when in certain situations, like an airplane in flight.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I just noticed that your title listed Ubuntu 9.04, which uses a newer kernel.

    The wireless on/off is controlled by the rfkill module. To see the current state of the module, use this command.
    Code:
    sudo cat /sys/class/rfkill/rfkill0/state
    The output should be either a 0 or a 1.

    0 = off
    1 = on

    If off, you can change the state with this command.
    Code:
    sudo echo 1 > /sys/class/rfkill/rfkill0/state
    You now have to unload and reload the driver module. You say it is using the rt73usb driver, so that is the one to unload/load.
    Code:
    sudo modprobe -r rt73usb
    Now reload it.
    Code:
    sudo modprobe rt73usb
    When I try this on my Atheros wireless, it won't work until I reboot it. You may actually have to unload several modules (rt2x00).
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #4
    Just Joined!
    Join Date
    Jul 2009
    Posts
    4
    Thanks Paul for your quick answer.

    I will try that this afternoon (in Spain) when I sit by the laptop in question. The annoying point is that the card shuts off automatically at every shutdown (reboot doesn't turn it off) and it doesn't even shows up after that in lsusb or lshw.

    To be honest I am only guessing when I say that Jaunty misidentifies the chipset of my wlan card. Maybe I am wrong, but the fact is that I have found a couple of posts talking about the same problem in laptops with exactly the same architecture as mine...

    hardware4linux.info/system/3276/

    except for the wireless card. See for example:

    ubuntuforums.org/archive/index.php/t-1038576.html

    The fact is also that I haven't found anywhere that architecture with a Ralink 2500 usb, as Jaunty says. To check my guess I will try to install the RTL8187B linux driver and blacklist the others.

    I will post all the stuff later.

    Carlos

  5. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Enter the system BIOS (at boot). Look for any settings for the wireless network card. Change any that you think may help, like enabling the Wake-on-LAN option for the wireless.

    It seems that this manufacturer re-named laptops made by others. According to this site HERE you can find the name of the manufacturer on the bottom. (It also says that it has a RTL8187b wireless, but we know that's not true! ). There are modules for some laptops to enable the Fn key switches. Not knowing the exact manufacturer means that you don't know what module it is suppose to use. And disabling apci/apic may make this problem worse.

    If I Google your laptop, I see many with the same problem, even in windows. I suspect that you will never be able to get this to work correctly. You may want to consider getting a different wireless card, and avoid the headaches. If there is a PCMCIA slot, then that type of wireless card is good, because it won't stick out too far. Otherwise a USB wireless is what you will want.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #6
    Just Joined!
    Join Date
    Jul 2009
    Posts
    4
    Bad luck for me!

    I have tried everything with no success...

    When the card is off I cannot use the commands

    Code:
    sudo cat /sys/class/rfkill/rfkill0/state
    sudo echo 1 > /sys/class/rfkill/rfkill0/state
    because there is nothing at all inside rfkill.

    I have enabled the 'Wake-On-LAN setting in the BIOS. Nothing.

    The thing that bothers me is that the card can be turned off through FN+F10. So some scripts are working fine in that way but not in the opposite. How could I find them in order to try to fix them or at least to understand the way they work?

    I have found this set of shell scripts in /etc/acpi

    Code:
    ac.d                mailbtn.sh       sleepbtn.sh
    asus-brn-down.sh    mediabtn.sh      sleep.sh
    asus-brn-up.sh      mutebtn.sh       start.d
    asus-touchpad.sh    nextbtn.sh       stopbtn.sh
    asus-wireless-2.sh  panabright.sh    suspend.d
    asus-wireless.sh    panapower.sh     thinkpad-stretchortouchpad.sh
    batterybtn.sh       playbtn.sh       thinkpad-thinkpad.sh
    battery.d           powerbtn.sh      tosh-wireless.sh
    ejectbtn.sh         power.sh         video_brightnessdown.sh
    events              prepare.sh       video_brightnessup.sh
    hibernatebtn.sh     prevbtn.sh       videobtn.sh
    hibernate.sh        resume.d         voldownbtn.sh
    ibm-wireless.sh     resume.sh        volupbtn.sh
    lid.sh              rotatescreen.sh  webbtn.sh
    lockbtn.sh          screenblank.sh   wireless.sh
    I suppose that some of them are responsible for the turning on/off of the card, and one of them can indeed turn the card off. But which of them?

    BTW, I can confirm that I was wrong. The card is certainly a RT73USB card.

  7. #7
    Just Joined!
    Join Date
    Jul 2009
    Posts
    4

    workaround found: updating the U50SI1 BIOS

    Finally Google gave answer to my prayers: updating the notebook BIOS was the solution.

    The most significant feature of the new BIOS is that the wireless is ON by default...

    forum.novatech.co.uk/showthread.php?t=4230

    This update works specifically for model U50SIx (where x=number) notebooks. See the bottom of your notebook to check it out. Follow the instructions. Mine is a U50SI1 and I have done the BIOS flashing with no issues. Now the wireless is always ON at boot. Of course the combination FN+F10 still doesn't work under Ubuntu, but now I can turn the wifi activity off through network-manager or similar.

    Should I add the [SOLVED] mark to the post title?

    Carlos

  8. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You can mark it as solved. If you later come up with more info, remove the solved tag and add the new post.

    First, I'll post the link that you gave, since you haven't yet reached the required post limit.

    U50SI Wireless Default ON BIOS - Novatech Community Forums

    Here is the link to the updated BIOS:

    http://www.e-weekly.co.uk/download/U50SI_V112N.iso

    I find it interesting that your laptop is an Advent brand, but the fix came from Novatech.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •