Find the answer to your Linux question:
Page 1 of 8 1 2 3 4 5 ... LastLast
Results 1 to 10 of 73
I'm a newbie to Linux, and I installed Ubuntu about 2 weeks ago. A few days later, I installed Fedora instead. Since then, my wireless internet has worked fine with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Location
    Drexel Hill, Pennsylvania
    Posts
    35

    [SOLVED] Setting up Wireless on Eee PC 900HD


    I'm a newbie to Linux, and I installed Ubuntu about 2 weeks ago. A few days later, I installed Fedora instead. Since then, my wireless internet has worked fine with no configuration. I could connect perfectly, and there were no problems. A few days ago, though, my wireless stopped working and I can't view any of the networks that I can connect to. When I click on the NetworkManager icon, it says 'Wired Netork - Disconnected'

    I'm sorry if this is a ridiculously simple problem, but I can't figure it out. So how can I set up wireless?

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,043
    Howdy Canas. For the best way to post in this section of the forum you will need to give some more info on what is going on with your EEEpc.

    Follow the instructions from Link Below and Post info in your next post.

    http://www.linuxforums.org/forum/wir...tart-here.html

    I have a EEEPC 900 but I don't run Fedora. So I won't be of much help. But other members who do run Fedora can use the info you provide to point you in the right direction. Good Luck Canas and Howdy and Welcome to the forum.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Since it was working ok, my first thought is that you accidentally turned off the wireless via either a hardware or software kill switch. I'm not familiar with eee pc's specifically, but check for some sort of physical switch on the machine first, then check if there is a key combo that toggles the wireless. On my laptop, it's Fn+F2, which is pretty standard.

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,043
    Yep. on the 900 Fn + F2 toggles the wireless reed.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Just Joined!
    Join Date
    Jul 2009
    Location
    Drexel Hill, Pennsylvania
    Posts
    35
    Thanks for the replies, and yes, I do believe I turned off the Wireless (Pressed fn+F2 to find out what it did), but the problem is that it won't work to turn it back on. I'll post more info to see if it helps.

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Updating the kernel has been known to make wireless stop working also, did Fedora update the kernel?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I have the Eee PC 900, with a Atheros wireless. The driver is included in the kernel, so a kernel update shouldn't make it stop working.

    When I last tried the wireless on/off switch, I had trouble turning it back on. There is a module called rfkill that controls this. To see the state of the module, use this command.
    Code:
    cat /sys/class/rfkill/rfkill0/state
    You should get a reply of 0 or 1.
    0 = wireless off
    1 = wireless on

    You can manually change the state of the rfkill module. To turn the wireless on, use this command.
    Code:
    echo 1 > /sys/class/rfkill/rfkill0/state
    You should unload and reload the wireless modules after changing the rfkill state. I had to reboot before it would work again.

    Because it was such a pain to get it to work again, I never shut it off again. If you use it during an airplane flight, you will need to turn it off. Just copy and save the commands that I gave you, so that you can turn it back on.

    Let us know if this works for you. The rfkill module is still a bit of a mystery to us.
    Last edited by waterhead; 07-19-2009 at 11:00 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #8
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,043
    I even made a text file of your post Waterhead. Thanks a bunch for that one.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  9. #9
    Just Joined!
    Join Date
    Jul 2009
    Location
    Drexel Hill, Pennsylvania
    Posts
    35
    I thought that my problem had finally been solved, but after doing what you said, I got a 1 instead of a 0.

    I guess my wireless is actually turned on, which is disappointing. Thanks for the help, though.

  10. #10
    Just Joined!
    Join Date
    Jul 2009
    Location
    Drexel Hill, Pennsylvania
    Posts
    35
    I have a feeling this has something to do with my troubles.

    UNSUPPORTED CHIPSETS:
    RTL8187SE: This device will work with drivers/staging/rtl8187se, which is the vendor driver converted to compile with a 2.6.29, or later, kernel. A mac80211 version of this kernel is being developed.

    * - 0x10EC,0x8199 and 0x10EC,0x8185 REV_22
    That is the chipset I have.

    Is there anything I can do about this?

Page 1 of 8 1 2 3 4 5 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •