Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 24 of 24
You can connect using wpa_supplicant. First you need to set up a config file, usually in the /etc/wpa_supplicant folder. For examples of config files, check the documentation, usually found in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    You can connect using wpa_supplicant. First you need to set up a config file, usually in the /etc/wpa_supplicant folder. For examples of config files, check the documentation, usually found in /usr/share/doc/wpasupplicant/examples. For WPA TKIP encryption, here is an example>
    Code:
    # WPA-PSK/TKIP
    
    ctrl_interface=/var/run/wpa_supplicant
    
    network={
    	ssid="example wpa-psk network"
    	key_mgmt=WPA-PSK
    	proto=WPA
    	pairwise=TKIP
    	group=TKIP
    	psk="secret passphrase"
    }
    Of course, you need to change the ssid and psk.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #22
    Just Joined!
    Join Date
    May 2009
    Posts
    72
    Back from vacation.
    My colleagues have made it work. I don't know how exactly but after I've settled back in and take knowledge of it I'll post back.

  3. #23
    Just Joined!
    Join Date
    May 2009
    Posts
    72
    Forgot to mention.
    After all of that we went with an Atheros card.

    We put the card in an Ubuntu machine, looked at the wpa_supplicant.conf file that was generated, changed the ssid, username, password info and copied the settings to the imedia setup.

    Code:
    network={
                    ssid="myssid"
                    identity="username"
                    password="password"
                    key_mgmt=WPA-EAP
                    eap=PEAP
                    proto=RSN
    }

  4. $spacer_open
    $spacer_close
  5. #24
    Just Joined!
    Join Date
    May 2009
    Posts
    72
    End result:
    Linux: Voyage 0.6.2
    Kernel: 2.6.26-486-voyage
    Atheros card.

    /etc/wpa_supplicant/wpa_supplicant.conf

    ctrl_interface=/var/run/wpa_supplicant

    network={
    ssid=”MYSSID”
    identity=”USER”
    password=”PASSWORD”
    key_mgmt=WPA-EAP
    eap=PEAP
    proto=RSN
    }

    /etc/network/interfaces

    auto lo
    iface lo inet loopback

    auto ath0
    iface ath0 inet dhcp
    madwifi-base wifi0
    wireless-mode Managed
    up iwconfig ath0 essid MYSSID
    up iwconfig ath0 txpower auto
    up iwconfig ath0 enc off
    up iwconfig ath0 rate auto
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf


    Thanks all for your help

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •