Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21
I have Ubuntu 9.04 on my Eee pC 900. I ran the command: Code: sudo modprobe usbserial vendor=0x12d1 product=0x140b It loaded the module without any error. And I don't even ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    I have Ubuntu 9.04 on my Eee pC 900. I ran the command:
    Code:
    sudo modprobe usbserial vendor=0x12d1 product=0x140b
    It loaded the module without any error. And I don't even have a Huawei modem!

    You must have something else wrong with your system. Did you ever look for the module like I suggested? My system just updated the kernel to 2.6.28-15-generic, so the module is found here:

    /lib/modules/2.6.28-15-generic/kernel/drivers/usb/serial/usbserial.ko

    Your kernel version may be different.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #12
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    OK, I Googled the error that you got, and found that it is a bug in the stock kernel.

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/345002

    It seems that the usbserial driver was changed from a module to a kernel driver. A workaround was given, but the best way to fix this is to update to the most current kernel. Do you have access to a wired internet connection?
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #13
    Just Joined!
    Join Date
    Jun 2009
    Posts
    22
    Sir now I changed my Linux to Sabayon4 . I have all the plugins now. But still I can’t connect to net. The usb modem is recognized as a storage media. I tried “modprobe usbserial vendor=0x12d1 product=0x140b” Then when I tried “wvdial” it said that there is no “ /usb/modem”.

  4. #14
    Just Joined!
    Join Date
    Jun 2009
    Posts
    22
    No i dont have any other net connection. So i switched to Sabayon4. Can you help me in this????

  5. #15
    Just Joined!
    Join Date
    Jun 2009
    Posts
    22
    The bug report says that usbserial driver seems to have been removed from ubuntu 9.04 kernel. so can u suggest to me some other ubuntu versions in which the usb gets detected..? does it work on Ultimate Ubuntu ?

  6. #16
    Just Joined!
    Join Date
    Jun 2009
    Posts
    22
    Can u tel me whether the usb detection can be enabled in Ubuntu 9.04 ? if yes, how can it be done ?

  7. #17
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The Ubuntu bug report that I linked to earlier had a work around:
    As a short term workaround until we can get it added pls try and report back with:

    Built in modules can have module params passed on the kernel command line: can you try booting with:

    usbserial.vendor=0x12d1 usbserial.product=0x1099

    You will need to press ESC during to grub pause upon restart/power on.

    Arrow down to the kernel you wish to boot.

    press "e" (for edit)

    Arrow down to the 2nd line (the command line)

    Press Enter to begin editing

    Arrow to the end of the line and add:

    usbserial.vendor=0x12d1 usbserial.product=0x1099

    When done press enter. Then press "b" to boot
    Make sure that you use the ID numbers for your device, not the ones listed in the workaround. After you get an internet connection, install the latest kernel update.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #18
    Just Joined!
    Join Date
    Jun 2009
    Posts
    22
    I finally managed to connet the net.. I installed wvdial through another,s laptop. And now i am replying through ubuntu.. it works nice.. just install wvdial and the neccessary packages it asks for... Ubuntu is great.. Bye.......

  9. #19
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    So, are you saying that you don't have to load the module with the parameters that I previously mentioned?

    If all you did was install wvdial to get it to work, then you could just use NetworkManager to connect. Right click it and select "Edit Connections". Then select the "Mobile Broadband" tab. Set up a new connection, and it will automatically connect, if you want.

    I was under the impression that is wasn't recognizing your modem, at least that is how I took it. You really should provide more detailed information on how you fixed this, so you can help others in the same position.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #20
    Just Joined!
    Join Date
    Jun 2009
    Posts
    22
    Yes sir its connecting that way also... Sorry to disturb your valuable time.. This works as you said "out of box" in ubuntu 9.04 . No need to do anything just edit the username and password and then get connected..

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •