This is intended for Ubuntu, but it might work for other distro's I am not sure. In place of sudo if you dont have it. use su.

update with: sudo update-manager -d
install ndiswrapper. Find the native windows drivers for your wireless card. in my case i had to use netgears wn311t. When they were extracted i would get netmw14x.inf (the driver).
find out what the device number is (forget what its called exatly) but it will be ####:#### (it will have letters) so do a "lspci -nn" minus the quotes.
it will show a list of stuff with network devices and such, Find your wireless adaptor and on the line with it it will have something like:
00:04.0 Ethernet controller [0200]: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet [1039:0900] (rev 91)

Im not booted into linux so im ssh'd into my shell. but your wireless card will show something like that. note down the numbers nad letters inside the [####:####]

"sudo ndiswrapper -i driver.inf" (/etc/ndiswrapper will create a folder named "netmw14x" inside it. make sure you are in the directory with the driver file. and dont forget the .inf part).

"sudo ndiswrapper -a 11ab:2a08 netmw14x" (lspci -nn will show device ids. with different versions of ndiswrapper it might be -d. but do sudo ndiswrapper -a or -d depending on your version. "ndiswrapper -a ####:#### driver" notice the driver on this one doesnt have the .inf part )

"sudo ndiswrapper -l" will now say the device is present and it can be configured normally.

after that you'll want to edit your network manager so you can use it with the wireless adaptor. so do

sudo gedit /etc/NetworkManager/nm-system-settings.conf
under [ifupdown], change managed=true

after youll want to add your alias with ndiswrapper so

"sudo ndiswrapper -m"

next youll want to make the module dependencies (its like a makefile) so do:

"sudo depmod -a"

and then youll want to load the modules so it will work:

"sudo modprobe ndiswrapper"

and then

"sudo ifup wlan0"


an overview of commands

1. sudo apt-get install ndiswrapper-common
2. sudo ndiswrapper -i driver.inf
3. lspci -nn (note down the device id)
4. sudo ndiswrapper -a ####:#### driver
5. sudo ndiswrapper -m
6. sudo gedit /etc/NetworkManager/nm-system-settings.conf (change managed to true)
7. sudo depmod -a
8. sudo modprobe ndiswrapper
9. sudo ifup wlan0

and your wireless should show up in the network manager

[edit] atleast thats all waht worked for me. i tried for months to get wireless to work and it wouldnt. the only thing i didnt do was change the managed to true which made it work. an easier way to install the driver though is using ndisgtk so you dont have to go through all the hassle of running commands. as it says ndisgtk gimp toolkit so its for x instead of a command line.