Find the answer to your Linux question:
Results 1 to 3 of 3
Hey everyone, so I ran that command lspci -knn and here are the results. I would very much like to run OpenSuse 11 if it's possible. Right now I am ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    1

    WiFi on Samsung 120 Netbook with lspci -knn


    Hey everyone, so I ran that command lspci -knn and here are the results. I would very much like to run OpenSuse 11 if it's possible. Right now I am running EEEbuntu and I don't really like it that much. Can anyone tell me what the next step is that I have to take to make wireless work for OpenSuse 11?

    02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter [168c:001c] (rev 01)

  2. #2
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    I found this on OpemSuse forums How to make stubborn atheros ar242 (5211) work - solution - openSUSE Forums I copied the relevant fix.

    Steps to install MadWifi driver for Atheros Wireless:

    (This is given as performed on a KDE 3.5.9 installation.
    The applications *should* be similar for Gnome and KDE 4.x)

    1. Blacklist the 'ath5k' driver
    From a terminal:
    su - root
    {supply password}
    echo "blacklist ath5k" > /etc/modprobe.d/ath5k
    uname -r
    {remember whether it says '-default' or '-pae'}

    2. Add the MadWifi Repository and software
    Start the YaST Setup Program
    -> Software Management
    -> click on 'Repositories' (top menu)
    -> click on 'Repository Manager'
    -> click on 'Add' button, towards bottom
    -> verify 'Specify URL' selected
    -> url is 'http://madwifi.org/suse/11.0'
    -> enter a name, 'Madwifi' works
    -> click on 'Next', returns to list of current repos
    -> click on 'Ok', returns to software installation page
    -> click in Search box, enter 'madwifi', click 'Search'
    -> depending on remembered entry from above:
    -> select either 'madwifi-kmp-default'
    or 'madwifi-kmp-pae'
    -> click on 'Accept', bottom right
    If it pops up a window saying
    'these packages were needed too', say 'Ok'
    -> wait briefly while drivers are downloaded and installed
    -> exit from 'YaST control center'

    3. Reboot

    4. Using YaST -> Network Devices -> Network Settings
    -> On the 'Global Settings' tab, choose Traditional
    or network-manager mode for control
    -> For Traditional, set up your wireless nic on the
    'Overview' tab.
    -> For network-manager mode, setup is done on your
    Desktop, via the 'knetwork-manager' application
    in the tray next to the clock.

    5. Some Caveats....
    knetwork-manager (the green globe) has been known to be
    'reluctant' to automatically connect. This should be
    resolved soon, but you may need to manually choose a
    network to connect to at startup for now.
    =================8<==========>8===================

    There's a very good chance that your Atheros wireless will work if you'll
    follow these instructions.
    Registered Linux User #420832

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I have the exact same wireless in my Eee PC 900. It did not work with the stock MadWifi driver. If you read the original thread link that Hal343 gave, this problem was reported by several people.

    My experience with this wireless is on Red Hat/Fedora and Ubuntu, not Suse. But since it is a kernel module, the driver is the same on all similar kernel versions. You have two options, both of them require compiling the driver from source.

    Download and compile madwifi-hal-testing (ath_pci) from here:
    snapshots.madwifi.org

    Download and compile the compat-wireless driver package, which contains the newest version of the Atheros ath5k driver:
    Download - Linux Wireless

    I recommend using the newest version of the ath5k driver. The madwifi driver is being phased out, and will eventually be discontinued.
    Last edited by waterhead; 08-18-2009 at 10:58 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •