Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
This problem may be from the wireless being turned off. If there is an On/Off switch, make sure it is turned on. You may want to try this: Turn it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    This problem may be from the wireless being turned off. If there is an On/Off switch, make sure it is turned on. You may want to try this:

    Turn it off
    reboot
    turn it on
    reboot

    Or something like that. If it uses shortcut keys to enable/disable the wireless, try those too. They most likely won't work, though.

    The driver does have an enable/disable option. You can see all of the module options with this command.
    Code:
    modinfo ipw2200
    There is this line:
    Code:
    parm:           disable:manually disable the radio (default 0 [radio on]) (int)
    I'm not sure exactly how to do this, but first you have to unload the module.
    Code:
    sudo modprobe -r ipw2200
    Then reload it with the option.
    Code:
    sudo modprobe ipw2200 disable=0
    Sometime when enabling/disabling the wireless, you need to reboot.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #12
    Just Joined!
    Join Date
    Aug 2009
    Posts
    11

    Wireless now active - but wifi cards are not present

    Quote Originally Posted by waterhead View Post
    This problem may be from the wireless being turned off. If there is an On/Off switch, make sure it is turned on. You may want to try this:

    Turn it off
    reboot
    turn it on
    reboot

    Or something like that. If it uses shortcut keys to enable/disable the wireless, try those too. They most likely won't work, though.

    The driver does have an enable/disable option. You can see all of the module options with this command.
    Code:
    modinfo ipw2200
    There is this line:
    Code:
    parm:           disable:manually disable the radio (default 0 [radio on]) (int)
    I'm not sure exactly how to do this, but first you have to unload the module.
    Code:
    sudo modprobe -r ipw2200
    Then reload it with the option.
    Code:
    sudo modprobe ipw2200 disable=0
    Sometime when enabling/disabling the wireless, you need to reboot.

    Paul, this is just great!
    modprobe solved the wireless enabling. I ran first
    Code:
    modprobe -r ipw2200
    then
    Code:
    modprobe -r ipw2200
    and the wireless is now on. Good job!

    Now I guess I have to work on
    Code:
    modinfo ipw2200
    because there are no wireless networks detected, or better said my 2 network cards do not appear when I click (right) on the NetworkManagerApplet. If I try to make a new connection, no cards appear.
    What would be the string using modinfo and modprobe to use the associate and auto-create?


    Code:
    root@jlm-amilo:/home/jlm# modinfo ipw2200
    filename:       /lib/modules/2.6.28-15-generic/kernel/drivers/net/wireless/ipw2200.ko
    license:        GPL
    author:         Copyright(c) 2003-2006 Intel Corporation
    version:        1.2.2kmprq
    description:    Intel(R) PRO/Wireless 2200/2915 Network Driver
    srcversion:     BA4E502DB2F58E9203E942E
    alias:          pci:v00008086d00004224sv*sd*bc*sc*i*
    alias:          pci:v00008086d00004223sv*sd*bc*sc*i*
    alias:          pci:v00008086d00004221sv*sd*bc*sc*i*
    alias:          pci:v00008086d00004220sv*sd*bc*sc*i*
    alias:          pci:v00008086d0000104Fsv*sd*bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002762bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002761bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002754bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002753bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002752bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002751bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002742bc*sc*i*
    alias:          pci:v00008086d00001043sv0000103Csd00002741bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002741bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002732bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002731bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002722bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002721bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002712bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002711bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002702bc*sc*i*
    alias:          pci:v00008086d00001043sv00008086sd00002701bc*sc*i*
    depends:        ieee80211
    vermagic:       2.6.28-15-generic SMP mod_unload modversions 586 
    parm:           disable:manually disable the radio (default 0 [radio on]) (int)
    parm:           associate:auto associate when scanning (default on) (int)
    parm:           auto_create:auto create adhoc network (default on) (int)
    parm:           led:enable led control on some systems (default 1 on) (int)
    parm:           debug:debug output mask (int)
    parm:           channel:channel to limit associate to (default 0 [ANY]) (int)
    parm:           rtap_iface:create the rtap interface (1 - create, default 0) (int)
    parm:           qos_enable:enable all QoS functionalitis (int)
    parm:           qos_burst_enable:enable QoS burst mode (int)
    parm:           qos_no_ack_mask:mask Tx_Queue to no ack (int)
    parm:           burst_duration_CCK:set CCK burst value (int)
    parm:           burst_duration_OFDM:set OFDM burst value (int)
    parm:           mode:network mode (0=BSS,1=IBSS,2=Monitor) (int)
    parm:           bt_coexist:enable bluetooth coexistence (default off) (int)
    parm:           hwcrypto:enable hardware crypto (default off) (int)
    parm:           cmdlog:allocate a ring buffer for logging firmware commands (int)
    parm:           roaming:enable roaming support (default on) (int)
    parm:           antenna:select antenna 1=Main, 3=Aux, default 0 [both], 2=slow_diversity (choose the one with lower background noise) (int)

  3. #13
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The modinfo command will only give information about the kernel module. It will also list any parameter (parm) options that the module has, if any.

    I am not sure why NetworkManager is not seeing it. How did you determine that the card is now working, if NetworkManager is not showing anything? Did you right-click the NM icon and make sure "Enable Wireless" is checked? Unless you posted it incorrectly, the second modprobe command should be without the -r option, as this removes the module.

    Run these commands, and post the output,
    Code:
    ifconfig
    Code:
    iwconfig
    And this command will show available networks, if the wireless is working. It may also show network info that you may not want to post, so edit out that stuff.
    Code:
    iwlist scan
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Aug 2009
    Posts
    11

    Wifi ipw2200 not active

    I ran
    Code:
     
    tail -300 /var/log/messages
    to check for conflicts/error status and I noticed the following concerning the ipw2000:
    ...
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.271834] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.271838] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.272373] ipw2200 0000:01:03.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.273297] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.273338] ipw2200 0000:01:03.0: firmware: requesting ipw2200-bss.fw
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.282682] iTCO_vendor_support: vendor-support=0
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.284708] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.05
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.284841] iTCO_wdt: Found a ICH6-M TCO device (Version=2, TCOBASE=0x0860)
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.284929] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.521853] ipw2200: Radio Frequency Kill Switch is On:
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.521856] Kill switch must be turned off for wireless networking to work.

    Aug 23 17:07:50 jlm-amilo kernel: [ 15.523925] ipw2200: Detected geography ZZR (14 802.11bg channels, 0 802.11a channels)
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.669611] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    Aug 23 17:07:50 jlm-amilo kernel: [ 15.940299] lp: driver loaded but no devices found

    ...

  6. #15
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    That is why I asked you to load the module with the disable=0 option. You didn't mention if you had tried that, and your post suggested that you didn't.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #16
    Just Joined!
    Join Date
    Aug 2009
    Posts
    11
    Quote Originally Posted by waterhead View Post
    The modinfo command will only give information about the kernel module. It will also list any parameter (parm) options that the module has, if any.

    I am not sure why NetworkManager is not seeing it. How did you determine that the card is now working, if NetworkManager is not showing anything? Did you right-click the NM icon and make sure "Enable Wireless" is checked? Unless you posted it incorrectly, the second modprobe command should be without the -r option, as this removes the module.

    Run these commands, and post the output,
    Code:
    ifconfig
    Code:
    iwconfig
    And this command will show available networks, if the wireless is working. It may also show network info that you may not want to post, so edit out that stuff.
    Code:
    iwlist scan


    After I used modeprobe, the wireless tickbox came back to life (right click allows me to enable/disable the wireless), so I thought that I would be able to configure again wireless networks, but the when I click (left) on NM, it shows my different Mobile Broadband connections available (that is what I use right now) , and wired (which is correct) and Wireless Networks greyed out and no wifi devices. I used to see my two wifi devices before (8.10, and 8.10 upgraded 9.04).

    I really appreciate your help, I feel somehow "dumb" on this issue.
    /jlm


    Code:
    root@jlm-amilo:/home/jlm# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:03:0d:30:a7:35  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:19 Base address:0xac00 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:1302 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1302 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:538070 (538.0 KB)  TX bytes:538070 (538.0 KB)
    
    ppp0      Link encap:Point-to-Point Protocol  
              inet addr:10.42.6.203  P-t-P:10.64.64.64  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
              RX packets:20384 errors:0 dropped:0 overruns:0 frame:0
              TX packets:18953 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3 
              RX bytes:18062432 (18.0 MB)  TX bytes:2980575 (2.9 MB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:0f:b5:00:ef:ad  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    wmaster0  Link encap:UNSPEC  HWaddr 00-0F-B5-00-EF-AD-00-00-00-00-00-00-00-00-00-00  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    
    
    Code:
    root@jlm-amilo:/home/jlm#
    root@jlm-amilo:/home/jlm# iwconfig lo no wireless extensions. eth0 no wireless extensions. pan0 no wireless extensions. ppp0 no wireless extensions. wmaster0 no wireless extensions. wlan0 IEEE 802.11bg ESSID:"" Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated Tx-Power=20 dBm Retry min limit:7 RTS thr:off Fragment thr=2352 B Encryption key:off Power Management:off Link Quality:0 Signal level:0 Noise level:0 Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0 root@jlm-amilo:/home/jlm#
    Code:
    root@jlm-amilo:/home/jlm# iwlist scan
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    pan0      Interface doesn't support scanning.
    
    ppp0      Interface doesn't support scanning.
    
    wmaster0  Interface doesn't support scanning.
    
    wlan0     No scan results
    
    root@jlm-amilo:/home/jlm#

  8. #17
    Just Joined!
    Join Date
    Aug 2009
    Posts
    11
    Sorry, my typing mistake. I used the modprobe ipw2200 disable=0 fine.

  9. #18
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like the wireless card is working, but that there are no wireless networks to connect to. Is this the case?

    I don't know if your card supports the rfkill module, but run this command and see what you get. It should give a 0 or a 1.
    Code:
    cat /sys/class/rfkill/rfkill0/state
    0 = off
    1 = on

    Edit: I see that you are running the commands as root. Don't run them as root unless you have to.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #19
    Just Joined!
    Join Date
    Aug 2009
    Posts
    11
    No my rfkill directory is empty. But I found a load of rfkill directories and files, only one is an executable (hald-addon-rfkill-killswitch), others are C header (.h) or object code (ko).

    Meanwhile I had a try using the Windows drivers with Windows Wireless drivers util (like I did before, I choose the XP driver which then shows when installed as w29n51). And result is identical to what I had with Ubuntu 8.10, it enables both devices (intel & netgear) but... only the Netgear can connect!

  11. #20
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    If you are going to use NDISwrapper, then you must disable and remove the Linux driver that it is replacing. Failure to do this will effectively load two drivers for the one device, confusing the system and keeping the device from working.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •