Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 37
When using ls, red indicates an archive, so that's normal. More info on that: Where is color of ls command defined? I'm at work on a windows machine, but I'll ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651

    When using ls, red indicates an archive, so that's normal.
    More info on that: Where is color of ls command defined?

    I'm at work on a windows machine, but I'll download the file when I get home and see about extracting it.

    I'm still thinking a permissions problem. Post the output of
    Code:
    ls -l
    (That's a lower case L, not a 1.)

  2. #22
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I am at work/windows too.

    You should be able to right-click on the archive, and select extract (here). Otherwise the command that reed9 gave you should have worked. You don't need root privileges to extract this archive (I didn't).

    First make sure that the terminal is directed to your home directory.
    Code:
    cd ~/
    Then this command should unpack the archive file.
    Code:
    tar xvfj 2009_0820_RT2870_Linux_STA_V2.2.0.0.tar.bz2
    Then point the terminal to the folder that the archive was unpacked to.
    Code:
    cd 2009_0820_RT2870_Linux_STA_V2.2.0.0
    Then you can follow the instructions on building the driver module. To build it, you first should have these installed:

    linux-source
    kernel-headers-`uname -r` (Those are backticks surrounding the uname command)
    build-essential

    Follow the README instructions that come with the source code. I gave some details on how I did it in one of my earlier posts, as the instructions aren't exactly correct.
    Last edited by waterhead; 08-28-2009 at 09:31 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #23
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I just downloaded the file and extraced it with the command I gave above without problems. I would try downloading it again. Possibly to a separate clean folder, so it's very clear where and which file it is.

  4. #24
    Just Joined!
    Join Date
    Mar 2009
    Location
    madrid
    Posts
    35
    Hi, ok, thanks so much for helping me with this.
    Now,- I've got it un-packed - I had to give up trying to do it in the terminal and did it with the manager. At first I opened the file ''read me'' and then opened the file Makefile - but not in the terminal. In read me, it says ''2> In Makefile
    set the "MODE = STA" in Makefile and chose the TARGET to Linux by set "TARGET = LINUX"
    define the linux kernel source include file path LINUX_SRC
    modify to meet your need.''
    I do not know why it says ''modify to meeet your needs'' because mode sta and target linux was already as that. - Then,- Define the linux kernet source include file path LINUX_SRC, not sure about this: the file that I downloaded is already in the src directory.

    Then I went to no.3 in the Makefile directory. (again, not by the terminal). - This part I dont understand: define the GCC and LD of the target machine
    define the compiler flags CFLAGS
    modify to meet your need. - dont know what gcc or ld is, or compile flags.
    These to orders I managed to change to ''y'': HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
    But then because Im not in terminal I didn't quite get, understand this bit: => #>cd wpa_supplicant-x.x
    => #>./wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d

    ( as you see from this terminal, I can not get there in terminal):
    boo@boo-laptop:~$ cd src
    boo@boo-laptop:~/src$ cd 2009_0820_RT2870_Linux_STA_V2.2.0.0
    boo@boo-laptop:~/src/2009_0820_RT2870_Linux_STA_V2.2.0.0$ cd Makefile
    bash: cd: Makefile: No es un directorio
    boo@boo-laptop:~/src/2009_0820_RT2870_Linux_STA_V2.2.0.0$ Makefile
    bash: Makefile: orden no encontrada
    boo@boo-laptop:~/src/2009_0820_RT2870_Linux_STA_V2.2.0.0$ /Makefile
    bash: /Makefile: No existe el fichero directorio
    boo@boo-laptop:~/src/2009_0820_RT2870_Linux_STA_V2.2.0.0$

    Its all just getting so confusing! (orden no encontrado means the order isn't found)

    And I move on to this: ** Build for being controlled by WpaSupplicant with Ralink Driver
    Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.
    => #>cd wpa_supplicant-0.5.7
    => #>./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d
    But again it looks like I should be in a directory in the terminal.
    At this point I've stopped. Took a day away from sitting at the pc all day. Its not easy, is it learning all this!? But Im happy to have come this far since trying out ubuntu at xmas for first time, and not having any idea what a terminal, or architecture meant.

  5. #25
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    these to orders I managed to change to ''y'': HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

    And I move on to this: ** Build for being controlled by WpaSupplicant with Ralink Driver
    Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.
    => #>cd wpa_supplicant-0.5.7
    => #>./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d
    Set the two options to "y" as you did in the first set, then ignore the second set.

    As far as I can tell looking at it, these are pretty much the only changes you need to make. The defaults in the Makefile should be fine.

    After that change, it looks like you should just be able to open the terminal to the main build directory and do
    make
    sudo make install

  6. #26
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Here's some detailed instructions:

    Upack the downloaded file with this command.
    Code:
    tar xvfj 2009_0820_RT2870_Linux_STA_V2.2.0.0.tar.bz2
    Then move the terminal to the new folder that the unpacked files are in.
    Code:
    cd 2009_0820_RT2870_Linux_STA_V2.2.0.0
    You now should switch to a file browser and go to that same folder. Then look in the folder /os/linux for the config.mk file. Open it in a text editor, and in the third paragraph change this:

    HAS_WPA_SUPPLICANT=n

    To this:
    HAS_WPA_SUPPLICANT=y

    And in the fourth paragraph, change this:
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n

    To this:
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

    Save the file and close it. Now go back to the terminal, compile the driver with this command. You need root permissions to do this, otherwise it exits with a permissions error, so use sudo or su to gain root permissions:
    Code:
    sudo make
    When complete, you can install the compiled driver.
    Code:
    sudo make install
    When done, you can manualy load the new driver.
    Code:
    sudo modporobe rt2870sta
    Now try your wireless again. It may not automatically load the module at boot. But if it works everytime you manually load the module, we can fix that.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #27
    Just Joined!
    Join Date
    Mar 2009
    Location
    madrid
    Posts
    35
    brilliant! first time it all happened without seeing any errors. - But the wireless device is still not being seen. I put here the results of modprobe first:
    boo@boo-laptop:~$ sudo modprobe rt2870sta
    [sudo] password for boo:
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.5, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.1, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.4, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.3, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/ralink, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.2, it will be ignored in a future release.
    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 10: ignoring bad line starting with 'wget'
    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 11: ignoring bad line starting with 'tar'
    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 12: ignoring bad line starting with 'cd'
    boo@boo-laptop:~$

    Im assuming that I now have to do something about this black list stuff? What do you guys think? Once again many thanks.

  8. #28
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    After you modprobe the module, check the output of lsmod and iwconfig.

    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save, it will be ignored in a future release.
    These errors just mean that in the near future, the files in /etc/modprobe.d/ will need to end with the extension .conf to be recognized. These files contain various options for modules, or blacklists of modules you don't want to load.

    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 10: ignoring bad line starting with 'wget'
    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 11: ignoring bad line starting with 'tar'
    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 12: ignoring bad line starting with 'cd'
    This means you have some config files in /etc/modprobe.d/ with some weird extraneous stuff in them. If you open up the files mentioned, you'll see lines beginning with wget, tar, and cd, which the system doesn't know what to do with. None of those lines should be in these files. Did you edit the files in /etc/modprobe.d/?

  9. #29
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I also got the warning about the /etc/modprobe.conf file, but not the others. I think that the driver installation is creating that file. This did not prevent the module from loading.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #30
    Just Joined!
    Join Date
    Mar 2009
    Location
    madrid
    Posts
    35
    Hi, no I haven't edited any files. I just saw what waterhead said and he says it didn't affect the module from loading. Now, I just did a lsmod and straight away I see the module there, a good sign for sure, I think! Then I did the iwconfig and it still does not say anything of my linksys dongle.- But I'm using the in built broadcom 4312 to connect at this moment. When I wasn't connected earlier I did try iwconfig though and it still didn't say anything about the dongle.
    boo@boo-laptop:~$ sudo modprobe rt2870sta
    [sudo] password for boo:
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.5, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.1, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.4, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.3, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/ralink, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist-rt73.conf.save.2, it will be ignored in a future release.
    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 10: ignoring bad line starting with 'wget'
    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 11: ignoring bad line starting with 'tar'
    WARNING: /etc/modprobe.d/blacklist-rt73.conf.save line 12: ignoring bad line starting with 'cd'
    boo@boo-laptop:~$ lsmod
    Module Size Used by
    rt2870sta 508244 0
    binfmt_misc 16776 1
    ppdev 15620 0
    bridge 56212 0
    stp 10500 1 bridge
    bnep 20224 2
    input_polldev 11912 0
    lp 17156 0
    parport 42220 2 ppdev,lp
    snd_hda_intel 434100 3
    snd_pcm_oss 46336 0
    snd_mixer_oss 22656 1 snd_pcm_oss
    snd_pcm 83076 2 snd_hda_intel,snd_pcm_oss
    snd_seq_dummy 10756 0
    snd_seq_oss 37760 0
    snd_seq_midi 14336 0
    snd_rawmidi 29696 1 snd_seq_midi
    snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
    uvcvideo 63368 0
    snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    snd_timer 29704 2 snd_pcm,snd_seq
    snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    leds_hp_disk 10756 0
    led_class 12036 1 leds_hp_disk
    psmouse 61972 0
    compat_ioctl32 9344 1 uvcvideo
    ieee80211_crypt_tkip 16896 0
    joydev 18496 0
    snd 62756 15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,sn d_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_de vice
    soundcore 15200 1 snd
    video 25360 4
    output 11008 1 video
    iTCO_wdt 19108 0
    iTCO_vendor_support 11652 1 iTCO_wdt
    sdhci_pci 15232 0
    sdhci 23940 1 sdhci_pci
    serio_raw 13444 0
    videodev 41600 1 uvcvideo
    v4l1_compat 21764 2 uvcvideo,videodev
    nvidia 7233756 39
    wl 1281364 0
    ieee80211_crypt 13444 2 ieee80211_crypt_tkip,wl
    intel_agp 34108 0
    snd_page_alloc 16904 2 snd_hda_intel,snd_pcm
    usbhid 42336 0
    pcspkr 10496 0
    lis3lv02d 17848 0
    agpgart 42696 2 nvidia,intel_agp
    ohci1394 38576 0
    ieee1394 94660 1 ohci1394
    r8169 40836 0
    mii 13312 1 r8169
    fbcon 46112 0
    tileblit 10752 1 fbcon
    font 16384 1 fbcon
    bitblit 13824 1 fbcon
    softcursor 9984 1 bitblit
    boo@boo-laptop:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11 Nickname:""
    Access Point: Not-Associated
    Link Quality:1 Signal level:175 Noise level:165
    Rx invalid nwid:0 invalid crypt:0 invalid misc:0

    pan0 no wireless extensions.

    boo@boo-laptop:~$

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •