Find the answer to your Linux question:
Results 1 to 10 of 10
When I start linux in the interactive mode, I can see that eth0 and some other network devices are brought up but the wlan0 device fails to be brought up. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    8

    Wireles internet on redhat linux


    When I start linux in the interactive mode, I can see that eth0 and some other network devices are brought up but the wlan0 device fails to be brought up.

    The following messages are displayed while linux starts and also when I try to manually run the wpa_supplicant command:


    Code:

    [root_localhost ~]# wpa_supplicant -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

    ioctl[SIOCSIWPMKSA]: No such device
    ioctl[SIOCSIWMODE]: No such device
    Could not configure driver to use managed mode
    ioctl[SIOCGIFFLAGS]: No such device
    Could not set interface 'wlan0' UP
    ioctl[SIOCGIWRANGE]: No such device
    ioctl[SIOCGIFINDEX]: No such device
    ioctl[SIOCSIWENCODEEXT]: No such device
    ioctl[SIOCSIWENCODE]: No such device
    ioctl[SIOCSIWENCODEEXT]: No such device
    ioctl[SIOCSIWENCODE]: No such device
    ioctl[SIOCSIWENCODEEXT]: No such device
    ioctl[SIOCSIWENCODE]: No such device
    ioctl[SIOCSIWENCODEEXT]: No such device
    ioctl[SIOCSIWENCODE]: No such device
    ioctl[SIOCSIWAUTH]: No such device
    WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
    ioctl[SIOCSIWAUTH]: No such device
    WEXT auth param 5 value 0x0 - ioctl[SIOCSIWAUTH]: No such device
    WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAP]: No such device
    ioctl[SIOCGIFFLAGS]: No such device

    I am not able to start wireless internet on linux.

  2. #2
    Just Joined!
    Join Date
    Sep 2009
    Posts
    8
    More info:

    card type - I think built in (it has a ON/OFF switch)
    Name - Intel(R) PRO/Wireless 3945ABG Network Connection

    Code:
    lspci | grep 3945
    I get:

    Code:
    05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
    Code:
    cat /etc/wpa_supplicant/wpa_supplicant.conf
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    
    network={
    
    
    
    ssid="MyHomeNetworkName"
    
    scan_ssid=1 
    
    key_mgmt=WPA-PSK
    
    psk="MyHomeNetworkPassword"
    
    }
    
    #network={
    #       ssid="any"
    #       key_mgmt=NONE
    #}
    
    
    
    
    
    [root@localhost /]# cat ./etc/modprobe.conf
    alias eth0 b44
    alias scsi_hostadapter ata_piix
    alias snd-card-0 snd-hda-intel
    options snd-card-0 index=0  
    options snd-hda-intel index=0  
    remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel
    alias wlan0 wificard

  3. #3
    Just Joined!
    Join Date
    Sep 2009
    Posts
    8
    more info:

    Code:
    [root@localhost v32]# ndiswrapper -l
    netw3 : driver installed
            device (8086:4222) present
    netw5v32 : driver installed
            device (8086:4222) present
    [root@localhost v32]# iwconfig
    
    lo        no wireless extensions.
    eth0      no wireless extensions.
    sit0      no wireless extensions.
     
    [root@localhost v32]# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:16:D4:DE:04:2D  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:58 
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:2056 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2056 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:2476700 (2.3 MiB)  TX bytes:2476700 (2.3 MiB)

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    NDISwrapper?

    Are you sure that there isn't an existing kernel module loading for it?

    Read the post linked to below, and post the info that it tells how to find.

    http://www.linuxforums.org/forum/wir...tart-here.html
    Last edited by waterhead; 09-14-2009 at 02:01 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Sep 2009
    Posts
    8
    Hi Waterhead,

    I have attached some files which contain the o/p of the following commands:

    Code:
    lspci
    lspci -n
    lsmod


    Code:
    [root@localhost ~]# uname -r
    2.6.18-53.el5
    dmesg gave a very large o/p
    The o/p is at:

    unix.cooom/attachments/red-hat/1116d1252919311-wireless-internet-redhat-linux-dmesg.txt

    dmesg | grep firmware gave out nothing
    Attached Files Attached Files

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    There are no wireless drivers loading. That is why there is no working wireless device.

    I recommend installing the Intel Linux iwl3945 driver. It can be downloaded from here (Download the iwlwifi-1.2.25.tgz file):

    Intel® Wireless WiFi Link drivers for Linux*

    You also must install the mac80211 subsystem and the firmware for your card. Both are available on the same page as the driver.

    Follow the instructions on the Intel web site, or look in the driver files for an instruction file named INSTALL. You will be compiling a kernel module, so you will need to have these installed FIRST:

    kernel source
    kernel headers
    gcc
    make

    You build the driver by first unpacking the driver files:
    Code:
     tar xvfz iwlwifi-1.2.25.tgz
    Then point the terminal to the new driver folder:
    Code:
    cd iwlwifi-1.2.25
    Compile the driver with the make command:
    Code:
    make
    After that process is finished you can install the newly compiled driver. You must now obtain root privileges using thesu command. The root password will remain hidden as you type it in:
    Code:
    su <enter>
    Password: <type root password here>
    Now you can install the driver:
    Code:
    make install
    Do the same for the mac80211 subsystem. You don't need root privileges to compile it, so exit from the root privileges before you run the makecommand. Gain root privilege again to install it. The reason for NOT running make as root is because you don't need it, and it will create files owned by root. These will be difficult to remove after you have finished installing the driver.

    The firmware can just be unpacked and used, no compiling needed. Copy the iwlwifi-3945-2.ucode file to the /lib/firmware folder. You will need root privilege to do this too.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Just Joined!
    Join Date
    Sep 2009
    Posts
    8
    Thanks Waterhead.

    I did the following to install mac80211:

    After tar..

    Code:
    cd mac80211-10.0.4
    make patch_kernel
    cd /lib/modules/$(uname -r)/build
    make menuconfig
    saved and exited

    I got the below mentioned error:

    Code:
    [root@localhost build]# make modules
      HOSTLD  scripts/kconfig/conf
    scripts/kconfig/conf -s arch/i386/Kconfig
    net/mac80211/Kconfig:5:warning: 'select' used by config symbol 'MAC80211' refer to undefined symbol 'CRYPTO_ECB'
    net/mac80211/Kconfig:11:warning: 'select' used by config symbol 'MAC80211' refer to undefined symbol 'NET_SCH_FIFO'
      CHK     include/linux/version.h
      CHK     include/linux/utsrelease.h
      HOSTCC  scripts/genksyms/genksyms.o
      HOSTCC  scripts/genksyms/lex.o
      HOSTCC  scripts/genksyms/parse.o
      HOSTLD  scripts/genksyms/genksyms
      CC      scripts/mod/empty.o
      MKELF   scripts/mod/elfconfig.h
      HOSTCC  scripts/mod/file2alias.o
      HOSTCC  scripts/mod/modpost.o
      HOSTCC  scripts/mod/sumversion.o
      HOSTLD  scripts/mod/modpost
    make[1]: *** No rule to make target `arch/i386/kernel/msr.c', needed by `arch/i386/kernel/msr.o'.  Stop.
    make: *** [arch/i386/kernel] Error 2

  9. #8
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    When you ran the make menuconfig, did you have root permissions? Also, there may have been some options that you needed to enable. Normally a [M] is used to configure it as a module.

    I can't be more specific right now. I am at work, and no Linux boxes to check this out for you.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #9
    Just Joined!
    Join Date
    Sep 2009
    Posts
    8
    Waterhead,

    Many thanks for all the efforts.
    I had root permissions but I did not set the parameters which you asked me to in your last post.
    I had seen those instructions in the insallation manual but I thought they were not mandatory.
    I also fetched and installed the uCode. But after which the following command took a lot of time and freezed the system:
    Code:
    ./load debug=0
    So,I restarted the system and the system threw many errors and I saw a kernel panic message as well.

    The good news is that I installed Fedora and withought any configuration do do.
    And I am writing this message via Fedora via firefox

    Many thanks for all the help, Waterhead.

    Regards,
    Girish S.

  11. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I usually tell people to use Fedora instead of RHEL. You will be better off with the latest version of Fedora.

    Enjoy!
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •