Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
Computer: HP Compaq nc6000 Linux distro: OpenSUSE 11.0 Problem description: With WPA encription enabled I have no internet access, although the wireless lan is connected. However when the encription is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    156

    Arrow Wireless lan connected but no internet


    Computer: HP Compaq nc6000
    Linux distro: OpenSUSE 11.0

    Problem description: With WPA encription enabled I have no internet access, although the wireless lan is connected. However when the encription is disabled I have normal internet access.

    By the way, Windows XP on the same machine, and also another linux machine (openSUSE 11.0 too), both have normal internet access when WPA encription is used.

    Can someone help me solve this problem?
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Is the Device recognized and set up properly? Do you have wpa_supplicant installed on both machines? Can you copy the wpa_supplicant.conf from the working machine to the non working machine?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    156
    Could you point me to the location of wpa_supplicant.conf?

    I believe the device is set up properly because it registers with the wireless assess point. I have exactly the same YAST Network Settings on both machines (at least the settings that are available to the user).
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  4. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Mine is located at /etc/wpa_supplicant/wpa_supplicant.conf

    You can try
    Code:
    whereis wpa_supplicant
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  5. #5
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    156
    /etc/wpa_supplicant/wpa_supplicant.conf is identical on both computers and it contains the following lines:
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    I have collected some more information from both computers. I hope it contains some useful clues.

    On the HEALTHY computer
    ************************************************** ************************************************** **
    iwconfig produces the following output:
    (the encryption key is masked, but shows the actual length)
    Code:
    wlan0     IEEE 802.11g  ESSID:"BLNL"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 00:22:57:1F:A6:F1   
              Bit Rate=48 Mb/s   Tx-Power=27 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
              Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX [2]
              Link Quality=71/100  Signal level=-50 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Network Manager shows the following connection info:

    ************************************************** ************************************************** **


    On the FAULTY computer
    ************************************************** ************************************************** **
    iwconfig produces the following output:
    (the encryption key is masked, but shows the actual length)
    Code:
    eth1      IEEE 802.11g  ESSID:"BLNL"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 00:22:57:1F:A6:F1   
              Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
              Retry limit:7   RTS thr:off   Fragment thr:off
              Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX   Security mode:open
              Power Management:off
              Link Quality=95/100  Signal level=-31 dBm  Noise level=-86 dBm
              Rx invalid nwid:0  Rx invalid crypt:111  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:2
    Network Manager shows the following connection info:

    ************************************************** ************************************************** **

    It seems to me that the faulty computer is applying the wrong key.
    Is the key not to short for WPA encryption?
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    On my system, I have all my settings in /etc/wpa_supplicant/wpa_supplicant.conf,
    I have edited my passkey and SSID, but this what mine looks like...and btw I do not use network manager, I use WICD, which in my opinion is the better tool. Maybe you can install that and give it a try. Make sure you are in the Wheel group too.
    Code:
    # This is a network block that connects to any unsecured access point.
    # We give it a low priority so any defined blocks are preferred.
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    ap_scan=1
    network={
      ssid="SSIDNAME"
      proto=WPA
      key_mgmt=WPA-PSK
      pairwise=CCMP TKIP
      group=CCMP TKIP WEP104 WEP40
      psk="XXXXXXXXXX"
      priority=2
    }

    Are you using DHCP to get your IP's or are you assigning them manually?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    156
    Thanks, I'll give it a try!
    Yes, I use DHCP, but the IP addresses are linked to the MAC addresses. So in that way it is a fixed IP address.
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  8. #8
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    156
    After installing WICD, the problem still exists.
    I get connected to wireless access point but no Internet, no e-mail, no updates.


    By the way, WICD did not change my wpa_supplicant.conf. It still contains the same two lines.
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    I manually entered the information that you gave me in wpa_supplicant.conf:
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    ap_scan=1
    network={
      ssid="SSIDNAME"
      proto=WPA
      key_mgmt=WPA-PSK
      pairwise=CCMP TKIP
      group=CCMP TKIP WEP104 WEP40
      psk="XXXXXXXXXX"
      priority=2
    }
    It also did not help. I still get connected, but no Internet access.


    PS: I notice that iwconfig reports Rx invalid crypt:111.
    Could this be a clue to my problem?
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  9. #9
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by blnl View Post
    Thanks, I'll give it a try!
    Yes, I use DHCP, but the IP addresses are linked to the MAC addresses. So in that way it is a fixed IP address.
    I don't know what this means really....any way you can unset this....just to see if it could be the problem? Just let DHCP assign an IP address all by itself.
    You did change the SSID and psk in the example I should you right?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #10
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    156
    There is a check box in my router that says Fix IP. That means when DHCP assigns IP address to a client. I can enable that check box, so each time this client will get that same IP address.
    I need this for NFS, because if my clients always get different IP addresses, I can't mount my NFS folders. (So, in fact I have fixed IP addresses.)

    Yes, I can disable it.
    I have done as you suggested. It did not help.

    Sorry, copy paste habit. Yes, I entered correct SSID and PSK in wpa_supplicant.conf.
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=wheel
    ap_scan=1
    network={
      ssid="BLNL"
      proto=WPA
      key_mgmt=WPA-PSK
      pairwise=CCMP TKIP
      group=CCMP TKIP WEP104 WEP40
      psk="MY_PSK_KEY"
      priority=2
    }
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •