Find the answer to your Linux question:
Results 1 to 6 of 6
I spent the weekend installing this card and trying to get it up and running. The usual tripping over old outdated webpages. I tried madwifi which kind of worked. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Posts
    5

    TL-WN951N (AR5008) install woes


    I spent the weekend installing this card and trying to get it up and running. The usual tripping over old outdated webpages. I tried madwifi which kind of worked. I saw a local AP I put on test. I really want to run this card as an AP though.

    I have removed madwifi after seeing more webpages mention ath9k, which seems to be the driver that is now being selected. Much hair lose and a headache brings me here! I just need to know if it is working and where I go from here to get into into master mode for use as an AP please?

    David
    Attached Files Attached Files

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Hi, and welcome to Linux Forums!

    The driver module appears to be loading OK, and everything looks good. You don't mention what distro you are using, but it appears to be Ubuntu server.

    What are you using to connect? If you are using Networkmanager, then that may be the source of the trouble. Install the Wicd connection manager.
    Code:
    sudo apt-get install wicd
    This will uninstall NetworkManager, and install Wicd. Then I think that you have to enable Wicd to connect to encrypted networks. This is found in one of the menus.

    If that still doesn't work, then you should try installing the latest version of the driver. It is available in a package containing many Linux wireless drivers, called compat-wireless.

    Download - Linux Wireless

    This is source code, and must be compiled. You will first need to install these:

    linux-source
    linux-headers
    build-essential
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Nov 2009
    Posts
    5
    Many thanks Paul,

    It's a Ubuntu 9.04 Server (2.6.28-16-server) with no GUI.

    I'm just sorting out remote-X access via SSH and then I'll see what wicd shows me. Failing that, I'll update the drivers.

    David

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    When you say it has no GUI, do you mean it has no X-server?

    If X isn't installed, you can still connect to wireless networks. If the network has no protection, or uses WEP (same thing?) you can use the iwconfig command.
    Code:
    paul@eeepc:~$ iwconfig --help
    Usage: iwconfig [interface]
                    interface essid {NNN|any|on|off}
                    interface mode {managed|ad-hoc|master|...}
                    interface freq N.NNN[k|M|G]
                    interface channel N
                    interface bit {N[k|M|G]|auto|fixed}
                    interface rate {N[k|M|G]|auto|fixed}
                    interface enc {NNNN-NNNN|off}
                    interface key {NNNN-NNNN|off}
                    interface power {period N|timeout N|saving N|off}
                    interface nickname NNN
                    interface nwid {NN|on|off}
                    interface ap {N|off|auto}
                    interface txpower {NmW|NdBm|off|auto}
                    interface sens N
                    interface retry {limit N|lifetime N}
                    interface rts {N|auto|fixed|off}
                    interface frag {N|auto|fixed|off}
                    interface modulation {11g|11a|CCK|OFDMg|...}
                    interface commit 
           Check man pages for more details.
    To use it "interface" means the wireless, usually wlan0. Run each option seperate, and then check it by running iwconfig again without any options. For example, to connect to a network named Linux_Forums enter this:
    Code:
    iwconfig wlan0 essid Linux_Forums
    Do this for all of the needed options.

    To connect to WPA encrypted networks, you need to use wpa_supplicant. You then need a pre-configured wpa_supplicant.conf file, usually in the /etc folder. Read these two man pages for more info.
    Code:
    man wpa_supplicant
    Code:
    man wpa_supplicant.conf
    Usually a server has no use for a wireless connection, so I don't even know if a wireless will work in the server edition. You may need to check a few things first. Read through the post linked to below. It describes the things to look at, and how to find them.

    Wireless Setup - Start Here
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    Just Joined!
    Join Date
    Nov 2009
    Posts
    5

    [SOLVED] Follow up

    Just want to say thank you for your advise and update you on how I solved it.

    I did download the latest drivers and Hostapd but met with more frustration. iw, nor iwconfig would allow the card to go into Mater mode. Hostapd complained that it could not find the nl80211 driver.

    I recompiled, ensure nl80211 was also selected but still no joy. A bit more reading around the web and I find people with simular problems with 802.11n cards had more success when upgrading to Ubuntu 9.10. I bit the bullet, upgraded and now have the card running in Master mode, as an AP with DHCP server. Peers are able to pick up an IP address and access the LAN.

    Now, I'm just trying to get IPTABLES configured to allow the WLAN to access the internet. I've posted for assistance on the Linux Network forum.

    Cheers, David
    Attached Files Attached Files

  6. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Thanks for the update.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •