Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
I tried, but then neither the embedded platform or my linux PC could access the router at all....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Dec 2009
    Posts
    19

    I tried, but then neither the embedded platform or my linux PC could access the router at all.

  2. #12
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    How are you sending the password? Are you using a connection manager GUI? Or do you use a configuration file?
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #13
    Just Joined!
    Join Date
    Dec 2009
    Posts
    19
    Sorry, I don't get what you mean. The embedded platform (or Linux PC) etc are not sending any passwords for as far as they are concerned they are using wired (to the switch) which is connected to the WAP. The WAP is in client mode, so it is permanently paired with the router having already done the shared key thing. I can access the router and WAP using their admin web pages. The embedded platform output I access using a UART socket on the back of the platform, having flashed it with a rom image. There is no UI (not yet) for the embedded platform, just serial access which gives me a command prompt (like telnet) once the boot process has completed. I think the embedded platforms boot process first probes the buses to see what hardware devices are there and installs the relevant drivers (inc ethernet) and at this point the dhcp discover packet is sent out, much later of does the root file system get loaded so anything I set in the file system will have no effect until after the dhcp request goes out.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I guess I got WAP confused with WEP.

    WAP = Wireless Access Point
    WEP = Wired Equivalency Protocol, a basic encryption method used for wireless passwords.

    So this is an open wireless access point?

    I guess my knowledge of embedded Linux isn't good enough to help you with this problem (I know zero about embedded Linux).

    Sorry
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #15
    Just Joined!
    Join Date
    Dec 2009
    Posts
    19
    No worries - thanks for trying though. I'm learning this whole thing as I go, so I'm sure to be using all sorts of wrong terminology.

    Its not an open WAP, its connection with the router is WPA (?) protected.

    Perhaps I'll try in an embedded forum - wasn't really sure where to ask - wireless, networking or embedded being as it touches all of them.

  7. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    For a WPA encrypted connection you need to use wpa_supplicant. This involves creating a wpa_supplicant.conf file containing all of the needed information. It is usually found in the /etc or /etc/wpa_supplicant/ folder. If the wireless worked on a different network, then you may need to configure it for the new network.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #17
    Just Joined! gnuuser's Avatar
    Join Date
    Nov 2009
    Location
    northwestern Pa, usa
    Posts
    69
    the problem I see is that you are using 1 a wireless dsl modem and 2 a wireless access point and your systems are trying to connect to the wap or switch.

    using 2 wireless communications devices like this poses a problem as the computers will connect to the downstream device and wont communicate with the adsl

    If you want to use the wap you need to hardwire the wap (ethernet cable to the adsl modem) then disable or remove the antenna from the adsl modem.
    then your computers should dhcp to the wap and should work ok

  9. #18
    Just Joined!
    Join Date
    Dec 2009
    Posts
    19
    I thought the whole point of using a WAP in client mode was so that you could have a wired network beyond it. Wireless ADSL router to wireless access point in client mode then wired on to a swtich for all other devices. The whole set up does work for most platforms I am using - Linux PC, Windows PC, so the process must be ok, it is just not working for an embedded platform and that is what I cannot understand.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •