Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I've recently installed the latest release of Archlinux. Setup is fine, but i'm having trouble setting up the wireless connection. Let me just start by saying I can get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38

    [SOLVED] Arch Linux Wireless Configuration


    Hi,

    I've recently installed the latest release of Archlinux. Setup is fine, but i'm having trouble setting up the wireless connection. Let me just start by saying I can get the wireless working without any security at all, so I know it's working fine. When I installed Arch I selected the base packages and the base-devil? base-daemon? packages, and made sure that every package relating to the internet or wireless was selected and installed.

    Setup:
    ASUS Pro50n series Notebook
    Wireless Security: WPA-PSK


    I have read the beginners guide wiki, and from that I have read the wireless setup wiki, which lead me onto the wpa_supplicant configuration for WPA-PSK security.

    In my /etc/wpa_supplicant.conf file I have the following:

    ctrl_interface=/var/run/wpa_supplicant GROUP=wheel
    eapol_version=1
    ap_scan=1

    network={
    ssid="PWNT"
    #psk="my-wpa-psk-pass-here"
    psk=numbers-generated-by-wpa_passphrase-PWNT-passphrase
    }
    *NOTE* I have tried many many variations of this config, by adding things like "proto=RSN" "key_mgmt=WPA-PSK" "pairwise=CCMP TKIP" or "pairwise=TKIP" "group=CCMP TKIP" or "group=TKIP". Countless numbers of things *NOTE*

    I then type the command:

    ifconfig wlan0 up
    then:

    iwconfig wlan0 essid PWNT
    then to see if its associated I type:

    iwconfig wlan0
    and nothing changes, it just shows all the information, and says "access point: Not-Associated" and doesn't get a mac address for it or anything.

    It's as if its not taking any notice of the /etc/wpa_supplicant.conf file at all.

    I know the wireless card is all being picked up correctly because 1.I've had it connected when I turn the routers wireless security off and 2. if I type ifconfig wlan0 it shows all the information on it up. I can also scan for the access points by doing iwlist wlan0 scan and it shows all the access points available including mine "PWNT".


    Can anoyne help? is there something I need to do to make it read the wpa_supplicant.conf file?.


    Thanks,
    Scott.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Once you have your wpa_supplicant.conf file setup, you would associate the wireless device with your network, as you did. And then run (as root)
    Code:
    wpa_supplicant -B -Dwext -i wlan0 -c /etc/wpa_supplicant.conf 
    dhcpcd wlan0
    But the easier method is to use netcfg. It's an optional selection on the core CD, so you may have installed it, if you did select everything to do with wireless.

    For that, you would create a network profile in
    /etc/network.d/
    named whatever you like.

    The contents of that file, say it's called home, would look something like.

    Code:
    CONNECTION="wireless"
    ESSID="my network"
    INTERFACE="wlan0"
    SCAN="yes"
    IP="dhcp"
    TIMEOUT="10"
    SECURITY="wpa"
    KEY="passphrase"
    This is my home WPA configuration. Replace ESSID and KEY with the appropriate values.

    So this would be /etc/network.d/home

    You would then do (as root)
    Code:
    netcfg home
    to bring up the network.

    Network Profiles - ArchWiki

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Or, if you have a wired connection available, just install wicd for an easy network tool.

    Code:
    pacman -S wicd
    You can run it from the console with an ncurses interface, or as a GUI.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Just used the netcfg option that you gave me reed9, worked perfectly. Can't believe its taken so long to try and get wpa_supplicant working, and then with Netcfg its taken literally 2 seconds. In the netword.d/examples it even gives you examples for every type of security all you have to do is copy it to the network.d folder and then type netcfg name-of-config-file like you said reed and it woked instantly.

    I don't understand why the beginners guide wiki doesn't tell you to do it that way.

    All I need to do now is make it auto connect on startup, which i've seen somewhere in the wiki.


    Thanks for your help everyone
    Scott.

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    All I need to do now is make it auto connect on startup, which i've seen somewhere in the wiki.
    It's in the network profiles wiki I linked to.

    In brief, edit /etc/rc.conf.

    Near the bottom, uncomment NETWORKS and add the name of the profile, then add net-profiles to your daemons array. (You will probably also want to remove the regular network daemon.)
    Code:
    NETWORKS=(home)
    
    DAEMONS=(...net-profiles...)
    Last edited by reed9; 01-20-2010 at 06:37 PM.

  7. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I should note that I actually have not been able to get net-profiles to connect properly to my network at boot. Not sure what the problem is. I don't reboot that often, so I haven't looked into it. But in case you run into trouble...

    Also, there's a handy tool call wifi-select in the AUR, which will automagically create a network profile for you.
    AUR (en) - wifi-select

    To use you run it as root like so
    Code:
    wifi-select wlan0
    It will pop up with a menu of available networks. Select one, enter the encryption key (note it will not echo what you type), and voila, you will have a profile in /etc/network.d/ named after the network essid.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •