Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Hi, Wireless Device: Zoom Wireless-G 4410 USB Distro: Archlinux After successfully getting Archlinux setup on my Laptop I thought i would have a go at setting it up on my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38

    [SOLVED] ndiswrapper Zoom USB Wireless-G 4410


    Hi,

    Wireless Device: Zoom Wireless-G 4410 USB
    Distro: Archlinux


    After successfully getting Archlinux setup on my Laptop I thought i would have a go at setting it up on my main PC again. The problem i've come to is that my wireless USB adapter(always seems to be a problem to varying degrees with wireless), doesn't have a linux driver available for my USB so I am aware that I need to use ndiswrapper to utilise the windows drivers. I have followed many different instructions from all over the net including the ones from the official ndiswrapper wiki, but with no avail, I simply still get an error that there is no interface for wlan0.

    So what im asking is if someone can guide me step by step through the setup and installation of windows drivers for my USB wireless stick in Archlinux?

    *NOTE* I have already got ndiswrapper so skip that step.

    When I mount the windows driver disk I navigate to

    /cdrom/Bin/Installs/USB/Driver
    Here I am given 2 more directories one named "Ndis5x" and one named "Ndis6".

    Within the "Ndis5x" folder there are the following files:

    WlanUZ2K.SYS
    WlanUZ98.SYS
    WlanUZME.SYS
    Wlanuzg.cat
    WlanUZ64.sys
    WlanUZG.inf
    WlanUZXP.sys
    Within the "Ndis6" folder there are the following files:

    WlanUZGV32.cat
    WlanUZGC32.sys
    WlanUZGV64.inf
    WlanUZGV32.inf
    WlanUZGV64.cat
    WlanUZGV64.sys
    I'm unsure which of the .inf files I should be using and from which directory.

    I'm aware after this step that I should use "ndiswrapper -i /directory to where driver is" e.g. "/cdrom/Bin/Installs/USB/Driver/...etc".

    Then after this I use the command ndiswrapper -m to create an alias directory? whatever that means?


    Thanks for your advice,
    Scott.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Can you plug in your USB wireless device and post the output of
    Code:
    lsusb
    So we can verify the USB ID.

    It's not clear to me which driver is correct. You can try each of them one by one.

    From this it looks like the driver should be called wlanuig.inf.SourceForge.net: Zoom 4410 - ndiswrapper But again we should check the usb id.

    Wireless Setup - ArchWiki

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Sorry, should have thought of including that in the original post, was in a rush to get out when I posted.

    lsusb gives:

    Bus 001 Device 002: ID 0803:4410 Zoom Telephonics, Inc.
    Theres various other lines most saying "Linux Foundation 1.1 Root Hub" but the line above is definitely the wireless card.

    Its strange that the USB ID isn't the same as the one on the ndiswrapper link you posted, I didn't notice that when I looked on the link before posting myself. And I've just double checked the box that the USB stick came in and its definitely Zoon Wireless-G USB 4410. Also strange that theres no driver called wlanuig.inf on the disk.

    *edit* I've just double checked the disk and theres no other directories with any driver files in. I wonder if the discrepancy between wlanuig.inf and whats on the disk is due to an input error to the Wiki? or maybe they changed the file names on the version of the USB stick that I bought?

    The only .inf that looks remotely like the one named in the wiki is the WlanUZG.inf.

    I tried installing the WlanUZGV32.inf and also the WlanUZGV64.inf with no avail, but maybe I carried out the install wrong? I did follow the wiki however. I've just read the wiki further and looked in the list of known NOT WORKING devices and list of known MAYBE WORKING devices and my device isn't listed in either of those categories so thats a good thing. My device is listed in the KNOWN WORKING section also.

    Is it just me, or is the ndiswrapper wiki really quite poor quality for someone who isn't fully familiar with Linux Operating systems? As far as I can see there is no "How To" for actually getting your USB stick working. I had to use the video from the wiki to try and do it (maybe this is why I have failed? lol).

    *EDIT* Further getting annoyed that every single link you click on, relates back to the ndiswrapper wiki... which is an absolute pile of junk that needs majorly updating as far as im concerned. Maybe when I get this working I can add a section to the wiki explaining in simple terms how to do this.

    Sorry for the long post, but thanks also for you help, I appreciate it,
    Scott.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like there are three versions of this wireless. Take a look at the page linked to below and find out which one you have'

    Zoom Telephonics: Zoom Wireless-G USB
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Hi Waterhead,

    Just checked and mine is the 4410B version, it has the F line in the serial.

    *EDIT* Just downloaded the B version from the Zoom link Waterhead pasted and extracted them and the files and directories are identical to those found on my disk, non of which are the same as what the supported version in the wiki says.

    Here is what I have tried so far:

    ndiswrapper -i /cdrom/Bin/Install/USB/Driver/Ndis5x/Wlanuzg.inf (this file only has a .cat file named the same, it doesn't have a .sys file as it says it should in the wiki video.
    Nonetheless, following the above command I carried:

    ndiswrapper -m
    all goes swimmingly.. then I do:

    ndiswrapper -l
    and get such and such relating to wlanuzg installed etc.

    Then I carry:

    iwconfig
    and it gives:

    lo - no wireless extensions.
    eth0 - no wireless extensions.
    I have tried exactly the same procedure with the wlanuzgv32.inf and with the wlanuzgv64.inf with no avail (obviously I removed the previous installed ones before I did the next.

    Is it as simple as I'm doing something wrong or missing something in the procedure or is it something else?.


    Scott.

  7. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Looks like the right driver should be WlanUZGV64.inf for 64 bit or WlanUZGV32.inf for 32 bit.

    [ubuntu] Wireless Dongle! (So close) - Page 2 - Ubuntu Forums

  8. #7
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Hi Reed,

    See *EDIT* in the above post


    Cheers.

  9. #8
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Did you load the ndiswrapper module after installing the windows driver?

    As root
    Code:
    modprobe ndiswrapper
    Possibly also need
    Code:
    depmod -a
    To load at boot, add ndiswrapper to the modules array in /etc/rc.conf

  10. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I just downloaded and checked all three divers, and I came to that same conclusion. The driver .inf files usually have the USB IDs in them.

    When you download and extract the 4410B driver, your driver is in the Ndis5x folder. Use the WlanUZG.inf file with NDISwrapper.

    This diver may not work because it is a combined driver, it has 32 bit and 64 bit drivers combined into one. Try it and see how is goes.

    When using NDISwrapper, run the -m -ma and -mi command options, after installing the driver. To see a list of the available options use this command.
    Code:
    ndiswrapper --help
    Please do not send Private Messages to me with requests for help. I will not reply.

  11. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by reed9 View Post
    Looks like the right driver should be WlanUZGV64.inf for 64 bit or WlanUZGV32.inf for 32 bit.
    It looks like those are the Vista drivers, so don't use those.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •