Find the answer to your Linux question:
Results 1 to 3 of 3
I have a usb wireless adapter with this model: DWA-120 please help on install and use it in ubuntu 9.10 my info: echo ============ lsusb ============ >> ~/wireless_setup.txt Bus 001 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    1

    Question Help on Dlink DWA-120 On ubuntu 9.10


    I have a usb wireless adapter with this model: DWA-120
    please help on install and use it in ubuntu 9.10

    my info:

    echo ============ lsusb ============ >> ~/wireless_setup.txt
    Bus 001 Device 008: ID 07d1:3a0d D-Link System DWA-120 Wireless 108G Adapter
    echo ============ lsmod ============ >> ~/wireless_setup.txt
    Module Size Used by
    nls_iso8859_1 3740 0
    nls_cp437 5372 0
    vfat 10716 0
    fat 51452 1 vfat
    usb_storage 52576 0
    isofs 31620 0
    udf 80900 0
    crc_itu_t 1852 1 udf
    binfmt_misc 8356 1
    dm_crypt 12928 0
    iptable_filter 3100 0
    ppdev 6688 0
    ip_tables 11692 1 iptable_filter
    x_tables 16544 1 ip_tables
    snd_intel8x0 30168 2
    snd_ac97_codec 101216 1 snd_intel8x0
    ac97_bus 1532 1 snd_ac97_codec
    snd_pcm_oss 37920 0
    snd_mixer_oss 16028 1 snd_pcm_oss
    snd_pcm 75296 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
    ndiswrapper 185404 0
    parport_pc 31940 1
    snd_seq_dummy 2656 0
    psmouse 56500 0
    serio_raw 5280 0
    k8temp 4188 0
    i2c_nforce2 6784 0
    snd_seq_oss 28576 0
    snd_seq_midi 6432 0
    snd_rawmidi 22208 1 snd_seq_midi
    snd_seq_midi_event 6940 2 snd_seq_oss,snd_seq_midi
    snd_seq 50224 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    snd_timer 22276 2 snd_pcm,snd_seq
    snd_seq_device 6920 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    snd 59204 14 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_ oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_ti mer,snd_seq_device
    soundcore 7264 1 snd
    snd_page_alloc 9156 2 snd_intel8x0,snd_pcm
    shpchp 32272 0
    lp 8964 0
    parport 35340 3 ppdev,parport_pc,lp
    dm_raid45 84228 0
    xor 15620 1 dm_raid45
    floppy 54916 0
    amd64_agp 9796 1
    agpgart 34988 1 amd64_agp
    forcedeth 54152 0
    ramzswap 8880 1
    xvmalloc 5180 1 ramzswap
    lzo_decompress 2620 1 ramzswap
    lzo_compress 2300 1 ramzswap
    echo ============ kernel version ============ >> ~/wireless_setup.txt
    2.6.31-16-generic
    echo ============ ifconfig ============ >> ~/wireless_setup.txt
    eth0 Link encap:Ethernet HWaddr 00:11:09:98:e1:29
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:22 Base address:0x2000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

    echo ============ iwconfig ============ >> ~/wireless_setup.txt
    lo no wireless extensions.

    eth0 no wireless extensions.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    This card is unfortunately poorly supported in linux. But there is hope with some effort. You will need to use a program called ndiswrapper and a Windows XP driver.

    https://help.ubuntu.com/community/Wi...er/Ndiswrapper
    NdisWrapper: The Ultimate Guide - LinuxQuestions.org

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    1
    Hello,
    I have the same wifi-adapter and ubuntu 9.10
    1) I downloaded windows XP drivers from the official site
    2) installed ndiswrapper and driver (ndiswrapper -i inf-file)
    3)
    Code:
    ndiswrapper -l
    WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
    neta5agu : driver installed
    	device (07D1:3A0D) present
    4) after doing modprobe ndiswrapper, i got this in dmesg output:
    Code:
    [  163.765592] ndiswrapper version 1.55 loaded (smp=yes, preempt=no)
    [  163.904099] usb 1-2: reset high speed USB device using ehci_hcd and address 2
    [  164.065194] ndiswrapper: driver neta5agu (D-Link,05/29/2007,1.5.204.1) loaded
    [  164.066845] ndiswrapper (ZwQueryValueKey:2329): not fully implemented (yet)
    [  164.577219] wlan0: ethernet device 00:1c:f0:13:76:e8 using NDIS driver: neta5agu, version: 0x10005, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 07D1:3A0D.F.conf
    [  164.615071] ndiswrapper: changing interface name from 'wlan0' to 'wlan1'
    [  164.615158] udev: renamed network interface wlan0 to wlan1
    [  164.639240] wlan1: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
    [  164.639269] ndiswrapper (wrap_procfs_add_ndis_device:398): wlan1 already registered?
    [  164.639365] usbcore: registered new interface driver ndiswrapper
    [  164.899214] ADDRCONF(NETDEV_UP): wlan1: link is not ready
    iwconfig
    Code:
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan1     IEEE 802.11g  ESSID:off/any  
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
              Bit Rate:54 Mb/s   
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    but if I do iwlist scan i get nothing:
    Code:
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wlan1     No scan results
    or sometimes one of many available APs

    but in hope i tried to setup it
    vim /etc/network/interfaces
    Code:
    auto wlan1
    iface wlan1 inet dhcp
    wpa-driver wext
    wpa-ssid nebo
    wpa-ap-scan 1
    wpa-proto WPA
    wpa-pairwise TKIP
    wpa-group TKIP
    wpa-key-mgmt WPA-PSK
    wpa-psk c435e35d8b41a29a9305631d53b1c02758a40c868ef3f20a14a1a7a914cacf37
    but after ifdown wlan1 and ifup wlan1 i get nothing:
    Code:
    Internet Systems Consortium DHCP Client V3.1.2
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit <del>
    
    Listening on LPF/wlan1/00:1c:f0:13:76:e8
    Sending on   LPF/wlan1/00:1c:f0:13:76:e8
    Sending on   Socket/fallback
    DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 14
    DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 21
    DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 21
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
     * Reloading /etc/samba/smb.conf smbd only
       ...done.
     * Stopping NTP server ntpd
       ...done.
    root@alesha-desktop:~#  * Starting NTP server ntpd
       ...done.
    What am I doing wrong?..

    after some time i get in dmesg
    Code:
    [   84.711668] ADDRCONF(NETDEV_UP): wlan1: link is not ready
    [  380.000996] ADDRCONF(NETDEV_UP): wlan1: link is not ready
    [  443.144630] ADDRCONF(NETDEV_UP): wlan1: link is not ready
    [  522.596292] ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
    [  533.168035] wlan1: no IPv6 routers present
    [ 1166.428615] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1181.617197] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1196.653100] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1211.701699] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1236.930639] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1242.929151] ADDRCONF(NETDEV_UP): wlan1: link is not ready
    [ 1248.973451] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1249.003458] ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
    [ 1259.156037] wlan1: no IPv6 routers present
    [ 1264.010683] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1284.015151] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1299.061305] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1315.275528] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1335.279742] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1350.322037] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1379.335667] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1409.035913] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1429.043792] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1444.086909] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1473.773438] ndiswrapper (iw_set_auth:1602): invalid cmd 12
    [ 1493.247416] usb 1-1: USB disconnect, address 2
    [ 1493.524778] ndiswrapper: device wlan1 removed
    [ 1493.764094] usb 1-1: new high speed USB device using ehci_hcd and address 3
    [ 1508.856793] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1509.096068] usb 1-1: new high speed USB device using ehci_hcd and address 4
    [ 1524.188168] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1524.428063] usb 1-1: new high speed USB device using ehci_hcd and address 5
    [ 1539.520161] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1539.760094] usb 1-1: new high speed USB device using ehci_hcd and address 6
    [ 1554.852768] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1555.092068] usb 1-1: new high speed USB device using ehci_hcd and address 7
    [ 1570.184206] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1570.424057] usb 1-1: new high speed USB device using ehci_hcd and address 8
    [ 1585.516154] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1585.760082] usb 1-1: new high speed USB device using ehci_hcd and address 9
    [ 1600.852193] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1601.092055] usb 1-1: new high speed USB device using ehci_hcd and address 10
    [ 1616.184323] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1616.424060] usb 1-1: new high speed USB device using ehci_hcd and address 11
    [ 1631.516146] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1631.756066] usb 1-1: new high speed USB device using ehci_hcd and address 12
    [ 1646.848193] hub 1-0:1.0: unable to enumerate USB device on port 1
    [ 1647.092069] usb 1-1: new high speed USB device using ehci_hcd and address 13
    and no wlan1 in iwconfig:
    Code:
    iwconfig 
    lo        no wireless extensions.
    
    eth0      no wireless extensions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •