Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
I am by far an expert but I wanted to post this to hopefully save some people hours of wanting to pull their hair out, so here it goes. Blacklisting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    5

    Ubuntu 9.10 + WUSB100v2 [Solved]


    I am by far an expert but I wanted to post this to hopefully save some people hours of wanting to pull their hair out, so here it goes.

    Blacklisting modules

    Open terminal
    Code:
    sudo gedit /etc/modprobe.d/blacklist.conf
    And add...
    Code:
    blacklist rt2x00usb
    blacklist rt2x00lib
    blacklist rt2800usb
    blacklist ndiswrapper
    Save and exit.

    Compiling a New Kernel Module (Driver)

    You'll need a compiler and Linux headers installed
    Code:
    sudo apt-get install build-essential linux-headers-generic
    Config and Install Driver

    Next you have to download the rt3070USB driver from ralinktech (Will add link if mod allows)

    Extract these files then move to the dir. in terminal:
    Code:
    cd Downloads/2009_1110_RT3070_Linux_STA_v2.1.2.0
    Next, we have to make a few adjustments to the config...

    Start with config.mk in /os/linux/:
    Code:
    gedit /os/linux/config.mk
    Then find:
    Code:
    # Support Wpa_Supplicant
    HAS_WPA_SUPPLICANT=n
    # Support Native WpaSupplicant for Network Maganger
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n
    and change to:
    Code:
    # Support Wpa_Supplicant
    HAS_WPA_SUPPLICANT=y
    # Support Native WpaSupplicant for Network Maganger
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
    Save and close

    Then open usb_main_dev.c in /os/linux/:
    Code:
    gedit /os/linux/usb_main_dev.c
    Then add the following before the #endif
    Code:
    {USB_DEVICE(0x1737,0x0078)}, /* Linksys WUSB100v2 */
    Compile

    Now run:
    Code:
    make
    make install
    Now you have to delete the rt2870sta that came with the install and load the new module
    Code:
    sudo rm -rf /lib/modules/`uname -r`/kernel/drivers/staging/rt2870
    modprobe rt3070sta
    insmod /lib/modules/`uname -r`/kernel/drivers/net/wireless/rt3070sta.ko
    Now if you run iwconfig you should see an ra0 interface but if you run ifconfig its not there. So here is the fix:
    Code:
    mv /etc/Wireless/rt3070sta /etc/Wireless/rt2870sta
    Now restart network-manager:
    Code:
    /etc/init.d/networking restart
    restart network-manager
    Now you should see wireless connections available in network manager (This may require a restart)

    I hoped this helped and like I said I am no expert and this was from doing research and forgive me if some is out of order I did my best to replicate what I did.

    Plus I would like to thank peepingtom from ubuntuforums (Will add link if mod allows)
    because he was vital in figuring this out and I hope this helps.

    ~Bruce

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Thank you for this information. It will help others in the same predicament.

    I was looking at the rt3070sta diver when I was trying to help you with this problem. I did see the 1737:0077 chip listed in that file, and wondered if this wasn't the driver to use. But, all information pointed to this being a rt2870 chip, and I didn't want to send you on a wild goose chase. I guess that I should trust my instincts!

    I am glad that you were able to get this working, and thanks again for posting the solution.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Posts
    43
    I've followed the instructions and then did 'make install'.
    Next I did: modprobe -v rt3070sta

    modprobe -v rt3070sta
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
    WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/anaconda, it will be ignored in a future release.
    insmod /lib/modules/2.6.31.12-174.2.19.fc12.i686/kernel/drivers/net/wireless/rt3070sta.ko
    FATAL: Error inserting rt3070sta (/lib/modules/2.6.31.12-174.2.19.fc12.i686/kernel/drivers/net/wireless/rt3070sta.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    dmesg (see attached)

    What do you suggest at this point?
    pete.

  4. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Please post the output of the dmesg message.

    How did you edit the file to add your wireless? If you used a windows based text editor, then that is the problem. Otherwise, you may have accidentally introduced a space or 'enter' into it.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    4

    Similar problem here

    Hi,

    I'm having a similar problem getting the 3070 driver to work with my Belkin N+ (F5D8055 v. 2) usb adapter. modprobe and insmod both relay fatal errors indicating that there is an unknown symbol in the module.

    dmesg output (output of dmesg|grep -e rt3 - duplicate entries and timestamp data removed.)
    Code:
    rt3070sta: Unknown symbol usb_alloc_urb
    rt3070sta: Unknown symbol usb_free_urb
    rt3070sta: Unknown symbol usb_register_driver
    rt3070sta: Unknown symbol usb_put_dev
    rt3070sta: Unknown symbol usb_get_dev
    rt3070sta: Unknown symbol usb_submit_urb
    rt3070sta: Unknown symbol usb_control_msg
    rt3070sta: Unknown symbol usb_deregister
    rt3070sta: Unknown symbol usb_kill_urb
    rt3070sta: Unknown symbol usb_buffer_free
    rt3070sta: Unknown symbol usb_buffer_alloc
    The belkin device that I'm using has a usb id of 050D:825B according to lsusb. I added the following line to RT3070_LinuxSTA_V2.3.0.1_20100208/common/rtusb_dev_id.c (at the end of the list, before the #endif, using gedit, so I don't think it's some odd linebreak problem or something...)
    EDIT: Just to be sure, I did it with vim as well, used spaces instead of a tab, same problem, same output from modprobe/dmesg.

    Code:
    {USB_DEVICE(0x050D,0x825B)}, /* Belkin 8055 v2 */
    Everything compiled and installed just fine (I had to change the names of RT2870STA.dat and RT2870STACard.dat to RT3070... in order to get make install to work.)

    Still no joy. I was able to get the 2870 driver to load and recognize the device (the little blue light came on and began blinking) but it wouldn't scan. Over in the ubuntu forums, one user suggests that he was able to get this particular device working with the 3070 driver. (I can't yet post links here, but the thread ID for that one is 8704426). So, I'm at a loss. Any suggestions on what I might do from here would be much appreciated.

    Cheers,
    -Richard

  6. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You say that you modded the rt3070sta driver. But then you talk about the rt2870 driver. If you modded the rt3070sta driver, isn't that the one that you want to try?
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    This thread has become more than the original poster intended it to be. I am going to move it to the wireless section.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #8
    Just Joined!
    Join Date
    Mar 2010
    Posts
    4
    Sorry, I should've been more clear.

    I had been fighting with the rt2870 driver, the result of which was a device that would power on, but not scan for or connect to networks. I ran across some discussion that for this model of the belkin usb device, the rt3070 driver is the key. So, I've been working on getting that driver loaded and functional, and that is when I ran into the problems mentioned above.

    Cheers,
    -R

  9. #9
    Just Joined!
    Join Date
    Mar 2010
    Posts
    4
    And I've solved the problem by using a slightly older version of the RT3070 driver. (2009_1110_RT3070_Linux_STA-v.2.1.2.0)

    Works smashingly. Consider me solved.

  10. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Where were you able to find an older version of the driver? Ralink only offers the latest version.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •