Find the answer to your Linux question:
Results 1 to 10 of 10
Hello, I installed OpenSuse 11.2 today . All went well and I am trying to get use to the KDE interface. I have purchased some Suse Linux books and will ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6

    Smile WUSB54GSC wireless Card, Please Help With Install


    Hello,

    I installed OpenSuse 11.2 today . All went well and I am trying to get use to the KDE interface. I have purchased some Suse Linux books and will be reading soon.

    However I am a COMPLETE NEWBIE to Linux and am having alot of trouble installing a wireless usb adapter I purchased today (LINKSYS) WUSB54GSC .

    I have done several google searches and tried to find a solution or way of installing, but still can't find the proper way. I can see the adapter listed in the hardware file (linux version of device manager).

    I know it must be annoying to get these types of questions from complete newbs to this wonderful O/S, but I'd greatly appreciate the help. Even if I can't get something like a step by step I'd appreciate at least being pointed in the correct direction.

    I am now typing through Windows 7, which I have as a dual boot with Suse11.2, so the adapter is fine and working (of course since it was designed for windows..).

    These are the closest steps I could find online to installing the adapter and getting online:

    "It's easy. Go into Yast then Software>Software Management
    Type in ndiswrapper. accept. It will ask for the cd so install using cd dl the windows drivers or load them from cd whatever, copy them to your home directory. Go into console change to your directory where the .inf file using cd (ie cd /home/yourusername/folder where inf is)
    then type ndiswrapper -i <filename.inf> Once driver installed type modprobe ndiswrapper press enter then type iwconfig.
    k great.
    Then in the bottom right look for the wireless in the knetworkmanager click an available wireless network shown and it will connect!"

    That is pretty much word for word and I kind of understood some was able to get into Yast then software management did the steps best I could understand etc...

    However I'm kind of lost and maybe that post was written for someone that already knew the basics. Thanks a million for any help.

  2. #2
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Okay, so I've been working on trying to get this to work by following the instructions @

    en.opensuse.org/Ndiswrapper_howto

    I installed both "bcmusbdhd" and "ndiswdm" (not at same time).

    for each I got the following:

    Warning : All config files need .conf /etc/modprobe .d/ndiswrapper
    ndiswdm: driver installed
    device (1737:0075) present

    However, when typing:

    ndiswrapper -d 1737:0075 'then the driver' (tried linksys, ndiswdm and bcmusbdhd)
    ls: cannot access /etc /ndiswrapper/linksys:No such file or directory
    driver 'linksys' is not installed (properly)!

    I went through the steps for each .inf file a few times after deleting the previous of course (all done as SU) and felt I got somewhere, but when opening the network settings under yast and trying to configure the wireless lan, I'd always come up with no HW info, however my built in NIC does show under Ethernet properly....

    I'm not sure what is going wrong, but I'm kind of lost now, even though I felt I have progressed alot in just getting use to some of the commands and interface of KDE etc...

    Still not able to connect...

    I hope the above steps kind of helps someone else help me .. if any makes sense..

    Oh and when doing command "lsusb", I get:

    BUS 001 Device 005: ID 1737:0075 Linksys

    If that helps at all....

    Thanks for any replies =)

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4
    You have to have the .sys file along with the .inf for ndis wrapper to work properly.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Hi, thanks for the reply.

    I actually did include the .sys files for both the xp and vista (32bit) all in the same folder.

    I wonder if returing this usb wireless adapter and installing an internal pci or pcie wireless card would make things any easier...

    However I can't complain, because the challenge is helping me learn the O/S more and is actually fun!

  6. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Linksys has made more than one version of this wireless, which one do you have? Make sure that the diver you get is for the correct version. It looks like you have version 2.

    Linksys by Cisco - WUSB54GSC Support

    You must use a Win2k/WinXP driver. Vista drivers wont work. Tell ndiswrapper to use the ndiswdm.inf file along with the ndiswdm.sys file.
    Code:
    sudo ndiswrapper -i /path/to/ndiswdm.inf
    Now check to see that it installed.
    Code:
    ndiswrapper -l
    Now run these commands, one at a time.
    Code:
    sudo ndiswrapper -m
    Code:
    sudo ndiswrapper -ma
    Code:
    sudo ndiswrapper -mi
    Now reboot, and see if the wireless will now work.

    It is possible that there already is a Linux driver loading for this wireless. Some info says that the rndis_wlan driver will wok for this. If it is also loading, it my conflict with ndiswrapper and keep the wireless from working.

    You really should read the wireless sticky, and run the script that is in the second section. Post the output of that script here, we need all of the info that it provides.

    Wireless Setup - Start Here
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #6
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Thank you very much for your response.

    I tried everything you mentioned but none worked.

    I do have the correct drivers (inf and sys) and you are correct it is the 2nd version of the usb adapter.

    When I ran your script (exactly as it says) these are the only results I got (which did output as you said it would "wireless_setup") :

    ============ lspci ============

    ============ lsusb ============
    ============ lspci ============

    ============ lsusb ============

    That is all that came out in the txt file afterwards.

    The closest I've come to being able to install this adapter (at least it feels like it, but I guess close doesn't count...) is when I followed the directions (to the T) from the openSuse org site.

    I see the hardware listed it seems to load the drivers, then I link the USBID to the driver. All goes well until I go into YaST and try to configure the wireless card there. It never shows any hardware profile.

    I have honestly been messing with this for 24 hours straight. My stomach hurts from too much coffee and white rockstar energy drink lol....

    I don't know what to do anymore, but this is quite a pain... I had no idea it would be such.

    I even reinstalled the O/S freshly three times and started from scratch in case I messed anything up while SU...

    Maybe I can return this card (which I only got because I had just got Windows 7 and this Suse 11.2 as dual booting O/S' a couple days ago).

    Maybe you can recommend another adapter that will be a bit more native with this distro of linux and Windows 7. I'm even willing to pay someone through pay pal to help me install this, just because it's a challenge now! lol

    I installed KDE all these times, but don't figure it should make too much of a difference..

    I am very greatful for any help I've received so far and I am learning my way through the command line and O/S little by little just trying to figure this out, which is good, since I want to get my Linux+.

    I currently have A+, A+2009, Network+, i-Net+, CIW Associate and am studying for my CCNA (eventually want to be a security specialist as I've been in the IT field since 2000 and have renewed my interest strongly the last couple of months)

    Funny though how having the experience in IT hasn't helped me with linux too much yet. It's still sooo foreign feeling (damn you windoze lol).

    Well I'm gonna finally try to get some rest and my mind of this for a bit. I'll be back at it tomorrow.

    Thank you again Paul. =)

    Mike

  8. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I see that Suse doesn't like my script.

    More info may be helpful in determining what is going on. A forum member has a similar script that was made for Suse. Although it won't make the wireless work, if you could try it and post the output, it may help.

    http://www.linuxforums.org/forum/lin...-problems.html

    As for getting a wireless that will work with Linux, it is difficult to determine which will work. The Linux drivers are based on the chips inside of the wireless (as windows drivers are too). The manufacturers don't list the chips anywhere, so you have to plug it in to find out.

    One way to find Linux compatible devices is this: Go to the NewEgg.com site and go to the Reviews section.

    Newegg.com - Computer Parts, PC Components, Laptop Computers, Digital Cameras and more!

    In the '(keywords)' section enter Linux, and in the dropdown box 'By Catagory' select Wireless Adapters. This will bring up reviews with the word 'Linux' in them. Check them out to see if they say that it works. You can then try and find the same device at a local store. Be aware of the version number of a device, as that can make a BIG difference. Rosewill products are only available from NewEgg.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #8
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Well, I tried the Suse script and it worked fine, until 34% at which time it hung. I tried it several times even with all the options just to see if it would go any further but no luck.

    What type of information do you need exactly, maybe I could just manually look for it (if I know how lol..).

    I looked at a few adapters on New Egg so thank you for that resource. I'm semi-convinced that this adapter should work since going through all the original steps seemed to get me so close.

    Maybe if I try again, someone can help me understand how to configure it in yaSt afterwards...? I mean the steps I go through at openSuse's Ndiswrapper how to...

    Or any other suggestion(s) would be great. Thanks again, this is a battle I know we (I) can win.. lol =)

  10. #9
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Other than making the adapter I have work (which is detected by Suse) what do you think about this adapter Wireless-G 802.11g WiFi USB Adapter BT3 Linux Backtrack ?

    Which is said to work plug and play with Linux distros....

    The old chipset was zd1211b, then Atheros bought them out and renamed it ar5007-ug

    This is from a seller of the USB Adapter.. Hope that helps, I know I'll be looking into it.

    Oh and by the way they couldn't confirm if it workes with Suse 11.2, but it does with all the other distros listed when you look it up.....

  11. #10
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I haven't used Suse in a while, so I can't help with the specific set up of the wireless. I do remember that you want this:

    Controlled by NetworkManager
    Use DHCP and DNS
    Don't activate at boot
    Allow all users to control the connection

    You also need to specify the default gateway. This would be the IP address of your router.

    As for getting the info. Try running my original script as root. Login to a terminal window with this command. (Include the dash)
    Code:
    su-
    First delete the text file that was originally created. Everytime you run the script, it will just add more to the file. If that still wont work, it is because the path to the command is unknown. You can then do a search for the commands. These are the ones to look for.

    lspci
    lsusb
    lsmod
    dmesg
    uname -r
    ifconfig
    iwconfig

    To search for them use the locate comand.
    Code:
    locate lspci
    It should give the entire path to where it is. Here is what my Ubuntu netbook search is like.
    Code:
    paul@Zotac-SAM:~$ locate lspci
    /boot/grub/lspci.mod
    /usr/bin/lspci
    /usr/lib/grub/i386-pc/lspci.mod
    /usr/share/man/man8/lspci.8.gz
    The one I want is /usr/bin/lspci, so enter the entire path in the terminal.
    Code:
    /usr/bin/lspci
    As for the wireless card you asked about. Backtrack is a Linux distribution used by many to crack into private wireless networks. I wouldn't buy anything from them, as it is illegal to crack into private networks, and I don't want to support them.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •