Find the answer to your Linux question:
Results 1 to 5 of 5
Hello all! I just upgraded to Fedora 12 with a fresh install, and have a little question here. I have a wireless card, 04:00.0 Network controller: RaLink RT2860 . In ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023

    Wireless installation in Fedora 12


    Hello all!

    I just upgraded to Fedora 12 with a fresh install, and have a little question here.
    I have a wireless card, 04:00.0 Network controller: RaLink RT2860. In Fedora 10, I simply downloaded the proper firmware from the Ralink site, compiled and did
    Code:
    modprobe rt2860sta
    All was good after that. Now, inF12, I get the error:
    Code:
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d
    I did check this thread and followed the instructions. I get error:
    Code:
    Error: Missing Dependency: kernel-uname-r = 2.6.32.9-67.fc12.i686 is needed by package kmod-rt2860-2.6.32.9-67.fc12.i686-2.1.2.0-3.fc12.19.i686 (rpmfusion-free-updates-testing)
    Any tips?

    Code:
    dmesg | grep firmware
    platform microcode: firmware: requesting intel-ucode/06-0f-0d
    platform microcode: firmware: requesting intel-ucode/06-0f-0d
    
    uname -r
    2.6.32.9-70.fc12.i686.PAE
    Forgot lsmod:
    Code:
    lsmod
    Module                  Size  Used by
    fuse                   48375  2 
    sunrpc                160134  1 
    cpufreq_ondemand        6993  2 
    acpi_cpufreq            6535  0 
    ip6t_REJECT             3394  2 
    nf_conntrack_ipv6      14859  2 
    ip6table_filter         2227  1 
    ip6_tables              9409  1 ip6table_filter
    ipv6                  223738  28 ip6t_REJECT,nf_conntrack_ipv6
    uinput                  5244  0 
    snd_hda_codec_realtek   197298  1 
    snd_hda_intel          19763  2 
    snd_hda_codec          59921  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep               4868  1 snd_hda_codec
    sdhci_pci               5200  0 
    snd_seq                42811  0 
    snd_seq_device          5031  1 snd_seq
    iTCO_wdt                7862  0 
    r8169                  29749  0 
    rfkill                 13401  1 
    snd_pcm                61044  2 snd_hda_intel,snd_hda_codec
    sdhci                  15396  1 sdhci_pci
    jmb38x_ms               9706  0 
    i2c_i801                8337  0 
    mmc_core               51268  1 sdhci
    iTCO_vendor_support     2023  1 iTCO_wdt
    memstick                7460  1 jmb38x_ms
    mii                     3510  1 r8169
    joydev                  7408  0 
    snd_timer              15541  2 snd_seq,snd_pcm
    snd                    46576  12 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
    soundcore               4863  1 snd
    snd_page_alloc          6125  2 snd_hda_intel,snd_pcm
    wmi                     5620  0 
    dm_multipath           12324  0 
    i915                  239486  2 
    drm_kms_helper         22251  1 i915
    drm                   135451  3 i915,drm_kms_helper
    i2c_algo_bit            4073  1 i915
    i2c_core               21732  5 i2c_i801,i915,drm_kms_helper,drm,i2c_algo_bit
    video                  16522  1 i915
    output                  1605  1 video
    Last edited by jayd512; 03-06-2010 at 08:16 AM. Reason: Forgot lsmod
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d
    This is just what is says. /etc/modprobe.conf is deprecated. All module config files must be in /etc/modprobe.d/ now and the filename must end in .conf.

    If you had something in /etc/modprobe.conf you can move the file to /etc/modprobe.d/modprobe.conf

    Error: Missing Dependency: kernel-uname-r = 2.6.32.9-67.fc12.i686 is needed by package kmod-rt2860-2.6.32.9-67.fc12.i686-2.1.2.0-3.fc12.19.i686 (rpmfusion-free-updates-testing)
    This package was built against kernel 2.6.32.9-67, but your running kernel is 2.6.32.9-70.fc12.i686.PAE. You need a package built against this kernel.

    This might help:
    HOWTO: Native rt2860, rt2870 & rt3070 wireless drivers for Fedora - FedoraForum.org

  3. #3
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I'll try the links instructions when I get home tonight...
    Until then, I have a question. Do you have any info on what the convention should be for just adding something to modprobe.d
    I like being able to edit config files, but this is a little bit of a change for me.

    BTW... I never actually looked at the contents of /etc/modprobe.conf...
    Never really had any reason to...

    I guess that's one of the little details that might be biting me in the @$$
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Until then, I have a question. Do you have any info on what the convention should be for just adding something to modprobe.d
    I like being able to edit config files, but this is a little bit of a change for me.
    The two usual files here are /etc/modprobe.d/modprobe.conf and /etc/modprobe.d/blacklist.conf


    The first for various module options, for example, my laptop's headphone jack doesn't work without adding options snd-hda-intel model=eapd probe_mask=1 position_fix=1. The second, obviously, for blacklisted modules.

    As far as I know, that's the convention, but it isn't required by the system. You can name the files however you want, so long as they end in .conf. You could do a separate file for every module you wanted blacklisted, if you wanted.

    And then depending on the distro, there is also /etc/modules, which forces a module to load, if for some reason it wasn't being autoloaded. At least, that is for Debian based distros. Arch does it different, not sure about Fedora and like.

    Blacklisting modules is as simple as adding
    Code:
    blacklist <module name>
    Module options are just
    Code:
    options <module option>
    Ubuntu Manpage: modprobe.d, modprobe.conf - Configuration directory/file for modprobe

  6. #5
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Well, I decided on a work around for now...
    I installed Mint. Been meaning to give it another try anyways.
    I'll go after wireless in Fedora 12 again, but right now I just didn't really have time to do any real trial and error on it right now.

    But thanks for the info, reed.
    It'll definitely come in handy.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •