Find the answer to your Linux question:
Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 21 to 30 of 41
Code: 244.984087] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2870STA/RT2870STA.dat [ 244.984090] Open file "/etc/Wireless/RT2870STA/RT2870STA.dat" failed! [ 244.984092] 1. Phy Mode = 0 [ 244.984094] ERROR!!! RTMPReadParametersHook failed, Status[=0x00000001] [ 245.040816] ---> RTMPFreeTxRxRingMemory ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Banned
    Join Date
    May 2010
    Posts
    19

    Code:
      244.984087] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2870STA/RT2870STA.dat
    [  244.984090] Open file "/etc/Wireless/RT2870STA/RT2870STA.dat" failed!
    [  244.984092] 1. Phy Mode = 0
    [  244.984094] ERROR!!! RTMPReadParametersHook failed, Status[=0x00000001]
    [  245.040816] ---> RTMPFreeTxRxRingMemory
    [  245.040859] <--- RTMPFreeTxRxRingMemory
    [  245.040863] !!! rt28xx Initialized fail !!!
    [  245.301173] <-- RTMPAllocTxRxRingMemory, Status=0
    [  245.302701] -->RTUSBVenderReset
    [  245.302826] <--RTUSBVenderReset
    [  245.578463] RtmpOSFileOpen(): Error 2 opening /etc/Wireless/RT2870STA/RT2870STA.dat
    [  245.578465] Open file "/etc/Wireless/RT2870STA/RT2870STA.dat" failed!
    [  245.578467] 1. Phy Mode = 0
    [  245.578469] ERROR!!! RTMPReadParametersHook failed, Status[=0x00000001]
    [  245.634989] ---> RTMPFreeTxRxRingMemory
    [  245.635008] <--- RTMPFreeTxRxRingMemory
    [  245.635010] !!! rt28xx Initialized fail !!!
    i got a similar problem as yours, and i managed to solve it. it's quite a simple trick.

    first, start by uninstalling all your rt2870sta and rt3070sta drivers with make uninstall.

    Then go to Ralink's website and download BOTH files:

    1. RT3070 driver
    2. RT2870 driver (dont ask why yet! i'll explain)

    untar the RT2870 driver, make the necessary changes that needs to be made /os/linux/config.mk and as root, install the driver with the following:

    make
    make install

    And DON'T MODPROBE THE rt2870sta driver!

    next, untar the rt3070 file and make the changes which waterhead has pointed out in the first post, and then install the driver as root with make and make install.

    Now, as root, run modprobe rt3070sta and you should finally be able to bring up the interface after about a couple of minutes of waiting.

    Why? Because the rt3070sta module makes calls to the RT2870STA.dat file, which, quite naturally, does not exist if you followed waterhead's steps to installing the driver. So you'll need to install the rt2870sta driver first to create an RT2870STA.dat file which rt3070sta can call to.

    I managed to get this working on Fedora 10, so i can only speak for myself. I hope it helps to solve your problem, and if it does not, i apologize for getting your hopes up.

    And to waterhead: you dont know just how much i love you for posting the fix to installing the rt3070sta driver.

  2. #22
    Just Joined!
    Join Date
    May 2010
    Posts
    9

    Found an easier fix...

    So for me to get this working in Ubuntu 10.04 (64-bit), an easier way is to install the latest rt3070sta drivers from Ralink after making the necessary changes specified in this thread, add rt3070sta to "modules", and to blacklist rt2870sta AND rt2800usb.

    And actually upon further investigation, rt2870sta by itself works with my AWUS036NH adapter, but it only recognizes it if rt2800usb is blacklisted, otherwise there's a conflict (I don't know why this is the case). In the end I didn't even need to install rt3070sta.

  3. #23
    Just Joined!
    Join Date
    Aug 2008
    Posts
    1
    Just wanted to confirm that the DPO_RT3070_LinuxSTA_V2.3.0.2_20100412 driver works for me on Ubuntu 10.04 using an Edimax EW-7711UTn (7392:7711). Many thanks for the information.

  4. #24
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Thanks Etna and marcris for the feedback!

    And welcome to Linux Forums to the both of you.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #25
    Just Joined!
    Join Date
    Jun 2010
    Posts
    1
    Umm, IK need help with a similar issue. I've tried all your steps, if I did them correctly, but I still can't seem to get my device to work. My device is an RNX EasyN-1 network adapter. I am also not sure if I have installed the drivers correctly. help would be appreciated before I asplode from frustration. The machine is running 10.04 Ubuntu. (lucid)

  6. #26
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Your problem could be totally unrelated to the subject of this thread. Please read through this thread first:

    Wireless Setup - Start Here

    That thread tells you how to find needed info. Start a new thread and post that info in it.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #27
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4
    I've been trying to get this working on Debian using DPO_RT3070_LinuxSTA_V2.3.0.4_20100604

    sudo make
    sudo cp RT2870STACard.dat RT3070STACard.dat
    sudo cp RT2870STA.dat RT3070STA.dat
    sudo make install
    cd /etc/Wireless/
    sudo ln -s RT3070STA RT2870STA
    cd RT3070STA
    sudo ln -s RT3070STA.dat RT2870STA.dat
    sudo modprobe rt3070sta

    Code:
    dmesg
    [42953881.420000] usb 1-2: new high speed USB device using ehci_hcd and address 4
    [42953881.590000] usb 1-2: configuration #1 chosen from 1 choice
    [42953881.610000] usb 1-2: New USB device found, idVendor=177f, idProduct=0153
    [42953881.620000] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [42953881.630000] usb 1-2: Product: 802.11 n WLAN
    [42953881.630000] usb 1-2: Manufacturer: Sweex 
    [42953881.640000] usb 1-2: SerialNumber: 1.0
    
    lsusb
    Bus 001 Device 003: ID 177f:0153 Sweex
    
    lsmod
    usbcore               128828  5 rt3070sta,ohci_hcd,ehci_hcd,usb_storage
    
    ifconfig shows eth0 and lo
    
    iwconfig
    lo        no wireless extensions.
    eth0      no wireless extensions.
    However it's still not working, any ideas?

  8. #28
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Your device ID is not among those that are recognized by the driver. If you are positive that this is the correct driver, you can add your device ID to the driver source, and then compile the driver.

    Look at the bottom of the first post in this thread. That is where I describe how to add it.

    To see a list of supported devices that a driver has, use the modinfo command.
    Code:
    modinfo rt3070sta
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #29
    Just Joined!
    Join Date
    Aug 2010
    Posts
    4
    ahh I only thought it was as it's the only info I could find re this adapter i've just found some info that says its

    Sweex LW313, RT2770, 177F:0313

    How would I install the rt2770 driver?

  10. #30
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Ralink Linux drivers can be found here:
    Ralink corp.

    It looks like the rt2770 is part of the rt2870 driver. You will need to download that driver, and add your device ID, and then compile the driver.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •