hi all ,

i am using ubuntu on my two laptop.and i have create a new wireless network,and want to connect
my those two laptop to this new wireless network.
for this i have update /etc/network/interfaces file in both laptop and gave static ip address:-10.114.12.27 --on first laptop
10.114.12.28---on second laptop

"ifconfig" on first is :-

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:996 errors:0 dropped:0 overruns:0 frame:0
TX packets:996 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:81514 (81.5 KB) TX bytes:81514 (81.5 KB)

wlan0 Link encap:Ethernet HWaddr 00:22:43:77:84:24
inet addr:10.114.12.27 Bcast:10.114.255.255 Mask:255.255.0.0
inet6 addr: fe80::222:43ff:fe77:8424/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:68 errors:0 dropped:0 overruns:0 frame:0
TX packets:299 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8828 (8.8 KB) TX bytes:36724 (36.7 KB)

wmaster0 Link encap:UNSPEC HWaddr 00-22-43-77-84-24-34-32-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)




iwconfig command on first is :-
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"ipv4_network"
Mode:Ad-Hoc Frequency:2.412 GHz Cell: 92:88:F9:B6:1C:18
Tx-Power=20 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

ifconfig on second is :-

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:996 errors:0 dropped:0 overruns:0 frame:0
TX packets:996 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:81514 (81.5 KB) TX bytes:81514 (81.5 KB)

wlan0 Link encap:Ethernet HWaddr 00:22:43:77:84:24
inet addr:10.114.12.28 Bcast:10.114.255.255 Mask:255.255.0.0
inet6 addr: fe80::222:43ff:fe77:8424/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:68 errors:0 dropped:0 overruns:0 frame:0
TX packets:299 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8828 (8.8 KB) TX bytes:36724 (36.7 KB)

wmaster0 Link encap:UNSPEC HWaddr 00-22-43-77-84-24-34-32-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



iwconfig on second laptop is:

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"ipv4_network"
Mode:Ad-Hoc Frequency:2.412 GHz Cell: 92:88:F9:B6:1C:18
Tx-Power=20 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.


but when i try to ping 10.114.12.27 from laptop of ip 10.114.12.28 , it is not able to ping.
plz help me ............
i m struggling from lot of days.......