Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 33
Originally Posted by tatiana30241 Okay, so when I tried to patch the driver, it gave me an ambiguous redirect error: Code: tatiana@desktop ~ $ cd ar5523 tatiana@desktop ~/ar5523 $ patch ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Engineer
    Join Date
    Mar 2005
    Location
    Where my hat is
    Posts
    766

    Quote Originally Posted by tatiana30241 View Post
    Okay, so when I tried to patch the driver, it gave me an ambiguous redirect error:

    Code:
    tatiana@desktop ~ $ cd ar5523
    tatiana@desktop ~/ar5523 $ patch <debian/patches/kcompat-2.6.2*
    bash: debian/patches/kcompat-2.6.2*: ambiguous redirect
    Is this the right path?
    Ambiguous redirect means that you're attempting to modify more than one file at a time. You need to be specific and patch one file at a time.
    Registered Linux user #384279
    Vector Linux SOHO 7

  2. #22
    Just Joined!
    Join Date
    Mar 2010
    Posts
    22
    Yes, I know, but this is the exact instruction listed in the Debian wiki as well as in Waterhead's post. Are you saying the command is leading to more than one file because of the wildcard? If this is the case, then what input should I use?

  3. #23
    Just Joined!
    Join Date
    Mar 2010
    Posts
    22
    Oh, I see.

    In the ar5523 directory there are 3 kcompat files: kcompat-2.6.25.patch, kcompat-2.6.26.patch, and kcompat-2.6.32.patch.

    But I have the 2.6.31-14-generic kernel.

    Which patch file should I use?

  4. #24
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    As for installing the patches, I have been able to figure it out. Your terminal must be in the top of the ar5523 folder. Then I gave the entire path to the patch, like this:
    Code:
    patch < /home/paul/ar5523/debian/patches/add-Gigaset-108.patch
    All of the patches installed, except one gave an error:
    Code:
    patch < /home/paul/ar5523/debian/patches/kcompat-2.6.26.patch 
    patching file ar5523.c
    Reversed (or previously applied) patch detected!  Assume -R? [n] y
    Hunk #1 succeeded at 128 (offset -1 lines).
    Hunk #2 succeeded at 415 (offset -1 lines).
    Hunk #3 FAILED at 573.
    Hunk #4 succeeded at 1275 (offset -6 lines).
    Hunk #5 succeeded at 1302 (offset -6 lines).
    1 out of 5 hunks FAILED -- saving rejects to file ar5523.c.rej
    It still fails to compile. I'm guessing that I shouldn't install all of the patches. I'm going to start fresh, and try again.
    Last edited by waterhead; 04-04-2010 at 06:31 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  5. #25
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Well, I deleted the folder and pulled it fresh from the SVN repository. This time I installed all of the patches, except for the kcompat kernel patches. Since my kernel doesn't match any of those, this makes sense. I still got an error installing the remove-unused-variables patch so I skipped it. The make still fails.

    So then I forced the installation of the remove-unused-variables.patch. I still get errors when I run make.

    This may be because of my kernel. You may need the latest kernel that there is a patch for (2.6.32). But I am just guessing.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #26
    Just Joined!
    Join Date
    Mar 2010
    Posts
    22
    I installed kernel 2.6.32, since there is a patch for that. That part went quite nicely I think. Then I tried to use the patch file, and the same thing happened to me that happened to you:

    Code:
    tatiana@desktop ~/ar5523 $ patch < /home/tatiana/ar5523/debian/patches/kcompat-2.6.32.patch
    patching file ar5523.c
    Hunk #2 succeeded at 498 (offset -1 lines).
    Hunk #3 FAILED at 583.
    Hunk #4 succeeded at 787 (offset -7 lines).
    Hunk #5 succeeded at 798 (offset -9 lines).
    Hunk #6 succeeded at 835 (offset -9 lines).
    Hunk #7 succeeded at 865 (offset -9 lines).
    Hunk #8 succeeded at 873 (offset -9 lines).
    Hunk #9 succeeded at 887 (offset -9 lines).
    Hunk #10 succeeded at 912 (offset -9 lines).
    Hunk #11 FAILED at 962.
    Hunk #12 succeeded at 973 (offset -10 lines).
    Hunk #13 succeeded at 999 (offset -10 lines).
    Hunk #14 succeeded at 1025 (offset -10 lines).
    Hunk #15 succeeded at 1047 (offset -10 lines).
    Hunk #16 succeeded at 1556 (offset 32 lines).
    2 out of 16 hunks FAILED -- saving rejects to file ar5523.c.rej
    What does it mean? Why is it patching some parts and not others?

  7. #27
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Did you try to build the driver? Maybe it will still build.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #28
    Just Joined!
    Join Date
    Mar 2010
    Posts
    22
    No, it just gives me 3 feet of error messages. Should I try the other patches or will that screw something up? I would feel better if I knew where in my system it is putting all this new information, so I can go and delete it if it doesn't work.

  9. #29
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    It looks like your results are the same as mine. You should maybe install all of the other patches, except the other kernel patches.

    Other than that, it looks like this is a bit over my head too. I didn't know installing this driver would be so hard. Your only other option is to try NDISwrapper, which will use the devices WinXP driver. You need to supply the WinXP driver.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #30
    Just Joined!
    Join Date
    Mar 2010
    Posts
    22
    Well, I will try the other patches. Ndiswrapper was actually the first thing I tried, and it did not work.

    Maybe I will try getting the other kernel versions that the other kernel patches will supposedly work with and try each of those in succession.

    One thing more, though, if you have the time. Can you tell me where all the information that the patches are installing is going? I want to be able to undo it if none of this works.

    Thanks for your time.

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •