Find the answer to your Linux question:
Results 1 to 4 of 4
Okay, so I've re-installed a 32-bit ISO of Ubuntu using Wubi. I installed updates upon Ubuntu installation. I have managed to install the graphical interface of ndiswrapper, and I installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    30

    [SOLVED] D-Link WUA 2340 - iwconfig still shows no connection


    Okay, so I've re-installed a 32-bit ISO of Ubuntu using Wubi. I installed updates upon Ubuntu installation.

    I have managed to install the graphical interface of ndiswrapper, and I installed the XP drivers from the D-Link CD. I saw a prompt which says that the driver was installed.

    However, upon running the iwconfig command, I still have no wireless extensions.

    Can anyone help me troubleshoot? What is the next step?

    I have been using this tutorial:

    WifiDocs/Driver/Ndiswrapper --type this in Google. It seems to be an Ubuntu community page. The forum still won't let me post links, grrr.

    I attempted the method of blacklisting certain drivers, but was unable to get around the read-only restrictions on the blacklist file. I can use gedit to edit the file, but not save it. Alternately, if I used the vi (vee-eye), then it kept warning me I was writing to a read-only file.

    Any pointers?

    I have a wired connection to work with, but it via a long and winding cable from the basement of my home. Obviously, this is not a long-term solution, so I am trying to get my wifi set up.

  2. #2
    Just Joined!
    Join Date
    Apr 2010
    Posts
    30
    I realized I can use the sudo command to change the blacklist file, and I added the reccomended lines to the blacklist file. Alas no luck.

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    30
    Code:
    nik@ubuntu:~$ uname -mr
    2.6.31-20-generic i686
    
    nik@ubuntu:~$ ndiswrapper -l
    WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
    neta5agu : driver installed
    	device (07D1:3A08) present
    
    
    nik@ubuntu:~$ lsmod
    Module                  Size  Used by
    isofs                  31620  1 
    udf                    80900  0 
    crc_itu_t               1852  1 udf
    binfmt_misc             8356  1 
    ppdev                   6688  0 
    snd_hda_codec_intelhdmi    12860  1 
    snd_hda_codec_realtek   203328  1 
    ndiswrapper           185532  0 
    snd_hda_intel          26920  2 
    snd_hda_codec          75708  3 snd_hda_codec_intelhdmi,snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep               7200  1 snd_hda_codec
    snd_pcm_oss            37920  0 
    snd_mixer_oss          16028  1 snd_pcm_oss
    snd_pcm                75296  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
    snd_seq_dummy           2656  0 
    snd_seq_oss            28576  0 
    iptable_filter          3100  0 
    snd_seq_midi            6464  0 
    snd_rawmidi            22176  1 snd_seq_midi
    ip_tables              11692  1 iptable_filter
    x_tables               16544  1 ip_tables
    snd_seq_midi_event      6940  2 snd_seq_oss,snd_seq_midi
    usblp                  12636  0 
    snd_seq                50224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    snd_timer              22276  2 snd_pcm,snd_seq
    snd_seq_device          6920  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    psmouse                56500  0 
    serio_raw               5280  0 
    led_class               4096  0 
    lp                      8964  0 
    parport                35340  2 ppdev,lp
    snd                    59204  17 snd_hda_codec_intelhdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore               7264  1 snd
    snd_page_alloc          9156  2 snd_hda_intel,snd_pcm
    fbcon                  36640  72 
    tileblit                2460  1 fbcon
    font                    8124  1 fbcon
    bitblit                 5372  1 fbcon
    softcursor              1756  1 bitblit
    usb_storage            52768  0 
    usbhid                 38208  0 
    ohci1394               29900  0 
    ieee1394               86596  1 ohci1394
    i915                  226120  3 
    drm                   160032  3 i915
    i2c_algo_bit            5760  1 i915
    video                  19380  1 i915
    output                  2780  1 video
    e1000e                121996  0 
    intel_agp              27676  2 i915
    agpgart                34988  2 drm,intel_agp
    
    Bus 005 Device 002: ID 04ca:002f Lite-On Technology Corp. 
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 002: ID 058f:6363 Alcor Micro Corp. 
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 05ac:1293 Apple, Inc. 
    Bus 001 Device 005: ID 07d1:3a08 D-Link System predator Bootloader Download
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 003: ID 04b8:084d Seiko Epson Corp. 
    Bus 004 Device 002: ID 046d:c054 Logitech, Inc. 
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    There is a file /etc/modprobe.d/ndiswrapper which does not have a .conf extension. Is this causing the problem?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2010
    Posts
    30
    I gave up on the D-Link WUA 2340. I read up on it. It might have worked with a firmware file from Atheros, but nowhere to be found, mysteriously missing from any downloaded D-Link package.

    I bought a Belkin F5D8053 v.4 (USB Adapter) with a ralink chip, as recommended by various sites. I plugged it in, and it just worked with native drivers. Downloads fairly quickly too. For anyone who reads this and is having similar issues, I recommend you just buy a linux-compatible wifi adapter/card.

    I was tempted earlier to keep going down this troubleshooting path, thinking I'd learn more somehow through the process. I have, but I also wasted hours re-installing software and Ubuntu twice. That time would have been better working on C or bash scripting or something.

    My $0.02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •