Find the answer to your Linux question:
Results 1 to 4 of 4
For some strange reason, our router seems to let me connect to it, but disconnects me after a few seconds. This wasn't the case before. Also, after I reboot to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    34

    Router denying (?) WLAN access from linux


    For some strange reason, our router seems to let me connect to it, but disconnects me after a few seconds. This wasn't the case before. Also, after I reboot to Win7 or XP, the router still won't let me connect. The only solution to this in my case was to rename our wifi's network name and then reboot.

    Details:
    - the wlan card does get detected.
    - wifi USED TO work flawlessly, then after a few updates or hours, something happens and then I can't connect anymore.
    - card = realtek 8187b.
    - linux mint 9.
    - router = DIR-300

    a few more specific details:
    - i tried to edit a line in nsswitch.conf to "hosts: files dns" but still this doesn't solve the problem.
    - blacklisted ipv6.
    - same issues in almost all distros i have tried. in fedora (live), i can connect and view a few pages, but some won't open (ex. facebook).

    anyone have an idea on this? o.O help would be appreciated. i already tried the search stuff

  2. #2
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,274
    Hello!

    Sorry to keep you waiting but if I may suggest, boot mint 9 and paste all the outputs asked here. Let's start from there

    Enjoy!
    nujinini
    Linux User #489667

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    34
    Sorry. I already removed Mint 9 --' Next time I wouldn't be running away from problems. That's a promise

    Fedora's wireless works flawlessly (after I switched off ipv6 and set hosts to "files dns") even after a running time of a few days

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,274
    Glad to hear your wireless is already working!

    Enjoy the forums!
    nujinini
    Linux User #489667

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •