Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 29
Hi Waterhead, Thanks for the update. I ran the script, and this is the output I got:- Code: rex@linuxmint ~ $ sudo tail -f /var/log/messages [sudo] password for rex: Jul ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2010
    Posts
    10

    Hi Waterhead, Thanks for the update. I ran the script, and this is the output I got:-
    Code:
    rex@linuxmint ~ $ sudo tail -f /var/log/messages
    [sudo] password for rex: 
    Jul 20 16:14:36 linuxmint rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="737" x-info="rsyslog.com"] rsyslogd was HUPed, type 'lightweight'.
    Jul 20 16:14:38 linuxmint kernel: [  900.000023] Machine check events logged
    Jul 20 16:14:51 linuxmint kernel: [  912.344452] usb 1-8: USB disconnect, address 3
    Jul 20 16:15:20 linuxmint sudo: pam_sm_authenticate: Called
    Jul 20 16:15:20 linuxmint sudo: pam_sm_authenticate: username = [rex]
    after plugging in

    Code:
    Jul 20 16:15:20 linuxmint sudo: pam_sm_authenticate: username = [rex]
    Jul 20 16:16:14 linuxmint kernel: [  995.476017] usb 1-8: new high speed USB device using ehci_hcd and address 4
    Jul 20 16:16:14 linuxmint kernel: [  995.613221] usb 1-8: configuration #1 chosen from 1 choice
    Jul 20 16:16:14 linuxmint kernel: [  995.615975] scsi4 : SCSI emulation for USB Mass Storage devices
    Jul 20 16:16:15 linuxmint usb-modeswitch: switching 19d2:2000 (HSPA,Incorporated: HSPA WCDMA Technologies MSM)
    The site would not let me upload my answer saying that I was not allowed to post URL's so the only change that I made is to remove the "http" etc before the "rsyslog"
    Being a beginner in Linux I may be wrong, but it looks to me that the data card is getting recognised and the modeswitch is also working. I don't know what exactly is wrong and would really appreciate any help.

    Regards.
    Last edited by MikeTbob; 07-25-2010 at 09:59 PM. Reason: Added Code tags

  2. #12
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    When posting system info or data, surround it with code tags. More info on that can be found here:
    Linux Forums - BB Code List

    After modeswitch does it's magic, check the output of lsusb again. The list for the modem hopefully will now be different. Please post that info.

    I believe that the driver module may not be loading. If this is the case, it can manually be loaded using the USB ID of the modem.

    Code:
    sudo modprobe usbserial vendor=0x#### product=0x####
    You would replace the "#"s with the modem USB ID, not the ID you get when it is seen as a storage device. You may also need to manually load the option driver module.
    Code:
    sudo modprobe option
    Last edited by waterhead; 07-21-2010 at 11:33 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #13
    Just Joined!
    Join Date
    Jul 2010
    Posts
    10
    Hi Waterhead,
    I ran the var/log script once again and got a different output this time which I am giving below.
    Code:
    sudo tail -f /var/log/messages
    [sudo] password for rex: 
    Jul 23 14:57:28 linuxmint kernel: [  186.693351] Disabling lock debugging due to kernel taint
    Jul 23 14:57:28 linuxmint kernel: [  186.704894] ndiswrapper version 1.55 loaded (smp=yes, preempt=no)
    Jul 23 14:57:28 linuxmint kernel: [  186.856022] usb 1-8: reset high speed USB device using ehci_hcd and address 3
    Jul 23 14:57:29 linuxmint loadndisdriver: loadndisdriver: load_driver(358): couldn't load driver hspadatacardusbdiag
    Jul 23 14:57:29 linuxmint kernel: [  187.019159] usbcore: registered new interface driver ndiswrapper
    Jul 23 14:57:33 linuxmint kernel: [  191.637716] scsi 3:0:0:0: Direct-Access     HSPA     MMC Storage      2.31 PQ: 0 ANSI: 2
    Jul 23 14:57:33 linuxmint kernel: [  191.648280] sd 3:0:0:0: Attached scsi generic sg3 type 0
    Jul 23 14:57:33 linuxmint kernel: [  191.652692] sd 3:0:0:0: [sdb] Attached SCSI removable disk
    Jul 23 14:59:32 linuxmint sudo: pam_sm_authenticate: Called
    Jul 23 14:59:32 linuxmint sudo: pam_sm_authenticate: username = [rex]

    I ran the lsusb command after this and got this output

    Code:
    rex@linuxmint ~ $ sudo lsusb
    [sudo] password for rex: 
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 003: ID 19d2:0108 ONDA Communication S.p.A. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    rex@linuxmint ~ $ sudo modprobe option
    WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
    rex@linuxmint ~ $ sudo modprobe usbserial vendor=0x19d2 product=0x0108
    WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
    Please let me know what I need to do. I would be very grateful for any help.

    Regards,
    Rex
    Last edited by MikeTbob; 07-25-2010 at 10:00 PM. Reason: Added Code tags

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    First, when using "code tags", the ending one needs a / at the beginning.

    This looks to be the modem:
    Code:
    Bus 001 Device 003: ID 19d2:0108 ONDA Communication S.p.A
    Use that ID when loading the usbserial module. I explained how in my last post. You can check the output of lsmod first, to see if they are already loaded. They will then have to be unloaded first.
    Code:
    sudo modprobe -r option
    Code:
    sudo modprobe -r usbserial
    Code:
    sudo modprobe usbserial vendor=0x19d2 product=0x0108
    Code:
    sudo modprobe option
    You now may be able to use the modem.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #15
    Just Joined!
    Join Date
    Jul 2010
    Posts
    10
    Thanks Waterhead, I'll try and let you know

  7. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    If it works, you may be able to make it automatic.

    First, you need to load the usbserial module with the USB ID of your device. You need to create a file in /etc/modprobe.d/. Call it anything, but for simplicity I will name it usbserial.conf.
    Code:
    sudo touch /etc/modprobe.d/usbserial.conf
    Then add the options to the file. Open it in gedit:
    Code:
    gksu gedit /etc/modprobe.d/usbserial.conf
    Add this to the empty file, and save and exit it.
    Code:
    options usbserial vendor=0x19d2 product=0x0108
    You also must add your card to the usb_modeswitch list of supported cards. In this folder:

    /etc/usb_modeswitch.d/

    You can modify an existing file to include your device. Open the 19d2_2000_uPr=ZTE_CDMA file, and change this:
    Code:
    ########################################################
    # ZTE MF626 and others (WE NEED MORE ID INFO!)
    
    DefaultVendor=  0x19d2
    DefaultProduct= 0x2000
    
    TargetVendor=   0x19d2
    
    TargetProductList="0002,0031,0037,0052"
    
    CheckSuccess=20
    
    MessageContent="55534243123456782000000080000c85010101180101010101000000000000"
    To this (just add your product ID to the list):
    Code:
    ########################################################
    # ZTE MF626 and others (WE NEED MORE ID INFO!)
    
    DefaultVendor=  0x19d2
    DefaultProduct= 0x2000
    
    TargetVendor=   0x19d2
    
    TargetProductList="0002,0031,0037,0052,0108"
    
    CheckSuccess=20
    
    MessageContent="55534243123456782000000080000c85010101180101010101000000000000"
    I am not 100% sure that this part will work, but it's worth a try. Also, there is suppose to be a usb_modeswitch log that you can check for error messages, found in /var/log/.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #17
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I just realized that my Ubuntu 9.10 install is using an older version of usb_modeswitch:
    Code:
    $ usb_modeswitch -e
    
     * usb-modeswitch: handle USB devices with multiple modes
     * Version 1.1.0 (C) Josua Dietze 2010
     * Based on libusb 0.1.12
    
     ! PLEASE REPORT NEW CONFIGURATIONS !
    The latest version is 1.1.3. I downloaded the source files and found that your device is supported in the newer version. I think that you may just want to uninstall the old version, and use the latest.

    Draisberghof - Software - USB_ModeSwitch

    You need both the usb-modeswitch and usb-modeswitch-data source . There is a Debian package available, but I do not know if that will work on Ubuntu/Mint.

    The latest version has this configuration file for your device. you may want to use it instead of the one I provided in my last post.
    Code:
    ########################################################
    # ZTE devices
    
    DefaultVendor=  0x19d2
    DefaultProduct= 0x2000
    
    TargetVendor=   0x19d2
    TargetProductList="0001,0002,0015,0016,0017,0031,0037,0052,0055,0063,0064,0108,0128"
    
    MessageContent="5553424312345678000000000000061e000000000000000000000000000000"
    MessageContent2="5553424312345679000000000000061b000000020000000000000000000000"
    
    NeedResponse=1
    
    CheckSuccess=20
    I still think that installing the newer version of usb_modeswitch is the best route to follow. You still will need the modified usbserial options too.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #18
    Just Joined!
    Join Date
    Jul 2010
    Posts
    10
    Hi Waterhead, I have already installed both the modeswitch and modeswitch data in channel. I did this by downloading both these apps in XP, logging into linux and then installing it. As you have also mentioned, the latest versions of ubuntu are supposed to recognise such devices, and since Mint is based on Ubuntu it should too, but for some weird reason, it does not for me. Every time I plug in the data card, I get an error popup that says
    Unable to mount BSNL 3G
    DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found

    Will try the new code, and let you know how things go.

    Regards,
    Rex Fernando.

  10. #19
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by Inkit View Post
    As you have also mentioned, the latest versions of ubuntu are supposed to recognise such devices...
    NOT the latest Ubuntu/Mint version, but the latest usb_modeswitch version. What version are you using?
    Code:
    usb_modeswitch -e
    Please do not send Private Messages to me with requests for help. I will not reply.

  11. #20
    Just Joined!
    Join Date
    Jul 2010
    Posts
    10
    usb-modeswitch-data -- version 20100127-1
    usb-modeswitch -- version 1.1.0-2

    I had previously taken this information from package manager. I haven't run your script as yet. will let you know if there is any difference.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •