Find the answer to your Linux question:
Results 1 to 3 of 3
Distribution: Arch Linux 2010.05 Kernal: 2.6.33.4 System Info: Intel Core2Duo 1.8GHz 2GB Crucial DDR2 667MHZ RAM ASrock 775-DualVSTA Motherboard NVIDIA 8800GT 512MB PCI-Express Graphics Card 500GB SATA Western Digital Caviar ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38

    wlan0 interface won't auto load


    Distribution:Arch Linux 2010.05
    Kernal:2.6.33.4

    System Info:
    Intel Core2Duo 1.8GHz
    2GB Crucial DDR2 667MHZ RAM
    ASrock 775-DualVSTA Motherboard
    NVIDIA 8800GT 512MB PCI-Express Graphics Card
    500GB SATA Western Digital Caviar Blue (MAIN SYSTEM DRIVE)
    250GB IDE Western Digital Caviar
    300GB SATA WEstern Digital Caviar RE16
    160GB IDE Maxtor Diamondmax Plus 9
    500W Casecom power supply


    Hi All,

    I'm having a problem getting my wlan0 interface to auto load at startup.

    I am using ndiswrapper for my Zoom Wireless-G USB card because there are no linux drivers for it. I have also decided to use Wicd for managing my wireless connections, as opposed to using netcfg like I used to use.

    The problem i'm having is that arch automatically starts my ethernet interface (eth0) on startup, yet it won't auto start my wireless interface (wlan0). Therefore I can't see any wireless connections. However, if I bring up the interface manually (ifconfig wlan0 up), then the wireless works fine.

    During the setup of Wicd the manual told me to comment out the eth0 and wlan0 interfaces in /etc/rc.conf, im assuming this is because Wicd carries out these options instead. I have tried uncommenting the wlan0 interface in /etc/rc.conf and still no success. Does anyone have any idea why its starting my eth0 interface, but not my wlan0 interface?.

    *note* in my deamons array I have the following:
    syslog-ng dbus hal crond ndiswrapper !network wicd alsa gdm
    When I uncommented the wlan0 interface in rc.conf i also uncommented the network deamon too.

    Any ideas?

    Thanks in advance,
    Scott.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    ndiswrapper is not a daemon. It should go in the modules array earlier in the file.
    Code:
    MOD_AUTOLOAD="yes"
    #MOD_BLACKLIST=() #deprecated
    MODULES=(ndiswrapper)
    Also, hal starts dbus so you don't usually need to specify it separately. At least, I never have.

    I would guess that ndiswrapper isn't loading properly because of the above and therefore there is no wlan0 to bring up at boot.

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Hi Reed long time no speak,

    Yeah I realised that, I had a bit of a stupid moment, and for some reason no matter how many times i read the ndiswrapper tutorial on Archwiki, I thought it said place it in the deamons array.

    I removed it and added it to the modules array and commented out the wireless interface again to let wicd handle the interfaces and its all working fine now, apart from my poor wireless signal strength. I think it may be time to make a cantenna.

    Thanks for the help Reed,
    Scott.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •