Find the answer to your Linux question:
Results 1 to 2 of 2
Hey all, could you help me out? I've installed Ubuntu Maverick on my tower and I really like it, but it's simply impossible to get anything wireless working. I've got ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    2

    Question A linux distro that supports my cards out of the box?


    Hey all, could you help me out? I've installed Ubuntu Maverick on my tower and I really like it, but it's simply impossible to get anything wireless working. I've got two cards to choose from, Linksys WUSB00N (USB a/b/g/n) and a ZyDas USB B/G. I've tried native drivers, new firmware, NDISwrapper, and all possible combinations of them, but nothing works and I'm pretty sick of it. There was even one point where I got both NDISwrapped and hardware was present and when I modprobed the whole thing crashed! I also have a PCI linksys WMP54GS sitting around, but it's mostly broken.

    Basically, I'm sick of it. Before it crashed, I had a 1997 laptop running Puppy Linux (a very nice, small distro. Great rescue CD too). I know for sure the ZyDas card worked with that out of the box, and possibly also the Linksys USB stick. I might not mind having Puppy on my nice dualcore tower, but my entire family has to use this thing and I need it to be multi-user. Puppy's only option is Root.

    Does anyone know of a distro that will work out of the box with the Linksys stick (rt2870 chipset), the ZyDas card, or even the PCI one? I really don't care. I just need my wifi.

    Thanks in advance!

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    The biggest problem people in your situation have is having too many of the wrong (or wrong and right) drivers installed. Remove/uninstall all the wireless cruft you have added (delete the .ko files as well). Reboot and download the kernel source. Configure the kernel source to support your wireless hardware. There is direct kernel driver support for ZyDas ZD1211 USB devices, and there is likely support for the Linksys devices as well, depending upon their chipsets. You can run "make menuconfig" and see if the appropriate drivers are built, either directly into the kernel, or as loadable modules. In some cases, usually for Broadcom 43xx chip set devices, you need to install the proprietary firmware, which you can cut from the Windows drivers using the b43-fwcutter program, or install them directly by going to the System->Administration->Additional Drivers on Ubuntu Meercat (10.10). I think the menu entry is "Additional Drivers", but I may misremember since I am not running that OS right now. Anyway, it is "Something" Drivers.

    So, try one thing at a time. If it doesn't work, then uninstall that component and try another. Definitely DO NOT install more than one driver/firmware package at a time. I have found that usually does not work.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •