Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, I have just installed CentOS 5 on my Toshiba Satellite harman/kardon Laptop. It runs the Realtek 8192 SE W-Lan Card and I have downloaded the Linux Driver for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2011
    Location
    TN, USA
    Posts
    2

    Realtek 8192SE on CentOS - Step by Step Guide?


    Hi all,

    I have just installed CentOS 5 on my Toshiba Satellite harman/kardon Laptop.
    It runs the Realtek 8192 SE W-Lan Card and I have downloaded the Linux Driver for it onto a USB stick using a different machine, as my Toshiba (obviously) is not online.

    I have never used Linux before, so I need to have it dumbed down, because the so called step by step guides I found, the commands for the terminal it lists, aren't recognized by my terminal.

    I also tried to follow the step in the Sticky up here, but typing the listed commands in the sticky into my terminal only gave me error messages:

    Code:
     bash: lspci: command not found
    same for lsmod ... lsusb listed my mouse and usb stick correctly, but no wlan thingi, as I do not have a wlan USB device... but only the built in Realtek Card.

    So basically... I have the driver on the USB stick - for easier use, I copied it onto my desktop.

    So now, I have the file:

    rtl8192se_linux_2.6.0019.1207.2010.tar.gz

    on my Desktop, and a Terminal Window open ... What next?

    By the way... the Readme provided by Realtek has some How to commands - those as well did not work ...

    What am I doing wrong?

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello and welcome to the forums!

    For some quick and easy lessons on using the Linux command line, check out this site:

    LinuxCommand.org: Learn the Linux command line. Write shell scripts.

    It might be that with Red Hat and some of its forks, you will need to add more to your commands to get them to work. Maybe try switching to root with the su command like this:

    Code:
    su
    or...

    Code:
    su -
    Also, you might try adding /sbin/ before the command, such as:

    Code:
    /sbin/lspci
    Code:
    /sbin/lsmod
    Hope some of that will help you get the output you seek.
    oz

  3. #3
    Just Joined!
    Join Date
    Apr 2011
    Location
    TN, USA
    Posts
    2
    Thank you, ozar
    The link is worth gold and I am eagerly reading over its contents.

    As for the Realtek 8192SE issue on CentOS - We found the solution.

    We is my husband who has returned from working and was able to guide me through a few things...

    So...
    We found out: CentOS 5 still uses the old Kernels and the Linux Driver by Realtek does not support the old Kernels anymore.
    We tried to compile ndiswrapper and then with it the winXP driver for the Wireless Card - but ndiswrapper doesn't support the old Kernel anymore either.

    Conclusion: CentOS 5 is not compatible with the Realtek 8192se Wireless Card and I now have to find another distro.

    Fedora, or Ubuntu?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,748
    Upgrade to Scientific Linux 6 - it is a RHEL 6 clone. That has support for new wireless hardware drivers. You can get it here: Scientific Linux - Welcome to Scientific Linux (SL)
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •