Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Greetings, I am a noob with Ubuntu (so far I really like it!) and have loaded the OS on one of my Win machines (dual boot) which I have been ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    11

    Netgear WG111T WiFi Dongle and Ubuntu 11.04


    Greetings,

    I am a noob with Ubuntu (so far I really like it!) and have loaded the OS on one of my Win machines (dual boot) which I have been using a Netgear WiFi dongle for connectivity.

    I am a little perplexed and can't find out how to install the drivers/program for the dongle. I can run a CAT5 to the machine but it is not a long-term option....

    Any help would be most appreciated.

    Thanks in advance.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome to LFO.
    Start here and post your results back into this thread please.
    http://www.linuxforums.org/forum/wir...tart-here.html
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Location
    Alameda, CA
    Posts
    6
    That is one tough instruction set for someone new to linux. In Ubuntu 11.04, Unity, there is a very small triangle in the upper right hand task bar. That triangle is the Ubuntu request for wireless internet information.

    Click on the triangle to open the window for configuring your wireless internet.
    After you click on the triangle, you will see a list of wireless networks.
    Click on your network. it will either connect automatically ore you will get another window telling you to authenticate. If you have no security, hit enter.

    After you get connected to the internet, you should look on the bottom of the modem for the mac address and password protect your network. It is okay to tape the password all over your house. You want it secure from outside people who want to do bad things.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    Thanks Ted. I did that on on an Ubuntu install on my laptop and it worked fine. Trying on my desktop (which connects via the USB dongle) did not work as the driver(s) for the WG111T are not on the Unbutu side (only the Win side).

    I will agree that the original post, although greatly appreciated, is daunting at best...

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    It's not as difficult as it looks at first...

    First thing to do is open a terminal.

    For a usb wireless adapter, we only really need a couple of pieces of info to get started. Copy the below and paste it into the terminal
    Code:
    lsusb >> wireless.txt && lsmod >> wireless.txt
    You will now find in your home directory a file called wireless.txt with the output of these two commands in it. Either attach the file or paste the contents here (and use code tags for the latter).

  7. #6
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    Awesome... thank you. Here you go:

    Code:
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 007: ID 1385:4251 Netgear, Inc WG111T (no firmware)
    Bus 001 Device 006: ID 046d:c52f Logitech, Inc. Wireless Mouse M305
    Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 001 Device 004: ID 0d62:001c Darfon Electronics Corp. Benq X120 Internet Keyboard Pro
    Bus 001 Device 003: ID 0bda:0111 Realtek Semiconductor Corp. Card Reader
    Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Module                  Size  Used by
    isofs                  40283  0 
    parport_pc             36959  0 
    ppdev                  17113  0 
    binfmt_misc            17565  1 
    snd_hda_codec_realtek   336693  1 
    snd_hda_intel          33211  2 
    snd_hda_codec         103804  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              13604  1 snd_hda_codec
    snd_pcm                96625  2 snd_hda_intel,snd_hda_codec
    snd_seq_midi           13324  0 
    snd_rawmidi            30486  1 snd_seq_midi
    snd_seq_midi_event     14899  1 snd_seq_midi
    snd_seq                61621  2 snd_seq_midi,snd_seq_midi_event
    i915                  514985  3 
    snd_timer              29602  2 snd_pcm,snd_seq
    snd_seq_device         14462  3 snd_seq_midi,snd_rawmidi,snd_seq
    joydev                 17606  0 
    drm_kms_helper         42136  1 i915
    psmouse                73535  0 
    drm                   227495  4 i915,drm_kms_helper
    snd                    67382  13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    serio_raw              13166  0 
    soundcore              12680  1 snd
    snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
    i2c_algo_bit           13400  1 i915
    video                  19438  1 i915
    lp                     17825  0 
    parport                46458  3 parport_pc,ppdev,lp
    usbhid                 46956  0 
    hid                    91020  1 usbhid
    usb_storage            53538  0 
    uas                    17996  0 
    firewire_ohci          40370  0 
    ahci                   25951  1 
    e100                   40946  0 
    firewire_core          62646  1 firewire_ohci
    libahci                26642  1 ahci
    crc_itu_t              12707  1 firewire_core

  8. #7
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    There is currently a linux driver in the works for this wireless device. I don't know how well it works yet.

    The other option is to use ndiswrapper and a windows XP or earlier driver. (Vista and Windows 7 drivers won't work.)

    NetGear WG111T Ubuntu Gareth R. White
    https://help.ubuntu.com/community/Wi.../Device/WG111T

  9. #8
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    Thank you for the links and info. I just can't seem to get the dongle 'found' by the system. I did scrape off the .inf file and had the Wireless Assistant thing try and load it in and just never worked. Tried method #2 (longer/more steps) to no avail..

    Sigh.

  10. #9
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Can you be more specific about what you tried?

    I'm assuming you installed ndiswrapper already. Otherwise do
    Code:
    sudo apt-get install ndiswrapper-common ndiswrapper-dkms ndiswrapper-utils-1.9
    If you were trying to use ndiswrapper already, remove the module
    Code:
    sudo modprobe -r ndiswrapper
    Now try this
    Code:
    mkdir netgear && cd netgear
    wget http://data.versiontracker.com/drivers/manual/Netgear/wg111t_1_2.zip
    unzip wg111t_1_2.zip
    cd WG111T_re1.2_rc1
    sudo ndiswrapper -i netwg11t.inf
    sudo ndiswrapper -i athfmwdl.inf
    sudo depmod -a
    sudo modprobe ndiswrapper
    EDIT: Does Ubuntu have unzip out of the box? May need to install
    Code:
    sudo apt-get install unzip
    Check if there is now a wireless interface
    Code:
    iwconfig
    Most likely the interface will be called wlan0. Assuming that's there, check that it's working by scanning for local networks
    Code:
    sudo iwlist wlan0 scan
    Assuming that works, you should be good to go and can configure your network as usual through the network manager.

    Add ndiswrapper to the list of modules to load at boot.
    Code:
    echo "ndiswrapper" | sudo tee -a /etc/modules

  11. #10
    Just Joined!
    Join Date
    May 2011
    Posts
    11
    Never did the wrapper thing... one posting I read (first one you linked) said not to? Unless I misread.

    OK so I ran the wrapper command (first CODE item), did the second batch of CODE then did this:

    Code:
    iwconfig
    and this came back:

    Code:
    MYNAME@ubuntu:~/netgear/WG111T_re1.2_rc1$ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    Tried the other set of commands and got this back:

    Code:
    MYNAME@ubuntu:~/netgear/WG111T_re1.2_rc1$ sudo iwlist wlan0 scan
    wlan0     Interface doesn't support scanning.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •