Find the answer to your Linux question:
Results 1 to 1 of 1
I am trying to install the driver in order to get my new wireless working, however Ive run into the end for me. Following a guide on THIS website from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    1

    [BackTrack5] AWUSO36NH 3070 help


    I am trying to install the driver in order to get my new wireless working, however Ive run into the end for me.

    Following a guide on THIS website from ~2010 that I cant post the link to because I get this error:"You are only allowed to post URLs to other sites after you have made 15 posts or more."
    everything seemed to work. However, no LEDs are lit on the transmitter.

    Code:
    5. Add a missing symlink.
    sudo mkdir /etc/Wireless/RT2870STA; sudo ln -s /etc/Wireless/RT3070STA/RT3070STA.dat /etc/Wireless/RT2870STA/RT2870STA.dat
    That is the only additional step that I did.

    Here is all the relevant output (I believe):
    Code:
    root@bt:~# lsmod | grep rt
    rt5370sta             733406  0 
    parport                34080  1 lp
    root@bt:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      no wireless extensions.
    
    ra0       Ralink STA  
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    
    root@bt:~# lsusb | grep al
    Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. 
    root@bt:/# sudo modprobe rt3070sta
    FATAL: Module rt3070sta not found.
    I am quite new to Linux, but I believe the "mod" should be rt3070sta, not 5370. My device ID from lsusb also falls into the guidelines for rt3070sta.

    Code:
    find . -name *rt3070*
    ./usr/src/linux-source-2.6.38/drivers/staging/rt2870/chips/.rt3070.o.cmd
    ./usr/src/linux-source-2.6.38/drivers/staging/rt2870/chips/rt3070.o
    ./usr/src/linux-source-2.6.38/drivers/staging/rt2870/chips/rt3070.c
    ./usr/src/linux-source-2.6.38/drivers/staging/rt2860/chips/rt3070.c
    ./usr/src/linux-source-2.6.38/drivers/staging/rt2860/chip/rt3070.h
    ./lib/firmware/rt3070.bin
    ./root/s/2011_0407_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.2_DPO/chips/.rt3070.o.cmd
    ./root/s/2011_0407_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.2_DPO/chips/rt3070.o
    ./root/s/2011_0407_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.2_DPO/chips/rt3070.c
    ./root/s/2011_0407_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.2_DPO/include/chip/rt3070.h
    ./root/installs/2009_1110_RT3070_Linux_STA_v2.1.2.0/chips/.rt3070.o.cmd
    ./root/installs/2009_1110_RT3070_Linux_STA_v2.1.2.0/chips/rt3070.o
    ./root/installs/2009_1110_RT3070_Linux_STA_v2.1.2.0/chips/rt3070.c
    ./root/installs/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/.tmp_versions/rt3070sta.mod
    ./root/installs/2009_1110_RT3070_Linux_STA_v2.1.2.0/include/chip/rt3070.h
    ./root/installs/RT3070_LinuxSTA_V2.3.0.1_20100208/chips/rt3070.c
    ./root/installs/RT3070_LinuxSTA_V2.3.0.1_20100208/include/chip/rt3070.h
    The .tar in directory /s/ is the one that I finally wound up installing. I tried and failed a few times on the others, so I dont know if that has anything to do with anything.


    Thanks!







    EDIT:
    Ok, i feel like an idiot, but I am still not quite sure what to do. My latest dabblings:

    Code:
    root@bt:/# ifconfig ra0 up
    root@bt:/# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      no wireless extensions.
    
    ra0       Ralink STA  ESSID:""  Nickname:"RT2870STA"
              Mode:Auto  Frequency=2.412 GHz  Bit Rate=1 Mb/s   
              RTS thr:off   Fragment thr:off
              Encryption key:off
              Link Quality=10/100  Signal level:-74 dBm  Noise level:-74 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    I still dont see any wireless networks... but at least the damn things blinking now.
    Last edited by miketgw; 07-03-2011 at 07:59 AM. Reason: Wont let me post code because it thinks its a URL...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •