Find the answer to your Linux question:
Results 1 to 10 of 10
I first experienced this problem using Network Manager, so I decided to blow it away and go entirely manual in order to try to understand what the problem is. I've ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2011
    Posts
    9

    Wireless doesn't recover from sleep mode.


    I first experienced this problem using Network Manager, so I decided to blow it away and go entirely manual in order to try to understand what the problem is. I've been able to get the wireless to work using wpa_supplicant, iwconfig, and dhclient, but still experiance the sleep mode problem. I'm running out of useful thoughts on debugging, and could use a nudge into the right direction.

    I've attached the things I'm using to manually setup my wireless.

    wireless_script.txt works fine after a restart, but does not after sleep mode. I'm attempting to basically "Restart" all services related to wireless networking, as if I'm starting from scratch so if im missing something, please point it out.

    my wireless setup is attached in wireless_setup.txt
    my wpa_supplicant.conf file is attached as well (slightly modified.) like I said, it works but only on a fresh boot.

    The goal here is to get my networking in a completely virgin state, and bring up everything I need manually, and learn what is causing the script to fail after sleep mode.

    ~Jon
    Attached Files Attached Files

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,158
    What distribution+version+kernel are you running? I am currently running Scientific Linux 6.1 (RHEL 6.1 clone) on my Dell D630 laptop (2.6.32-131.21.1 kernel) and it recovers from sleep and hibernate just fine.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Nov 2011
    Posts
    9
    ++ cat /etc/*-release
    Fedora release 16 (Verne)
    ++ uname -mrs
    Linux 3.1.2-1-fc16.x86_64 64 x86_64

    I'm not convinced anymore that its specifically triggered by sleep mode. It just goes down after a random amount of time. I cannot get it to recover any other way than restarting the comp right now.

    other userful? tidbit:
    after I send:
    bash# ip link set wlan0 up
    I get back
    Input/Output failure

    Any ideas?
    additionally #`service network restart` always seems to fail. I'm certain I haven't completely brought down the network, I would think bringing everything down then back up would atleast let me know which part of the system is failing, but I haven't' figured out how to completely shut down networking.

    ~Jon

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,158
    Have you looked at your power manager preferences? It may be that it is set to shut the system down after some period of inactivity.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    Nov 2011
    Posts
    9

    Suspend mode not the root cause

    Its been disabled for some time. Its probably not related to suspend mode. I had it happen while I was in front of the computer recently.

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Try looking at the output of dmesg next time you have trouble.
    Code:
    dmesg | tail -100
    Will spit out the last 100 lines of kernel messages.


    I did notice in one of your above attachments:
    wpa_supplicant -i wlan0 -D wext -c /etc/wpa_supplicant.conf -B
    Which I think should be
    Code:
    wpa_supplicant -i wlan0 -Dwext -c /etc/wpa_supplicant.conf -B
    Either way, I'm not sure if this is going to help you with your problem.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Just Joined!
    Join Date
    Nov 2011
    Posts
    9
    Allright, I want to get this to work once and for all

    $ ethtool -i wlan0
    driver: ath9k
    version: 3.3.4-3.fc16.x86_64
    firmware-version: N/A
    bus-info: 0000:04:00.0
    supports-statistics: no
    supports-test: no
    supports-eeprom-access: no
    supports-register-dump: no
    ---
    $ uname -r
    3.3.4-3.fc16.x86_64
    ---
    I'm using NetworkManager to manage my connections.
    Network manager simply prompts over and over again for a password (which I give the corret one) and tries to configure until I tell it to give up.

    the network adapter is a linksys wmp110
    $ lspci | grep Ath
    04:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)

    Its using the ath9k driver, this is supposed to be the correct one.

  8. #8
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    928
    Have you tried power cycling your router? Unplug router for 30 seconds and then reconnect. On occasion, the router develops issues which recycling will solve.
    Registered Linux user #526930

  9. #9
    Just Joined!
    Join Date
    Nov 2011
    Posts
    9
    Quote Originally Posted by MASONTX View Post
    Have you tried power cycling your router? Unplug router for 30 seconds and then reconnect. On occasion, the router develops issues which recycling will solve.
    thanks for the reply

    yeah, I've done that, a few times...

    i've decided that there is a legitimate problem with the drivers. Maybe I'll try to look at the code one of these days. Or i could just spend 20 bucks on a new card

  10. #10
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    You could also try the ath5k driver just for giggles.
    login as root and type
    modprobe -r ath9k
    modprobe ath5k
    Check your connections.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •