Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Any Hope for Monoprice USB Wifi Devices? (Ralink, Realtek)

    I have 3 Monoprice 802.11n USB adapters that I got as a side effect of another transaction. For all 3 devices, the packaging declares Linux as a supported OS on both the front and back, as do the paper instruction manual and CD, but after numerous sessions trying to get them working, none of the 3 is useful. I've tried with Debian 6, several live distros, and periodically with Debian testing weekly ISOs, in a room with ~2 meters clear line of sight separation.

    Monoprice product #5333 was sold as being Ralink 3070 based
    Monoprice product #6147 was sold as being Realtek RTL8191SU based
    Monoprice product #6148 was sold as being Realtek RTL8188SU based

    The 5333 (148f:3070) seems to load its firmware successfully and responds to iwconfig/ifconfig/iwlist/iw as you'd expect, but fails in various ways: sometimes simply failing to associate, but usually establishing a successful connection and then dropping it within a few minutes. Logs vary with each version of distro and kernel, for example "No probe response from AP" or "disassociating by local choice (reason=3)". Sometimes data transfer begins with a surge for a second or 2, but then stalls for minutes at a time until the connection drops.

    I experienced what others have noticed, that the USB-ID changes for the Realtek devices. Initially the 6147 was 0bda:8172 and the 6148 was 0bda:8171, but now both identify as 0bda:8192
    Both Realtek devices will not even load firmware, so there's not much to test with them.

    kern.log says
    rtl819xU:EEPROM ID is invalid(is 0x0(should be 0x8129)

    usb 4-2: not running at top speed; connect to a high speed hub
    (mass storage devices as well as the 5333 do connect at high speed)

    I've tried various workarounds for the firmware problem (including following instructions on the net for modifying udev rules), but haven't found one that works.

    Other than the USB-ID, is there a way to determine what chip is actually being used in each device? Why would the ID change?

    If anyone knows how to get these devices working with Debian (and hopefully other Free systems), I'd appreciate your advice.

    BTW, the 2 Realteks have wps buttons: Do these function with Linux drivers?


  2. #2
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Mason Texas
    I have a ralink 3070 device that works fine with Ubuntu, but had problems with several other distro's. Drivers are available on line. Try Ralink-A MEDIATEK COMPANY. If I remember right, it uses the rt2870 driver.
    Registered Linux user #526930

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    This site has been awesome for getting WiFi working with various Linux distributions: Welcome - Linux Wireless
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
  5. #4
    Other than the USB-ID, is there a way to determine what chip is actually being used in each device? Why would the ID change?
    Mine works fine in AntiX but the chip model is a little different

    harry@biker:~$ lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
    Now as root in terminal

    # lshw -C network
           description: Ethernet interface
           product: RTL-8139/8139C/8139C+
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 2
           bus info: pci@0000:02:02.0
           logical name: eth0
           version: 10
           serial: 00:16:76:dd:65:f5
           size: 10Mbit/s
           capacity: 100Mbit/s
           width: 32 bits
           clock: 33MHz
           capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
           resources: irq:9 ioport:1000(size=256) memory:60010000-600100ff
           description: Wireless interface
           physical id: 1
           bus info: usb@1:2
           logical name: wlan0
           serial: 00:e0:4c:5a:56:07
           capabilities: ethernet physical wireless
           configuration: broadcast=yes driver=rtl8187 driverversion=2.6.38-7.dmz.2-liquorix-686 firmware=N/A ip=<filtered> link=yes multicast=yes wireless=IEEE 802.11bg
    Notice that wlan0 which is my wireless usb is using driver=rtl8187

    No dropped connections for days, I use wicd for connection, on this

    ~$ inxi -F
    System:    Host: biker Kernel: 2.6.38-7.dmz.2-liquorix-686 i686 (32 bit) 
               Desktop Fluxbox 1.3.1 Distro: antiX-M11-base-686 Jayaben Desai 25 April 2011
    Machine:   System: GATEWAY product: W3507 version: 500
               Mobo: Intel model: D102GGC2 version: AAD70214-201
               Bios: Intel version: GC11020M.15A.2010.2006.0817.0956 date: 08/17/2006
    CPU:       Single core Intel Celeron D CPU (-UP-) cache: 512 KB flags: (lm nx sse sse2 sse3) clocked at 3200.438 MHz 
    Graphics:  Card: ATI RC410 [Radeon Xpress 200] X.Org: driver: radeon Resolution: 1024x768@85.0hz 
               GLX Renderer: Gallium 0.4 on ATI RC410 GLX Version: 2.1 Mesa 7.11
    Audio:     Card: ATI IXP SB4x0 High Definition Audio Controller driver: HDA Intel Sound: ALSA ver: 1.0.23
    Network:   Card-1: Realtek RTL-8139/8139C/8139C+ driver: 8139too 
               IF: eth0 state: down mac: <filtered>
               Card-2: Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter driver: rtl8187 
               IF: wlan0 state: up mac: <filtered>
    Drives:    HDD Total Size: 120.0GB (7.6% used) 1: /dev/sda ST3120213A 120.0GB 
    Partition: ID: / size: 109G used: 8.5G (9%) fs: ext3 ID: swap-1 size: 2.17GB used: 0.00GB (0%) fs: swap 
    Sensors:   System Temperatures: cpu: 45.9C mobo: 46.1C 
               Fan Speeds (in rpm): cpu: 2263 fan-2: 1118 fan-4: 0 
    Info:      Processes: 84 Uptime: 2 days Memory: 256.8/880.0MB Client: Shell inxi: 1.7.27
    The Network card 2 in my inxi readout is actually the USB wireless. In case you wish to install inxi in Debian, You can also install smxi also if you wish. It is Debian compatible also.
    INXI Homepage:
    inxi - A newer, better system information script for irc, administration, and system troubleshooters. - Google Project Hosting

    smxi Manual which talks about what smxi is about
    smxi Manual :: Configuration and Operation Information

    What Debian has to say about your Ralink 3070 chip

    rt2870sta - Debian Wiki

    Lastly, Wicd connects me with this USB with my wpa2 encrypted network also. I don't know if your usb wifi sticks support wpa or not, maybe just wep.
    I refuse to let fear and fear of others rule my life. It puts my humanity at risk.
    Accepting Death is the only way to stay alive.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts