Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Only getting 52 Mb/s from my 802.11N, Ubiquiti SR71-E, Atheros AR9280 adapter in my HTPC ( Linux 2.6.32 ) that has a nice 6 inch antenna. It is only about ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10

    Not getting 802.11N speeds from AR9280 and ath9k


    Only getting 52 Mb/s from my 802.11N, Ubiquiti SR71-E, Atheros AR9280 adapter in my HTPC ( Linux 2.6.32 ) that has a nice 6 inch antenna. It is only about 15 feet from the router and goes through 1 hollow drywall interior wall.
    I have 2 laptops that connect farther away and get much faster speeds. My 5 year old Macbook also running Ubuntu 10.04 (Kernel 2.6.32) is getting 195 Mb/s right now. ( Atheros AR5008 ) Both use Ath9k module. The AP is set to 802.11N only mode and 5ghz.

    The HTPC settings are in /etc/network/interface because it doesn't have the GUI Network Manager. The manufacturers specs confirm it does 802.11n at 5 ghz. The ath9k website says that this chip has been supported since 2.6.27 kernel. The HTPC kernel is 2.6.32. "iw list" command doesn't list bitrates over 54 Mb/s. I upgrade the wireless modules to ones backported from 2.6.38 it changed nothing. Do you think I need a even newer kernel, or could I be missing something? Maybe I'll try out the beta version of XBMC


    /etc/network/interfaces

    auto wlan0
    iface wlan0 inet dhcp
    wpa-driver wext
    wpa-conf /etc/wpa_supplicant.conf

    network={
    ssid="livefire"
    #psk="********"
    psk=******...
    }

    iw dev wlan0 link

    Connected to 58:6d:8f:78:15:43 (on wlan0)
    SSID: livefire
    freq: 5180
    RX: 1736217513 bytes (3046326 packets)
    TX: 48245106 bytes (488617 packets)
    signal: -59 dBm
    tx bitrate: 52.0 MBit/s MCS 11

    modinfo ath9k

    filename: /lib/modules/2.6.32-38-generic/updates/compat-wireless-2.6.35/ath9k.ko
    license: Dual BSD/GPL
    description: Support for Atheros 802.11n wireless LAN cards.
    author: Atheros Communications
    srcversion: 032F6A7E12347D89F037DCE
    alias: pci:v0000168Cd0000002Esv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Dsv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Csv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Bsv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Asv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000029sv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000027sv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000024sv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000023sv*sd*bc*sc*i*
    depends: ath9k_hw,mac80211,led-class,ath,cfg80211,ath9k_common
    vermagic: 2.6.32-38-generic SMP mod_unload modversions 586
    parm: debugebugging mask (uint)
    parm: nohwcryptisable hardware encryption (int)

    lspci -vvk

    04:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
    Subsystem: Device 0777:4e05
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 19
    Region 0: Memory at febf0000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [40] Power Management version 2
    Flags: PMEClk- DSI- D1+ D2- AuxCurrent=375mA PME(D0+,D1+,D2-,D3hot+,D3cold-)
    Status: D0 PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
    Address: 00000000 Data: 0000
    Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
    ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
    DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
    RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
    MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM unknown, Latency L0 <512ns, L1 <64us
    ClockPM- Suprise- LLActRep- BwNot-
    LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk-
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
    Vector table: BAR=0 offset=00000000
    PBA: BAR=0 offset=00000000
    Capabilities: [100] Advanced Error Reporting <?>
    Capabilities: [140] Virtual Channel <?>
    Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
    Kernel driver in use: ath9k
    Kernel modules: ath9k

  2. #2
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    I don't think it is an issue with the ath9k module its self. I upgraded to wireless modules backported from kernel 3.1. No affect!
    Could be a library support issue in Ubuntu 10.04 or some config issue. I'll update as soon as XBMC has a standalone install of Eden 11 beta

    filename: /lib/modules/2.6.32-38-generic/updates/compat-wireless-3.1/ath9k.ko
    license: Dual BSD/GPL
    description: Support for Atheros 802.11n wireless LAN cards.
    author: Atheros Communications
    srcversion: B983C85B493CF14DAE9CE20
    alias: pci:v0000168Cd00000032sv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000030sv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Esv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Dsv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Csv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Bsv*sd*bc*sc*i*
    alias: pci:v0000168Cd0000002Asv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000029sv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000027sv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000024sv*sd*bc*sc*i*
    alias: pci:v0000168Cd00000023sv*sd*bc*sc*i*
    depends: ath9k_hw,mac80211,led-class,ath9k_common,ath,cfg80211,compat
    vermagic: 2.6.32-38-generic SMP mod_unload modversions 586
    parm: debugebugging mask (uint)
    parm: nohwcryptisable hardware encryption (int)
    parm: blink:Enable LED blink on activity (int)
    parm: btcoex_enable:Enable wifi-BT coexistence (int)

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    Are there other devices connecting to this access point that are 802.11b or g, but not 802.11n? That will slow it down considerably. Having 802.11b devices on an 802.11b/g access point has the same problem in that your 802.11g systems don't get their full throughput.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    I try not to give too bad of a time for not reading this before. The Access Point is set to 802.11n only and 5ghz. Well technically my router has two access points, its called simultaneous dual band. The "Livewire" SSID is 2.4 ghz and it's set to run 11g/n mode and the "Livefire" SSID is 5 ghz and it set to 11n only. I'm probably the only one that finds my SSID naming amusing. Like I said before my laptop connects at over 100 Mb/s to the 5 ghz AP. I can see this with the speed listed in iwconfig and with the speed of file transfers to my wired Ethernet desktop computer. I starting to see that software/library issue with Ubuntu 10.04. Because I can connect fast with the gui "Network Manger", but I use the iwlist scan command on my laptop it says the AP only does 54 Mb/s

  6. #5
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    So, the fast connect is probably connecting you with the Livewire SSID, and not the Livefire one... Well, you should be able to disable the connection to the Livewire SSID in the Linux network manager tool, so it only connects to the faster one.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #6
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    You need to work on reading comprehension. Forget I even mentioned the 2.4 ghz "Livewire" network, its only used by my Wii and iPods. All the devices mentioned 2 laptops, Home Theater Computer (the one that won't connect over 52 Mb/s) only connect to "Livefire" my 5 ghz 802.11n-only Network.

  8. #7
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    That may be the case, but the fact remains, that AP's (even multi-AP's like yours) are affected by slower connections that are simultaneously active on the network. Also, a 5GHz network, like your Livefire AP, is definitely affected by distance and intervening structures (walls, etc), much more so than your 2.4GHz 802.11b/g AP. As far as I'm concerned, you might benefit from changing the channel(s) that you operate on, but if you get a real 54mbps throughput on ANY of your devices, you are doing OK. The 5GHz signal attenuates much more rapidly over distance and with interference than the 2.4GHz one does.

    FWIW, I am an electrical engineer, and 20+ year member of the IEEE. I do this stuff for a living, though these days it seems I am mostly in software, although currently it is in the mobile phone business. Also, I used to teach these subjects. You indicate that some of your laptops that are further away (a MacBook, etc) get better speeds, and your HTPC with 6" antenna that is only 15 feet from the AP is only able to get 52mbps. What other electrical devices are in that area which may be interfering with the signal? Have you tried moving the system to near where the Mac is operating? Have you verified that the connected AP is the Livefire, and not the Livewire?

    In any case, I believe you need to look at physical causes of this problem before you start thinking it is a software problem. Yes, it may be a software problem, but until you eliminate all potential environmental causes, there is no way to tell. This is a situation where the scientific method needs to be applied, rigorously.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  9. #8
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    I get your point, but doesn't seem fit in this case. I even put it to the test. I set my 2.4ghz AP to N-Only too. ( Lost wifi to my phone, oh well ) I shutdown all other wireless devices, didn't change the speed to my HTPC. I'm pretty sure it's software, the wireless tools (iw, iwlist, iwconfig) don't ever list speeds anything over 54 Mb/s being possible. Hopefully I'll upgrade the system soon.

  10. #9
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    Ok. Thanks for doing the double-check. Nothing like eliminating possibilities to help focus on the REAL problem at hand. In my career I have seen too many good, but false, assumptions made about problem causes, but unless you eliminate other possible causes, Murphy states that what must be "obvious" will not be the case in truth.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  11. #10
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    Tried Ubuntu 11.10, still the same. It's something with connecting via command line. I booted a live CD and connected at 196 Mb/s
    This is the config I'm using:

    /etc/network/interfaces

    auto lo
    iface lo inet loopback

    auto wlan0
    iface wlan0 inet dhcp
    wpa-driver wext
    wpa-conf /etc/wpa_supplicant.conf

    /etc/wpa_supplicant.conf (not showing wpa keys)

    network={
    ssid="livefire"
    #psk="****"
    psk=*************
    }

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •