Find the answer to your Linux question:
Results 1 to 5 of 5
This is Linux Mint 12 64 bit on an HP Probook 6560 with a Broadcom BCM43224 network card. I've been through just about every thread there is regarding drivers but, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! MickeyRat's Avatar
    Join Date
    Feb 2012
    Posts
    9

    Question about rfkill


    This is Linux Mint 12 64 bit on an HP Probook 6560 with a Broadcom BCM43224 network card. I've been through just about every thread there is regarding drivers but, I'm coming to the conclusion that the driver isn't my problem.

    This laptop does have a wireless button but, it looks like the wireless is bocked no matter what I do with it. Here's what it does:

    Code:
    > rfkill list all
    0: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    1: hp-wifi: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    
    Press wireless button
    
    > rfkill list all
    0: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    1: hp-wifi: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    
    Turn wireless button off in BIOS.
    
    > rfkill list all
    0: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    1: hp-wifi: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    As expected pressing the button with it turned off in the BIOS has no effect. rfkill unblock all/wifi/wlan has no effect.

    My thinking is that drivers aren't going to effect that phy0 hard block and I need to be looking elsewhere. Is that correct? If it is correct, what should I be looking at?

    I'll keep digging if it can be drivers but, I've tried lots of different options including downloading the driver files and compiling them myself.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Did you try
    Code:
    rfkill unblock all
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined! MickeyRat's Avatar
    Join Date
    Feb 2012
    Posts
    9
    Quote Originally Posted by MikeTbob View Post
    Did you try
    Code:
    rfkill unblock all
    Yes, I did. I also did an rfkill unblock wifi and rfkill unblock wlan. None of them seemed to do anything. Thanks for the reply though.

    This is mostly speculation from what little I can glean that doesn't just say press the wireless button but, I think I may be dealing with a kernel problem. That said, there's not a lot I've been able to find that really says what can effect what rfkill says except the button. Eliminating the drivers would be great! I've already spent hours on the drivers to no avail.

  4. #4
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,996
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  5. #5
    Just Joined! MickeyRat's Avatar
    Join Date
    Feb 2012
    Posts
    9
    As always, I appreciate the reply.

    Those are driver threads and I've been through a ton of them but, there are a ton more I'm sure. There are some things in those I didn't try. However, as I understand it, a hard block in rfkill indicates that the kernel thinks the wireless is turned off by an actual external switch or a BIOS setting, etc. If that's right, it won't matter which drivers I load because it won't try to use them. What I'm really asking is whether a driver can cause that phy0 hard block.

    All I can find about rfkill is that it's checking on a status in the kernel. In the places where I found that, everything else went over my head in a hurry. The only other information says to toggle the switch and I've done that.

    It's not really kosher but, I may try cross posting this in the kernel forum. They might be the best ones to answer that question.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •