Find the answer to your Linux question:
Results 1 to 5 of 5
Hi guys, I've been working on this problem for a while. I'm trying to get my Android phone to scan for WiFi signals in an active mode. The biggest problem ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    16

    Android Scan for Wifi in active mode


    Hi guys,

    I've been working on this problem for a while. I'm trying to get my Android phone to scan for WiFi signals in an active mode.
    The biggest problem is I don't know how to accomplish this. I've read some where I could achieve this by calling iwlist scan as su. But I'm pretty sure it didn't scan actively because it took 1.2 seconds to complete a full scan on 11 channels.
    I'm hoping to scan WiFi signals within a range of 250-300ms. Because I found out scanning in an active mode would take 15ms per channel, with 11 channels that would take 165ms.

    Does anybody know how to achieve this?

    Info:
    Device: HTC Desire
    Kernel version: 2.6.35.8
    Wifi driver: bcm4329
    Wifi device: bcm4329

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    I for one would not want my Android device scanning constantly for wireless networks. This uses power and drains the battery and doing constant scans will deplete your battery in a very short amount of time.

    As to auto scans, you should be able to set this up under the setting for your phone/device but I do not think you can get continue scanning.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Apr 2012
    Posts
    16
    Battery drain is not an issue. The scan interval can't be set that simple. It is something that's set inside the driver. I've already forced Android to scan actively but there is still something overruling it. But can't find what's causing this.

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I think your best bet may be to check at the android forums.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #5
    Just Joined!
    Join Date
    Apr 2012
    Posts
    16
    I've already tried this, it looks like an Linux related issue. So I've tried it here also.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •